cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
6476
Views
5
Helpful
20
Replies
Beginner

RIP Routing not advertising

I am trying to get RIP Routing to advertise between 3 routers. I think my configuration ois correct but I am not sure. I am a beginner to the network world and have been checking out other threads but nothing seems to be helping. I am attaching my configs along with outputs from some commands. Can someone please steer me in the right direction?

Everyone's tags (3)
20 REPLIES 20

Re: RIP Routing not advertising

Hello, Ben.

Please write a diagram will all the addresses assigned per interface.

I guess you will find the first issue.

Second one is that RIP is not enabled on all the interfaces ( CORE:s0/1/0, CORE s0/3/1).

If you are just learning RIP, then use command network 0.0.0.0

Beginner

RIP Routing not advertising

I issued the network 0.0.0.0 command and rip routes are still not being advertised. And how exactly do you enable rip on specific interfaces?

VIP Advisor

RIP Routing not advertising

Hello

Richmond

========

no router rip

ip routing

router rip

version 2

no auo-summary

network 195.131.50.0

Erie

=====

no router rip

ip routing

router rip

version 2

no auo-summary

network 199.122.20.0

Core

======

Does the core device have reachablilty to both Richmond and Eire over its physical interfaces?

Also disable Automatic network summarization.

ip routing

router rip

version 2

no auo-summary

clear ip route *

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Rising star

RIP Routing not advertising

Ben,

For starts, I would suggest doing 'no auto' under the RIP routing process at the hub.

Erie

-----

!

interface Serial0/3/0

ip address 199.122.20.10 255.255.255.248

encapsulation ppp

!

I see that interface, as the only interface configured, with an IP address on that router, yet under RIP I see the following.

!

router rip

version 2

network 189.12.0.0

network 195.131.50.0

network 199.122.20.0

network 203.167.10.0

network 212.2.40.0

no auto-summary

!

I don't think the networks advertisd in bold really need to be advertised...

Richmond

--------------

Same thing as Erie, I see the following interface, as the only interface configured with an IP address.

!

interface Serial0/3/0

ip address 195.131.50.10 255.255.255.248

encapsulation ppp

But under RIP you are advertising all the networks.

Rising star

RIP Routing not advertising

Pdriver,

Damnit, got to it first hahahaha..

VIP Advisor

RIP Routing not advertising

Hello John

Apologies but i guess thats the beauty of these forums so many people will to help others!

res

Paul

Please don't forget to rate any posts that have been helpful.

Thanks.



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

RIP Routing not advertising

First off...Thank You guys.

I made the changes both of you explained but i still cannot get these router to see one another.

PDriver - yes the core router can see both the erie and richmond routers.

Hall of Fame Guru

RIP Routing not advertising

Ben

Assuming the core router can ping each of the other routers can you post -

1) "sh ip route" from all routers

2) RIP config from each router (not the whole config just the router bit if you can)

Beginner

RIP Routing not advertising

CoreR1#sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     189.12.0.0/16 is variably subnetted, 2 subnets, 2 masks
C       189.12.30.0/29 is directly connected, Serial0/3/0
C       189.12.30.10/32 is directly connected, Serial0/3/0
     195.131.50.0/24 is variably subnetted, 2 subnets, 2 masks
C       195.131.50.8/29 is directly connected, Serial0/1/0
C       195.131.50.10/32 is directly connected, Serial0/1/0
     199.122.10.0/29 is subnetted, 1 subnets
C       199.122.10.8 is directly connected, Serial0/3/1
     199.122.20.0/32 is subnetted, 1 subnets
C       199.122.20.10 is directly connected, Serial0/3/1
     203.167.10.0/24 is variably subnetted, 2 subnets, 2 masks
C       203.167.10.0/29 is directly connected, Serial0/0/0
C       203.167.10.10/32 is directly connected, Serial0/0/0
     212.2.40.0/29 is subnetted, 1 subnets
C       212.2.40.0 is directly connected, Serial0/2/0
     212.4.40.0/32 is subnetted, 1 subnets
C       212.4.40.10 is directly connected, Serial0/2/0
CoreR1#

!

router rip

version 2

no auto-summary

!

-------------------------------------------------

Erie#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     199.122.10.0/32 is subnetted, 1 subnets

C       199.122.10.9 is directly connected, Serial0/3/0

     199.122.20.0/29 is subnetted, 1 subnets

C       199.122.20.8 is directly connected, Serial0/3/0

!

router rip

version 2

network 199.122.20.0

no auto-summary

!

---------------------------------------------------------

Richmond#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area

       * - candidate default, U - per-user static route, o - ODR

       P - periodic downloaded static route

Gateway of last resort is not set

     195.131.50.0/24 is variably subnetted, 2 subnets, 2 masks

C       195.131.50.8/29 is directly connected, Serial0/3/0

C       195.131.50.9/32 is directly connected, Serial0/3/0

Richmond#

!

router rip

version 2

network 195.131.50.0

no auto-summary

!

Beginner

RIP Routing not advertising

and just so you guys know...there are other routers on this network and rip is not working for any of them. I just figured to use 3 instead of all of them to make it easier to troubleshoot. once I find the fix I will apply to the remaining routers

Hall of Fame Guru

RIP Routing not advertising

Ben

Okay, sorry but can you actually post the "sh run" for all three devices and attach them as you did in your original post.

Can you ping from the core router to each of the other routers ?

Jon

Beginner

Re: RIP Routing not advertising

Sorry Jon. The configs are below. Also yes I can ping all routers from the Core router.

CoreR1#sh run

Building configuration...

Current configuration : 1135 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname CoreR1

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/0/0

ip address 203.167.10.1 255.255.255.248

encapsulation ppp

clock rate 64000

!

interface Serial0/1/0

ip address 195.131.50.9 255.255.255.248

encapsulation ppp

clock rate 64000

!

interface Serial0/1/1

no ip address

shutdown

!

interface Serial0/2/0

ip address 212.2.40.1 255.255.255.248

encapsulation ppp

clock rate 64000

!

interface Serial0/2/1

no ip address

shutdown

!

interface Serial0/3/0

ip address 189.12.30.1 255.255.255.248

encapsulation ppp

clock rate 64000

!

interface Serial0/3/1

ip address 199.122.10.9 255.255.255.248

encapsulation ppp

clock rate 64000

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

no auto-summary

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Richmond>en

Richmond#sh run

Building configuration...

Current configuration : 678 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Richmond

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/3/0

ip address 195.131.50.10 255.255.255.248

encapsulation ppp

!

interface Serial0/3/1

no ip address

!

interface Vlan1

no ip address

shutdown

!

router rip

version 2

network 195.131.50.0

no auto-summary

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Baltimore#sh run

Building configuration...

Current configuration : 674 bytes

!

version 12.4

no service timestamps log datetime msec

no service timestamps debug datetime msec

no service password-encryption

!

hostname Baltimore

!

!

!

!

!

!

!

!

!

!

!

!

!

!

spanning-tree mode pvst

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

shutdown

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

shutdown

!

interface Serial0/3/0

ip address 212.4.40.10 255.255.255.248

encapsulation ppp

!

interface Serial0/3/1

no ip address

shutdown

!

interface Vlan1

no ip address

shutdown

!

router rip

network 212.2.40.0

no auto-summary

!

ip classless

!

!

!

!

!

!

!

line con 0

!

line aux 0

!

line vty 0 4

login

!

!

!

end

Highlighted
Hall of Fame Guru

Re: RIP Routing not advertising

Ben

On the core router you need to add network statements under your RIP config for the networks used to connect to the other two routers.

Jon

Rising star

Re: RIP Routing not advertising

Jon,

I agree.

Ben if you look at the below config, you have network statements setup previously for your RIP networks on your CORE router.

!

router rip

version 2

network 189.12.0.0

network 195.131.20.0

network 199.122.20.0

network 203.167.10.0

network 212.2.40.0

!

For the two spokes to come up Erie and Richmond, you need to add the following.

network 199.122.20.0

network 195.131.50.0

The others you don't technically have to add, if the're are no routers running RIP connected to them, but if you want reachability for those networks within RIP, you will need to add those network commands as well.

*I was just joking with you pdriver. I was thinking when I was typing all that above, I bet someone is doing the same thing as me haha*

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards