cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1516
Views
0
Helpful
18
Replies
Laith_IQ
Beginner

RIP with 176.16.X.X

Hello,

 

see the exhibit please.

I have made a network with 3 routers, 3 sub-networks with
1-  176.16.0.0/24
2-  176.16.1.0/24
3.  176.16.2.0/24
and the routers networks
1-  10.10.10.0/30
2-  10.10.10.4/30
3-  10.10.10.8/30

I used RIP as a daynamic router protocol.

issue:

If i add network 176.16.1.0 & network 176.16.2.0 to the rip route then if i do a show to my ip route i see only the 176.16.0.0.
In other words: the router convert the networks 176.16.1.0 & 176.16.2.0 to 176.16.0.0 becaus they are according to the router a prive neworks 176.16.x.x/16.


if i change the ip range to 192.168.x.x/24 then i have aconnection , but i should use the other range of 176.16.X.X/24


any solution?

2 ACCEPTED SOLUTIONS

Accepted Solutions
paul driver
VIP Mentor

Hello

As others have stated rip is a class full protocol as such it will by default auto summarise into class-full networks(version 1-2)  sowon’t take into account the hosts bit of the network  which can cause issue if your spokes have networks with it this summary

 

in version 2 rip apply the -“No auto summary” under the rip process and then it should advertise the correct network

 

res

paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post

Dear all,


I finally found it. this has to do with packet tracer.


1- I have turned off all the router
2-one is turned on then I do my configuration on this router.
3- then I start the 2nd ..etc.
however, the following config is executed on all routers.

router rip
version 2
netwwork x.x.x.x. (add your network)
netwwork x.x.x.x. (add your network)
no car-numbery
passive interface {interface name bv g0 / 0}
defualt -information originate
exit
exit
copy run st

 

thanks for the interesting answers

View solution in original post

18 REPLIES 18
acampbell
Advocate

Sounds like you are set for classful routing.
Can you try adding to your global config

ip classless
Regards, Alex. Please rate useful posts.

thanks for the feedback

!
!
!
Router(config)#no ip classless
^
% Invalid input detected at '^' marker.
cofee
Contributor

Can you confirm if you are using RIP version 2?

 

router rip

version 2

!

thanks for the feedback.
i tried v1 & v2 ...the same result

thanks for the feedback.
im always triad v1 & v2 ...the same result

Joseph W. Doherty
Hall of Fame Expert

I recall (?) Cisco's RIP, including Cisco's RIPv2, does classful summerization by default. I also recall (?) I didn't find a way to override this.
Rolf Fischer
Engager

Hello,

 

Joseph is correct, even classless RIPv2 auto-summarizes "subprefixes to the classful network boundary when crossing classful network boundaries" by default (weird, I know...).

 


if i change the ip range to 192.168.x.x/24 then i have aconnection , (...)


This is because the /24 is already the classful network boundary for a class-C network. A 192.168.x.x/30 network, for instance, would also be auto-summarized to the /24 classful network boundary.

"no auto-summary" under the RIP processes should do the trick.

 

HTH

Rolf

Router(config)#router rip
Router(config-router)#no au
Router(config-router)#no auto-summary
Router(config-router)#ne
Router(config-router)#network 10.10.10.0 255.255.255.252
^
% Invalid input detected at '^' marker.

Router(config-router)#network 10.10.10.0
Router(config-router)#network 10.10.10.8
Router(config-router)#network 176.16.2.0
Router(config-router)#exit
Router(config)#exit
Router#show ip prot
Router#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 27 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 1 2 1
Serial0/0/1 1 2 1
GigabitEthernet0/0 1 2 1
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
176.16.0.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
Distance: (default is 120)

In RIP, the network commnad doesn't have a wildcard- or subnetmask option; this also applies to v2.

However, with auto-summary disabled, the router should now advertise the prefixes with the correct masks and you should no longer see classful summary routes.

Router(config)#no router rip
Router(config)#
Router(config)#
Router(config)#
Router(config)#ro
Router(config)#router r
Router(config)#router rip
Router(config-router)#aut
Router(config-router)#auto-summary dis
Router(config-router)#auto-summary ?
<cr>
Router(config-router)#no auto-summary
Router(config-router)#net
Router(config-router)#network 10.10.10.8
Router(config-router)#network 10.10.10.4
Router(config-router)#network 176.16.1.0
Router(config-router)#exit
Router(config)#exit
Router#
%SYS-5-CONFIG_I: Configured from console by console

Router#show ip pro
Router#show ip protocols
Routing Protocol is "rip"
Sending updates every 30 seconds, next due in 8 seconds
Invalid after 180 seconds, hold down 180, flushed after 240
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: rip
Default version control: send version 1, receive any version
Interface Send Recv Triggered RIP Key-chain
Serial0/0/0 1 2 1
Serial0/0/1 1 2 1
GigabitEthernet0/0 1 2 1
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks:
10.0.0.0
176.16.0.0
Passive Interface(s):
Routing Information Sources:
Gateway Distance Last Update
10.10.10.10 120 00:00:01
Distance: (default is 120)
Router#

Is there something you want to tell us?

Yes, the no auto- summery didn't change the situation.

Could you provide the "show ip route" output of the neighbor router(s) to show us the routes that are still auto-summarized to classful networks?

Or perhaps you could provide some clarification if I misunderstood the problem you're trying to fix?

paul driver
VIP Mentor

Hello

As others have stated rip is a class full protocol as such it will by default auto summarise into class-full networks(version 1-2)  sowon’t take into account the hosts bit of the network  which can cause issue if your spokes have networks with it this summary

 

in version 2 rip apply the -“No auto summary” under the rip process and then it should advertise the correct network

 

res

paul



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future

View solution in original post