10-23-2017 04:50 PM - edited 03-05-2019 09:21 AM
Hi!
So I am trying to set up the attached topology and I have to say that I have no clue what I am doing wrong.
The problem I have is that I've been trying to ping from R1 to R3 with no success. I've kind of understood that the problem lies in R2 because I can't ping from R1 to the "internet" or the Lo0 either. But exactly what the problem is, I don't know.
I discovered the problem when I checked to see if R1 and R3 had learned the "Gateway of last resort" after the "default-information originate" command which they had not.
How do I upload packet tracer files here? I thought it would be much easier to get help if you could download my file but it wouldn't let me upload ".pkt" files...
If someone could help me and tell me what I'm doing wrong I would be so happy, (test on wednesday..)
I will just post the running config until I can upload the pkt file.
#R1
Building configuration...
Current configuration : 1395 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R1
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524XZCO
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.21
encapsulation dot1Q 21
ip address 192.168.21.1 255.255.255.0
!
interface GigabitEthernet0/1.23
encapsulation dot1Q 23
ip address 192.168.23.1 255.255.255.0
!
interface GigabitEthernet0/1.99
encapsulation dot1Q 99
ip address 192.168.99.1 255.255.255.0
!
interface Serial0/1/0
ip address 172.16.1.1 255.255.255.252
clock rate 128000
!
interface Serial0/1/1
no ip address
clock rate 2000000
shutdown
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface GigabitEthernet0/1
passive-interface Serial0/1/0
network 172.16.0.0
network 192.168.21.0
network 192.168.23.0
network 192.168.99.0
default-information originate
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
password cisco
logging synchronous
login
!
line aux 0
!
line vty 0 4
password cisco
logging synchronous
login
!
!
!
end
#R2
Building configuration...
Current configuration : 1205 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R2
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX15245624
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
!
interface GigabitEthernet0/0
ip address 209.165.200.233 255.255.255.248
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
ip address 172.16.1.2 255.255.255.252
!
interface Serial0/1/1
ip address 172.16.2.1 255.255.255.252
clock rate 128000
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface Serial0/1/0
passive-interface Serial0/1/1
passive-interface Loopback0
network 10.0.0.0
network 172.16.0.0
default-information originate
no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 209.165.200.238
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
password cisco
logging synchronous
login
!
line aux 0
!
line vty 0 4
password cisco
logging synchronous
login
!
!
!
end
#R3
Building configuration...
Current configuration : 1290 bytes
!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname R3
!
!
!
enable secret 5 $1$mERr$9cTjUIEqNGurQiFU.ZeCi1
!
!
!
!
!
!
no ip cef
no ipv6 cef
!
!
!
!
license udi pid CISCO1941/K9 sn FTX1524XVNI
!
!
!
!
!
!
!
!
!
!
!
spanning-tree mode pvst
!
!
!
!
!
!
interface Loopback4
ip address 192.168.4.1 255.255.255.0
!
interface Loopback5
ip address 192.168.5.1 255.255.255.0
!
interface Loopback6
ip address 192.168.6.1 255.255.255.0
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
shutdown
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/1/0
no ip address
clock rate 2000000
shutdown
!
interface Serial0/1/1
ip address 172.16.2.2 255.255.255.252
!
interface Vlan1
no ip address
shutdown
!
router rip
version 2
passive-interface Serial0/1/1
passive-interface Loopback4
passive-interface Loopback5
passive-interface Loopback6
network 172.16.0.0
network 192.168.4.0
network 192.168.5.0
network 192.168.6.0
no auto-summary
!
ip classless
!
ip flow-export version 9
!
!
!
!
!
!
!
line con 0
password cisco
logging synchronous
login
!
line aux 0
!
line vty 0 4
password cisco
logging synchronous
login
!
!
!
end
Solved! Go to Solution.
10-23-2017 05:34 PM - edited 10-23-2017 05:49 PM
Hi
If you configure passive-interface, these interface will not receive routing information.
Passive-interface is recommended for the interface associated to the LAN's only, you could use it for loopbacks as well but it is optional.
The RIP configuration should be:
R1
router rip
version 2
passive-interface GigabitEthernet0/1
network 172.16.0.0
network 192.168.21.0
network 192.168.23.0
network 192.168.99.0
no auto-summary
R2
router rip
version 2
passive-interface Loopback0
network 10.0.0.0
network 172.16.0.0
default-information originate
no auto-summary
R3
router rip
version 2
network 172.16.0.0
network 192.168.4.0
network 192.168.5.0
network 192.168.6.0
no auto-summary
For NAT on R2, it should be:
interface GigabitEthernet0/0
ip address 209.165.200.233 255.255.255.248
ip nat outside
duplex auto
speed auto
!
interface Serial0/1/0
ip address 172.16.1.2 255.255.255.252
ip nat inside
!
interface Serial0/1/1
ip address 172.16.2.1 255.255.255.252
ip nat inside
clock rate 128000
ip access-list standard MY-LAN
(Include your LAN here)
permit 192.168.4.0 0.255.255.255
permit 192.168.5.0 0.255.255.255
permit 192.168.6.0 0.255.255.255
permit 192.168.21.0 0.255.255.255
permit 192.168.23.0 0.255.255.255
permit 192.168.99.0 0.255.255.255
ip nat inside source list MY-LAN interface g0/0 overload
Hope it is useful
:-)
10-23-2017 05:34 PM - edited 10-23-2017 05:49 PM
Hi
If you configure passive-interface, these interface will not receive routing information.
Passive-interface is recommended for the interface associated to the LAN's only, you could use it for loopbacks as well but it is optional.
The RIP configuration should be:
R1
router rip
version 2
passive-interface GigabitEthernet0/1
network 172.16.0.0
network 192.168.21.0
network 192.168.23.0
network 192.168.99.0
no auto-summary
R2
router rip
version 2
passive-interface Loopback0
network 10.0.0.0
network 172.16.0.0
default-information originate
no auto-summary
R3
router rip
version 2
network 172.16.0.0
network 192.168.4.0
network 192.168.5.0
network 192.168.6.0
no auto-summary
For NAT on R2, it should be:
interface GigabitEthernet0/0
ip address 209.165.200.233 255.255.255.248
ip nat outside
duplex auto
speed auto
!
interface Serial0/1/0
ip address 172.16.1.2 255.255.255.252
ip nat inside
!
interface Serial0/1/1
ip address 172.16.2.1 255.255.255.252
ip nat inside
clock rate 128000
ip access-list standard MY-LAN
(Include your LAN here)
permit 192.168.4.0 0.255.255.255
permit 192.168.5.0 0.255.255.255
permit 192.168.6.0 0.255.255.255
permit 192.168.21.0 0.255.255.255
permit 192.168.23.0 0.255.255.255
permit 192.168.99.0 0.255.255.255
ip nat inside source list MY-LAN interface g0/0 overload
Hope it is useful
:-)
10-23-2017 06:44 PM
10-23-2017 08:36 PM
Hi
You are welcome, have a good day!
:-)
02-19-2018 03:20 PM
02-19-2018 03:39 PM - edited 02-19-2018 03:43 PM
Hi,
The default-information originate command is used to advertise a default route to other routers running the same protocol dynamically otherwise we should create default static routes on each router pointing to the exit or edge router.
As it can be seen on the shared configuration, R2 is the one advertising a default route via RIP, take in consideration R2 must have a default static route pointing to Internet otherwise the unknow requests will be discarded.
:-)
02-19-2018 03:45 PM
02-19-2018 03:46 PM
That is correct
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide