cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
351
Views
0
Helpful
11
Replies
Highlighted
Beginner

Route Internet through Cisco 3925

Greetings network pros,

I'm a bit of a rookie and I am sure I am missing a simple command/configuration.

I have Cisco 3925 router.  Gi0/0 is from the modem (DHCP IP).  Gi0/1 is configured to hand out 172.16.1.X IPs.  Gi0/2 is configured to hand out 172.16.10.X IPs.

I cannot find the appropriate config to allow internet traffic to/from gi0/0 and gi0/1 and gi0/2.

I've also attached my sh run and sh run int.  I've removed most of the configurations to start fresh and not get anything mixed up.

 

EdCenter#sh ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 unassigned YES DHCP up up
GigabitEthernet0/1 172.16.1.1 YES manual up up
GigabitEthernet0/2 172.16.10.1 YES manual up up
GigabitEthernet0/3 unassigned YES NVRAM administratively down down
NVI0 unassigned NO unset up up

11 REPLIES 11
Highlighted
VIP Expert

Hello,

 

make the changes/additions marked in bold:

 

EdCenter#sh run
Building configuration...

Current configuration : 1649 bytes
!
! Last configuration change at 15:55:50 UTC Fri Nov 13 2020
version 15.2
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname EdCenter
!
boot-start-marker
boot-end-marker
!
!
enable secret 4 A0n9oGknEXrcLvatOfRaGBT4qXXISB.6Kao0MS0F8lw
!
no aaa new-model
!
ip cef
!
!
--> ip dhcp excluded-address 172.16.1.1
--> ip dhcp excluded-address 172.16.10.1
!
ip dhcp pool WIFI
network 172.16.1.0 255.255.255.0
default-router 172.16.1.1
dns-server 71.10.216.1 71.10.216.2
!
ip dhcp pool TESTING
network 172.16.10.0 255.255.255.0
default-router 172.16.10.1
dns-server 71.10.216.1 71.10.216.2
!
no ip domain lookup
no ipv6 cef
multilink bundle-name authenticated
!
license udi pid C3900-SPE200/K9 sn FOC171400QJ
!
interface GigabitEthernet0/0
description INTERNET
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description WIFI
ip address 172.16.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
description TESTING
ip address 172.16.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/3
no ip address
shutdown
duplex auto
speed auto
!
--> no ip default-gateway 69.144.208.145
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
--> ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
!
--> access-list 1 permit 172.16.1.0 0.0.0.255
--> access-list 1 permit 172.16.10.0 0.0.0.255
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

Highlighted

Thank you for the reply. I made the appropriate changes, but still can't get internet from gi0/0 to the other interfaces.  I've attached an updated sh run.

Highlighted

The updated show run looks appropriate. Can you post the output of show ip interface brief and of show ip route

HTH

Rick
Highlighted

Thanks for the reply!  Both attached.

Highlighted
Rising star

Can you ping the internet from the router? What is the DHCP address for that interface (sh ip int brief). Make sure you have the DHCP address on that interface and that the router can access the internet. 

Ex.:

ping 1.1.1.1 source 172.16.10.1.

Highlighted

Thanks for the reply.  I am unable to ping beyond the router.  Gi0/0 is configured as DHCP and doesnt have an IP assigned.  The modem has a good connection as I've tested with a small business router.

 

edit:  after some reading, is it possible that i need to set routes from GI0/1 and 2 over to GI0/0?

ip route 172.16.1.1 255.255.255.255 gi0/0 dhcp

ip route 172.16.10.1 255.255.255.255 gi0/0 dhcp

Highlighted

Hello,

 

what exactly is connected to interface GigabitEthernet0/0 ?

Highlighted

ISP modem

Highlighted

Thanks for the additional information. You asked "is it possible that i need to set routes from GI0/1 and 2 over to GI0/0?" and the answer is that no you do not need to set routes for them. They should automatically be inserted into the routing table as locally connected routes.

 

The output that you posted indicates clearly that the main problem here is that G0/0 does not have an IP address. I am not sure why that is the case, but this is the main problem. Can you check the connection from the router to the ISP? Make sure it is securely plugged in on both ends. Perhaps try a different cable? 

 

 

HTH

Rick
Highlighted

Thanks for the reply Rick.  I currently have a Cisco small business router installed and vlan'd out to handle 172.16.1.X and 172.16.10.X without any issue.  Internet is passing through no problem to both vlans/networks.

 

I was having issues with the ISP's modem and the static IP they had assigned.  They reconfigured the modem to assign IPs dynamically this morning.  

Highlighted

Hello,

 

sounds like a problem with the ISP modem. Actually, the fastest way to resolve this is probably to call the ISP and check what exactly they did, and if maybe the MAC address of the previously installed device was retained. Either way, I would start out by rebooting the ISP modem.