cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
5541
Views
0
Helpful
11
Replies

Route-Map not Seeing DHCP Next-Hop

Ed Melendez
Level 1
Level 1

I have a 2801 with dual ISP connections, and I have configured route-maps to direct voice traffic over ISP1 (working just fine), and I'm attempting send all other traffic over ISP2 (traffic is load-balancing instead).  The connection to ISP2 is DHCP, and I have configured a route-map to route this traffic using the 'ip next-hop dynamic dhcp' command, but when I look at the route-map, it states the following:

ip next-hop dynamic dhcp - current value is UNKNOWN

Is there something that I need to enable in order to see the next-hop, and properly send traffic over the ISP2 connection?

Configured:

route-map TrafficSplit permit 10

match ip address VoIPNetwork

set ip precedence priority

set ip next-hop XXX.XXX.XXX.XXX

!

route-map TrafficSplit permit 20

match ip address LocalNet

set ip next-hop dynamic dhcp

Show Output:

route-map TrafficSplit, permit, sequence 10

  Match clauses:

    ip address (access-lists): VoIPNetwork

  Set clauses:

    ip precedence priority

    ip next-hop XXX.XXX.XXX.XXX

  Policy routing matches: 12772 packets, 10978067 bytes

route-map TrafficSplit, permit, sequence 20

  Match clauses:

    ip address (access-lists): LocalNet

  Set clauses:

    ip next-hop dynamic dhcp - current value is UNKNOWN

  Policy routing matches: 997611 packets, 1398419458 bytes

Cisco IOS Software, 2801 Software (C2801-ADVENTERPRISEK9-M), Version 12.4(22)YB8, RELEASE SOFTWARE (fc1)

Thanks,

-Ed

1 Accepted Solution

Accepted Solutions

Glad to help Ed, and thanks for the update.

Can you please mark the threat as resolved, so other people can benefit from it?

Reza

View solution in original post

11 Replies 11

Reza Sharifi
Hall of Fame
Hall of Fame

Ed,

Can you do a "sh ip arp" on your device and figure out the IP address that is assigned to you by provider2?  Then instead of set ip next-hop dynamic dhcp use set ip next-hop XXX.XXX.XXX.XXX  and see if traffic is being divided correctly.

obviously, this would not be a permanent solution, but will tell us if the issue is the DHCP statement in the route map or not.

HTH

Ed

I would suggest a somewhat different approach for you. Instead of having two route maps you might have one route map for the Voice traffic through ISP1 and have a default route to ISP 2 for all other traffic. If you want failover then a floating static default route should be possible.

HTH

Rick

Sent from Cisco Technical Support iPad App

HTH

Rick

Reza-

Great idea... not sure why I didn't think of that!

When I put the next-hop as suggested, the traffic does appear to go as planned.  All of the voice traffic over ISP1, and all the other over ISP2... so the route-map is definitely not seeing the DHCP assigned gateway.

An additional thing I noticed is that when I checked my default routes (show ip route), the DHCP gateway was no longer listed (it was previously).

When I Initially Checked:

S*   0.0.0.0/0 [1/0] via XXX.XXX.XXX.XXX

After Bouncing the DHCP Interface:

S*   0.0.0.0/0 [1/0] via XXX.XXX.XXX.XXX

               [1/0] via XXX.XXX.XXX.XXX

So there definitely seems to be an issue with DHCP and it's gateway address... any ideas???

-Ed

P.S. - You can see the DHCP gateway by using the 'show dhcp lease' command.

Hi Ed,

As long as the IP address you are getting from your ISP2 is dynamic, why dont you sent the interface instead of IP address in command set ip next-hop.


Please rate the helpfull posts.
Regards,
Naidu.

Hi Naidu,

Specifying an interface is not an option:

have a look:

Switch(config-route-map)#set ip next-hop ?

  A.B.C.D              IP address of next hop

  dynamic              application dynamically sets next hop

  in-vrf               VRF for VPNv4 nexthop

  peer-address         Use peer address (for BGP only)

  verify-availability  Verify if nexthop is reachable

Switch(config-route-map)#set ip next-hop

The only set interface I see is under interface and not ip:

Switch(config-route-map)#set interface ?

  Async               Async interface

  Auto-Template       Auto-Template interface

  BVI                 Bridge-Group Virtual Interface

  CTunnel             CTunnel interface

  Dialer              Dialer interface

  FastEthernet        FastEthernet IEEE 802.3

  Filter              Filter interface

  Filtergroup         Filter Group interface

  GigabitEthernet     GigabitEthernet IEEE 802.3z

  GroupVI             Group Virtual interface

  Lex                 Lex interface

  Loopback            Loopback interface

  Null                Null interface

  Port-channel        Ethernet Channel of interfaces

  Portgroup           Portgroup interface

  Pos-channel         POS Channel of interfaces

  TenGigabitEthernet  Ten Gigabit Ethernet

  Tunnel              Tunnel interface

  Vif                 PGM Multicast Host interface

  Virtual-Template    Virtual Template interface

  Virtual-TokenRing   Virtual TokenRing

  Vlan                Catalyst Vlans

  fcpa                Fiber Channel

Switch(config-route-map)#set interface

HTH

Ed,

Looking at the Command Reference Guide, it indicates that this command was integrated in IOS 12.3(8)T and 15.0(1)M.

Looking at your verstion, you are not running T revision.  So, I am wondering if an upgrade to T or 15 could resolve the issue. If none of these help, then the easiest solution might be to request a static IP from the ISP.

HTH

I'm not sure I see the correlation between it being in a 'T' revision, and the revision I'm running now.  If the command is present it should function as expected.  I was thinking that this might be a bug with the way it's behaving.

I'm fine with upgrading, but I'd like to know that it will resolve the issue, and that this is in fact not normal behavior.

Thanks Reza.

Problem resolved by upgrading to Version 12.4(25f)... thanks for everyone's input.

-Ed

Glad to help Ed, and thanks for the update.

Can you please mark the threat as resolved, so other people can benefit from it?

Reza

JS57
Level 1
Level 1

This is an 8 year old question, but thw answer will save you time and grief in solving the router-map next-hop dynamic dhcp issue.

 

I found that rebooting the router after configuring "next-hop dynamic dhcp" in a route-map will pull the gateway from the dhcp source.

 

This makes sense since there is no command to tell the route-map to make a dhcprequest for a gateway until a reboot occurs.  Works after initial reboot and all subsequent reboots.  Tested on Cisco 891, 881, 871, 1841s with 12.x and 15.x codes.

 

This is absolutely correct, in fact issuing "release dhcp gi0/x" works as well. However it still pulls in the same dhcp settings for both statements. 

before

route-map PBR, permit, sequence 10
Match clauses:
ip address (access-lists): 101
Set clauses:
ip next-hop dynamic dhcp - current value is 47.185.16.1
default interface GigabitEthernet0/1
Policy routing matches: 86673 packets, 13061504 bytes
route-map PBR, permit, sequence 20
Match clauses:
ip address (access-lists): 102
Set clauses:
ip next-hop self
ip next-hop dynamic dhcp - current value is 47.185.16.1
default interface GigabitEthernet0/2
Policy routing matches: 9173 packets, 782973 bytes

 

After

INET-2921-RT#sh route-map PBR
route-map PBR, permit, sequence 10
Match clauses:
ip address (access-lists): 101
Set clauses:
ip next-hop dynamic dhcp - current value is 35.134.112.1
default interface GigabitEthernet0/1
Policy routing matches: 86673 packets, 13061504 bytes
route-map PBR, permit, sequence 20
Match clauses:
ip address (access-lists): 102
Set clauses:
ip next-hop self
ip next-hop dynamic dhcp - current value is 35.134.112.1
default interface GigabitEthernet0/2
Policy routing matches: 9173 packets, 782973 bytes

 

I am still working on this problem. If anyone has any new input please let me know. 

 

My Config: 

ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/1 dhcp 10 (this needs to be removed ultimately, but allows my internet to work currently) 
!
ip sla auto discovery
ip sla 1
icmp-echo 47.185.16.1 source-interface GigabitEthernet0/1
ip sla schedule 1 life forever start-time now
!
route-map PBR permit 10
match ip address 101
set ip next-hop dynamic dhcp
set default interface GigabitEthernet0/1
!
route-map PBR permit 20
match ip address 102
set ip next-hop dynamic dhcp
set default interface GigabitEthernet0/2
!
route-map NAT_ISP2 permit 10
match ip address 102
match interface GigabitEthernet0/2
!
route-map NAT_ISP1 permit 10
match ip address 101
match interface GigabitEthernet0/1
!

 

Thank you! 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card