cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
734
Views
0
Helpful
8
Replies
Beginner

route problem with GLBP

Hi everybody,

I'm actually studying CCNP route/switch certification and I have a question with the topology below.

I try to understand the mechanism of the GLBP protocol. So I made a real lab with some gears.

The following problem is that R3 have 2 defaults route to reach the network 192.168.200.x.

Once goes to Serial 1/1, the other on Serial 1/0.

When I try to ping the host R4 (192.168.200.100) from the serial 1/1 interface it's work.

But it's doesn't work from the serial 1/0. It's seem I have a routing problem. How I can fix that ?

On the other hand, host R4 can reach the loopback interface of R3;

I copy/past some result of command just below the scheme.



R4#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.200.253 86 0007.b400.0102 ARPA FastEthernet0/0

The forwarding router for host R4 is R2

R3#traceroute 192.168.200.100 source loopback 0

Type escape sequence to abort.
Tracing the route to 192.168.200.100

1 172.16.2.1 8 msec
172.16.1.1 8 msec
172.16.2.1 8 msec
2 192.168.200.100 8 msec 8 msec *

R3#traceroute 192.168.200.100 source serial 1/1

Type escape sequence to abort.
Tracing the route to 192.168.200.100

1 172.16.2.1 8 msec * 8 msec
2 192.168.200.100 8 msec 8 msec *

R3#traceroute 192.168.200.100 source serial 1/0

Type escape sequence to abort.
Tracing the route to 192.168.200.100

1 *
172.16.1.1 8 msec *
2 * * *
3 * * *
4 * * *
5 * * *
6 * * *

8 REPLIES 8
VIP Expert

Hi,

Hi,

Can you post "sh run" and "sh ip route" from r3?

Also, on r3, can you try the following and test again?

config t

no ip route 0.0.0.0 0.0.0.0 s1/0

no ip route 0.0.0.0 0.0.0.0 s1/0

ip route 0.0.0.0 0.0.0.0 172.16.1.1

ip route 0.0.0.0 0.0.0.0 172.16.2.1 100

HTH

Beginner

Hi reza,Thanks for your time

Hi reza,

Thanks for your time :)

Please find below the results of the "sh run" and "sh ip route" commands on R3 before the modification.

And more below, the results after the modification with your proposition.

I understand the metric of 100 for the second default route, but, how I can do if I want to do load-balancing between my two links towards R2 and R1 ?
I just would like to load balance the traffic from R3 to the network 192.168.200.0 between my two links. I would to use both of them. It's possible ?

R3 "sh ip route"

R3#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

S* 0.0.0.0/0 is directly connected, Serial1/1
is directly connected, Serial1/0
3.0.0.0/32 is subnetted, 1 subnets
C 3.3.3.3 is directly connected, Loopback0
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.0.0/24 is directly connected, FastEthernet0/0
L 10.0.0.3/32 is directly connected, FastEthernet0/0
172.16.0.0/16 is variably subnetted, 4 subnets, 3 masks
C 172.16.1.0/30 is directly connected, Serial1/0
L 172.16.1.2/32 is directly connected, Serial1/0
C 172.16.2.0/24 is directly connected, Serial1/1
L 172.16.2.2/32 is directly connected, Serial1/1



R3 "sh run"

R3#sh run
Building configuration...


Current configuration : 1329 bytes
!
! Last configuration change at 10:21:33 UTC Mon Dec 5 2016
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot system flash:c2800nm-advipservicesk9-mz.150-1.M4.bin
boot-end-marker
!
!
no aaa new-model
!
!
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO2811 sn FCZ131271CA
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
!
interface FastEthernet0/0
ip address 10.0.0.3 255.255.255.0
duplex auto
speed auto
!
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
!
!
interface Serial1/0
ip address 172.16.1.2 255.255.255.252
clock rate 128000
!
!
interface Serial1/1
ip address 172.16.2.2 255.255.255.0
clock rate 128000
!
!
interface Serial1/2
no ip address
!
!
interface Serial1/3
no ip address
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 0.0.0.0 0.0.0.0 Serial1/0
ip route 0.0.0.0 0.0.0.0 Serial1/1
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
end

And here, the results after I changed the modification with your commands.

R3#traceroute 192.168.200.100 source serial 1/0

Type escape sequence to abort.
Tracing the route to 192.168.200.100
1 172.16.1.1 8 msec 8 msec 8 msec
2 192.168.200.100 8 msec 8 msec *
R3#traceroute 192.168.200.100 source loopback 0
Type escape sequence to abort.
Tracing the route to 192.168.200.100
1 172.16.1.1 8 msec 8 msec 8 msec
2 192.168.200.100 8 msec 8 msec *

VIP Expert

Hi,

Hi,

So, it appears that the trace route is taking the correct path and not looping as it was it before (see below from your first post).

Type escape sequence to abort.
Tracing the route to 192.168.200.100

1 172.16.2.1 8 msec
172.16.1.1 8 msec
172.16.2.1 8 msec
2 192.168.200.100 8 msec 8 msec *

Now, does trace route from r4 to 3.3.3.3 take the correct path (r1)?

Can you also post "sh run" from r1 and r2?

HTH

Beginner

Hi,

Hi,

Yes is taking the correct path for all of my computers (SW3 and R4).

But, how I can do if I want to do load-balancing between my two links towards R2 and R1 ?

I would to use both of them. It's possible ?

I just would like to load balance the traffic from R3 to the network 192.168.200.0 between my two links.

Please see below the results of the "traceroute" and "sh arp" commands from R4, SW3 and SW1;

And the results of the "sh run" command for R1 and R2

SW1 - traceroute toward 3.3.3.3
SW1#traceroute 3.3.3.3
Type escape sequence to abort.

Tracing the route to 3.3.3.3

1 192.168.200.250 8 msec 0 msec 0 msec
2 172.16.2.2 9 msec * 8 msec
SW1 - sh arp
SW1#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 172.31.31.254 - 0016.c80d.7244 ARPA Vlan30
Internet 192.168.200.250 36 001c.58b9.3aa9 ARPA Vlan200
Internet 192.168.200.251 155 001b.5443.6880 ARPA Vlan200
Internet 192.168.200.253 1 0007.b400.0102 ARPA Vlan200
R4 – traceroute toward 3.3.3.3
R4#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3

1 192.168.200.251 0 msec 0 msec 4 msec
2 172.16.1.2 8 msec * 8 msec
R4 - sh arp
R4#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 192.168.200.100 - 0024.1402.9750 ARPA FastEthernet0/0
Internet 192.168.200.253 3 0007.b400.0101 ARPA FastEthernet0/0
Internet 192.168.200.254 21 0016.c80d.7241 ARPA FastEthernet0/0
SW3 – traceroute toward 3.3.3.3
SW3#traceroute 3.3.3.3
Type escape sequence to abort.
Tracing the route to 3.3.3.3

1 192.168.200.250 0 msec 0 msec 0 msec
2 172.16.2.2 8 msec * 9 msec
SW3 – sh arp
SW3#sh arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 3.3.3.3 194 0007.b400.0102 ARPA Vlan200
Internet 192.168.200.254 5 0016.c80d.7241 ARPA Vlan200
Internet 172.16.1.2 6 0007.b400.0101 ARPA Vlan200
Internet 192.168.200.100 9 0024.1402.9750 ARPA Vlan200
Internet 192.168.200.103 - 0016.474c.90c1 ARPA Vlan200
R1 - sh run
R1#sh run
Building configuration...

Current configuration : 1184 bytes
!
! Last configuration change at 22:48:28 UTC Mon Dec 5 2016
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
license udi pid CISCO2811 sn FCZ111870QZ
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address 192.168.200.251 255.255.255.0
duplex auto
speed auto
glbp 1 ip 192.168.200.253
glbp 1 priority 150
!
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
!
interface Serial0/2/0
no ip address
shutdown
clock rate 2000000
!
!
interface Serial0/3/0
ip address 172.16.1.1 255.255.255.0
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 3.3.3.0 255.255.255.0 172.16.1.2
ip route 192.168.10.0 255.255.255.0 192.168.200.254
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password xdtex
login
!
scheduler allocate 20000 1000
end
R2 - sh run
R2#sh run
Building configuration...

Current configuration : 1158 bytes
!
! Last configuration change at 16:40:58 UTC Fri Dec 2 2016
!
version 15.0
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
!
!
dot11 syslog
ip source-route
!
!
ip cef
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
voice-card 0
!
!
!
!
!
license udi pid CISCO2811 sn FCZ11317038
!
redundancy
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex auto
speed auto
!
!
interface FastEthernet0/1
ip address 192.168.200.250 255.255.255.0
duplex auto
speed auto
glbp 1 ip 192.168.200.253
!
!
interface Serial0/2/0
no ip address
shutdown
no fair-queue
!
!
interface Serial0/3/0
ip address 172.16.2.1 255.255.255.0
!
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip route 3.3.3.0 255.255.255.0 172.16.2.2
ip route 192.168.10.0 255.255.255.0 192.168.200.254
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
line con 0
logging synchronous
line aux 0
line vty 0 4
password xdtex
login
!
scheduler allocate 20000 1000
end
VIP Expert

Hi,

Hi,

Load balancing should work with 2 static routes without any metrics.

The issue might be that r3 is not load balancing traffic.  By default, Cisco routers load balance traffic per destination.  What type of router is r3?

HTH

Beginner

It's a Cisco 2811. 

It's a Cisco 2811. 

With the IOS version below installed.

ithe Description: ASK9-AISK9 FEAT SET FACTORY UPG FOR BUNDLES
Release: 15.1.4M
Release Date: 25/Mar/2011
File Name: c2800nm-advipservicesk9-mz.151-4.M.bin
Min Memory: DRAM 512 MB Flash 128 MB
Size: 62.71 MB (65755360 bytes)
MD5 Checksum: f77e51385c1d2d0eb96761df1183551b
SHA512 Checksum:
d9bb2a451656316bd57ad4686cadbc9b...
R3#sh version
Cisco IOS Software, 2800 Software (C2800NM-ADVIPSERVICESK9-M), Version 15.0(1)M4, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2010 by Cisco Systems, Inc.
Compiled Thu 28-Oct-10 17:09 by prod_rel_team

ROM: System Bootstrap, Version 12.4(13r)T, RELEASE SOFTWARE (fc1)

R3 uptime is 4 weeks, 2 hours, 39 minutes
System returned to ROM by reload at 12:35:38 UTC Tue Nov 8 2016
System image file is "flash:c2800nm-advipservicesk9-mz.150-1.M4.bin"
Last reload type: Normal Reload


This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.

Cisco 2811 (revision 53.50) with 512000K/12288K bytes of memory.
Processor board ID FCZ131271CA
2 FastEthernet interfaces
4 Low-speed serial(sync/async) interfaces
1 Virtual Private Network (VPN) Module
DRAM configuration is 64 bits wide with parity enabled.
239K bytes of non-volatile configuration memory.
125440K bytes of ATA CompactFlash (Read/Write)


License Info:

License UDI:

-------------------------------------------------
Device# PID SN
-------------------------------------------------
*0 CISCO2811 FCZ131271CA



Configuration register is 0x2102

Highlighted
Engager

On R2 change route to ip

On R2 change route to ip route 3.3.3.0 255.255.255.0 172.16.2.2

The return path back from R3 int S1/1 is incomplete, because of the routing.

Please rate useful posts & remember to mark any solved questions as answered. Thank you.
Beginner

Hi Bilal,Thank for your

Hi Bilal,

Thank for your response :)

R2 has already the route configured

ip route 3.3.3.0 255.255.255.0 172.16.2.2

And R1 have this one 

ip route 3.3.3.0 255.255.255.0 172.16.1.2

I changed the incorrect route in my scheme. But it's just an oversight. Sorry :)

CreatePlease to create content
Content for Community-Ad