cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

356
Views
5
Helpful
5
Replies
Beginner

Router BGP configuration with default vrf and other specific vrf

Hi,

Trying to configure BGP, with default vrf and specific other vrf in single BGP statement. I did try to configure, but only the one with default vrf is getting shown in show ip bgp summary. Please see the below config. Experts, pls advice the correction required, if am doing anything wrong.

 

interface Ethernet1/5.3333
encapsulation dot1q 3333
vrf member VRF-TEST-DMZ
ip address 10.101.0.22/30
no shutdown


feature bgp
router bgp 65512
log-neighbor-changes
address-family ipv4 unicast
network 10.20.32.0/21
neighbor 10.100.0.21 remote-as 31898
address-family ipv4 unicast
vrf VRF-TEST-DMZ
address-family ipv4 unicast
network 10.20.4.0/24
neighbor 10.101.0.21 remote-as 31898
address-family ipv4 unicast
default-originate

 

DECO-N77K01-PROD# show ip bgp summary
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
10.100.0.21 4 31898 2751 2601 8 0 0 1d19h 2

 

Thanks in advance

Sreeraj

5 REPLIES 5
Beginner

Re: Router BGP configuration with default vrf and other specific vrf

Hello

did you define VRF either vrf definition or ip vrf forwarding ?

and what is your topology

using sub interface is correct

where did you use

router bgp <AS>
address-family ipv4 vrf <nameyour vrf>
neighbor....................activate
neighbor .....................remote-as.......

without this you activated it in Global routing table

i think you forget to add VRF keyword behind address-family ipv4

 

Beginner

Re: Router BGP configuration with default vrf and other specific vrf

Thanks for the quick response. I got it figured out, the configuration was correct.

But, I had to check the BGP status using show ip bgp summary vrf <vrf name>

 

which showed the BGP peering.

 

Thanks

Beginner

Re: Router BGP configuration with default vrf and other specific vrf

any  --->    Show commands when comes in place when you have configured correct configuration otherwise NOT!

regards

 

and also i did not say your config was right or wrong

if right you why use VRF ...use Gloabl Routing Table instead of....VRF

anyway

good news it worked

Highlighted
Hall of Fame Expert

Re: Router BGP configuration with default vrf and other specific vrf

@cisc0.ameer 

 

very good reply!

Rated as deserved

 

Best Regards

Giuseppe

Beginner

Re: Router BGP configuration with default vrf and other specific vrf

Hello and thanks
many valuable from Your side
regards
CreatePlease to create content
Content for Community-Ad
FusionCharts will render here