cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1258
Views
0
Helpful
5
Replies

Router HSRP Connectivity

Cody Ridge
Beginner
Beginner

Hello,

I am configuring an Active and Standby router with HSRP.  Each router has a configured WAN/LAN interface and a 4 FE switchports.

My question is how to best connect the 2 routers to ensure exchange of the multicast traffic that determines active/standby role status.

I was considering connecting the primary router fastethernet0/1/1 port and the secondary router fastethernet0/1/1 port with a LAN cable.  Then creating a separate VLAN for the HSRP traffic.

Something like:

Router A

interface vlan120

ip address 10.1.1.1 255.255.255.252

interface FastEthernet0/1/1

switchport access vlan 120

ip route 10.1.1.0 0.0.0..3 10.1.1.2

Router B

interface vlan120

ip address 10.1.1.2 255.255.255.252

interface FastEthernet0/1/1

switchport access vlan 120

ip route 10.1.1.0 0.0.0.3 10.1.1.1

Any suggestions or feedback would be greatly appreciated.

Thank you.

5 Replies 5

Edison Ortiz
Hall of Fame Mentor Hall of Fame Mentor
Hall of Fame Mentor

1) You don't need static routing as those routes will be shown as connected routes.

2) If you are using HSRP - it is to serve hosts on that subnet on a first hop redundancy. If you have a /30 subnet, where are you placing the hosts?

Thank you for your reply Edison,

There will be a separate VLAN /24 subnet for the LAN traffic.  Both the LAN and WAN interfaces will have virtual IP addresses.

The LAN VLAN will be on ID 110.  If I apply the VLAN 110 on each of the FE0/1/1 switchports, and connect the 2 routers using a LAN cable, will that ensure the exchange of the HSRP multicast traffic?

Yes, and if you have multiple Vlans, make sure to have a trunk.

If you have more switches sharing Vlan 110, make sure one of these routers is the STP root of the Vlan.

Thanks again,

Question for you regarding HSRP and group IDs.

I understand that HSRP needs to be configured on each router interface.  In my case, HSRP will be configured on a WAN gig interface and on a LAN VLAN interface, each with their own virtual IP.

Does assigning both WAN and VLAN interfaces to the same group result in the two interfaces acting as a single failover group?  Meaning, if both interfaces are in group 5 on the Active and Standby routers, and the WAN interface fails on the Active router, does that also result in the LAN interface in the group failing over as well?

In summary,

Router A is Active

Router B is Standby

Router A WAN interface in Group 5 fails

Router B WAN interface in Group 5 switches from Standby to Active

Router A WAN interface in Group 5 is now Standby

Will the Router A VLAN interface in Group 5 switch over to the standby router (which is now Active) as well?

Or, if the interfaces on the same router are assigned different Group IDs, does the failover act independently?

Regards,

You can re-use the same HSRP group as they are on different subnets. The LAN and the WAN HSRP peers will behave independently from each other.

Regards,

Edison

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers