cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
287
Views
0
Helpful
7
Replies
Highlighted

Router on a Stick Help

 

Working with Packet Tracer 7.3 trying to get a handle on a router on a stick but running into some troubles.  I have created a network of 7 VLANS, 3 connected to a Layer2 2960 switch with 253,254 as a management VLAN, the last 2 are connected to another LAYER2 2960 switch with the 2 management VLANS.  Those are connected to a LAYER3.  Then the LAYER3 is connected to the router.  Refer to the picture.

 

I wanted to run fiber connections for everything and ran into problems so i went back to copper, but cant run etherchannel between the layer2 switches, since there isn't enough gigabit connections.  So i have the LAYER2 and LAYER3 connected with 1 copper between them with a SFP connector in the LAYER3 for the incoming.

  R1 (g0/1)  
    
  SWM(g1/1/1)  
SWM(g1/1/2)  
 SWM(g1/1/3)
SW1(g0/1)   SW2(g0/1)
SW1(g0/2)←→←→←→SW2(g0/2)

 

Below is the configs for alll the switches and routers.

 

R1

 

!
version 15.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname RTM
!
!
!
enable secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
no ip cef
no ipv6 cef
!
!
!
username chris secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
!
license udi pid CISCO2911/K9 sn FTX1524T40F-
!
ip ssh version 2
ip domain-name chris.doyle
!
spanning-tree mode pvst
!
interface GigabitEthernet0/0
 ip address 193.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/0.10
 encapsulation dot1Q 10
 ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/0.20
 encapsulation dot1Q 20
 ip address 192.168.20.1 255.255.255.0
!
interface GigabitEthernet0/0.30
 encapsulation dot1Q 30
 ip address 192.168.30.1 255.255.255.0
!
interface GigabitEthernet0/0.40
 encapsulation dot1Q 40
 ip address 192.168.40.1 255.255.255.0
!
interface GigabitEthernet0/0.50
 encapsulation dot1Q 50
 ip address 192.168.50.1 255.255.255.0
!
interface GigabitEthernet0/0.253
 encapsulation dot1Q 253
 ip address 192.168.253.1 255.255.255.0
!
interface GigabitEthernet0/0.254
 encapsulation dot1Q 254 native
 ip address 192.168.254.1 255.255.255.0
!
interface GigabitEthernet0/1
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet0/2
 no ip address
 duplex auto
 speed auto
 shutdown
!
interface GigabitEthernet0/0/0
 no ip address
 shutdown
!
interface GigabitEthernet0/1/0
 no ip address
 shutdown
!
interface Serial0/2/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/2/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/0
 no ip address
 clock rate 2000000
 shutdown
!
interface Serial0/3/1
 no ip address
 clock rate 2000000
 shutdown
!
interface Vlan1
 no ip address
 shutdown
!
ip classless
!
ip flow-export version 9
!

no cdp run
!
line con 0
 exec-timeout 2 0
 password 7 0822445C000A
 login
!
line aux 0
!
line vty 0 4
 exec-timeout 2 0
 password 7 0822445C000A
 login local
line vty 5 15
 exec-timeout 2 0
 password 7 0822445C000A
 login local
!
!
!
end

 

SWM

!
version 16.3.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname SWM
!
!
enable secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
ip cef
no ipv6 cef
!
username chris secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
ip ssh version 2
no ip domain-lookup
ip domain-name chris.doyle
!
!
spanning-tree mode pvst
!
interface GigabitEthernet1/0/1
!
interface GigabitEthernet1/0/2
!
interface GigabitEthernet1/0/3
!
interface GigabitEthernet1/0/4
!
interface GigabitEthernet1/0/5
!
interface GigabitEthernet1/0/6
!
interface GigabitEthernet1/0/7
!
interface GigabitEthernet1/0/8
!
interface GigabitEthernet1/0/9
!
interface GigabitEthernet1/0/10
!
interface GigabitEthernet1/0/11
!
interface GigabitEthernet1/0/12
!
interface GigabitEthernet1/0/13
!
interface GigabitEthernet1/0/14
!
interface GigabitEthernet1/0/15
!
interface GigabitEthernet1/0/16
!
interface GigabitEthernet1/0/17
!
interface GigabitEthernet1/0/18
!
interface GigabitEthernet1/0/19
!
interface GigabitEthernet1/0/20
!
interface GigabitEthernet1/0/21
!
interface GigabitEthernet1/0/22
!
interface GigabitEthernet1/0/23
!
interface GigabitEthernet1/0/24
 switchport access vlan 254
!
interface GigabitEthernet1/1/1
!
interface GigabitEthernet1/1/2
 switchport trunk native vlan 254
 switchport trunk allowed vlan 10,20,30,40,50,253-254
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/1/3
 switchport trunk native vlan 254
 switchport trunk allowed vlan 10,20,30,40,50,253-254
 switchport trunk encapsulation dot1q
 switchport mode trunk
!
interface GigabitEthernet1/1/4
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description Sales VLAN10 (192.168.10.0)
 mac-address 0002.4a01.4901
 ip address 192.168.10.2 255.255.255.0
 ip helper-address 192.168.10.1
!
interface Vlan20
 description Purchasing VLAN20 (192.168.20.0)
 mac-address 0002.4a01.4902
 ip address 192.168.20.2 255.255.255.0
 ip helper-address 192.168.20.1
!
interface Vlan30
 description Security VLAN30 (192.168.30.0)
 mac-address 0002.4a01.4903
 ip address 192.168.30.2 255.255.255.0
 ip helper-address 192.168.30.1
!
interface Vlan40
 description Engineering VLAN40 (192.168.40.0)
 mac-address 0002.4a01.4904
 ip address 192.168.40.2 255.255.255.0
 ip helper-address 192.168.40.1
!
interface Vlan50
 description Quality VLAN50 (192.168.50.0)
 mac-address 0002.4a01.4905
 ip address 192.168.50.2 255.255.255.0
 ip helper-address 192.168.50.1
!
interface Vlan253
 description Management VLAN253 (192.168.253.0)
 mac-address 0002.4a01.4906
 ip address 192.168.253.2 255.255.255.0
 ip helper-address 192.168.253.1
!
interface Vlan254
 description Management VLAN254 (192.168.254.0)
 mac-address 0002.4a01.4907
 ip address 192.168.254.2 255.255.255.0
 ip helper-address 192.168.254.1
!
ip default-gateway 192.168.1.1
ip classless
!
ip flow-export version 9
!
banner motd Authorized Users Only!
!
line con 0
 exec-timeout 2 0
 password 7 0822445C000A
 login
!
line aux 0
!
line vty 0 4
 exec-timeout 2 0
 password 7 0822445C000A
 login local
 transport input ssh
line vty 5 15
 exec-timeout 2 0
 password 7 0822445C000A
 login local
 transport input ssh
!
end

SW1

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname SW1
!
enable secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
!
!
ip ssh version 2
no ip domain-lookup
ip domain-name chris.doyle
!
username chris secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 10
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 20
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 30
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 254
!
interface GigabitEthernet0/1
 switchport trunk native vlan 254
 switchport trunk allowed vlan 10,20,30,40,50,253-254
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk native vlan 254
 switchport trunk allowed vlan 10,20,30,40,50,253-254
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description Sales VLAN10 (192.168.10.0)
 mac-address 00e0.f92c.2501
 ip address 192.168.10.3 255.255.255.0
 ip helper-address 192.168.10.1
!
interface Vlan20
 description Purchasing VLAN20 (192.168.20.0)
 mac-address 00e0.f92c.2502
 ip address 192.168.20.3 255.255.255.0
 ip helper-address 192.168.20.1
!
interface Vlan30
 description Security VLAN30 (192.168.30.0)
 mac-address 00e0.f92c.2503
 ip address 192.168.30.3 255.255.255.0
 ip helper-address 192.168.30.1
!
interface Vlan40
 description Engineering VLAN40 (192.168.40.0)
 mac-address 00e0.f92c.2504
 ip address 192.168.40.3 255.255.255.0
 ip helper-address 192.168.40.1
!
interface Vlan50
 description Quality VLAN50 (192.168.50.0)
 mac-address 00e0.f92c.2505
 ip address 192.168.50.3 255.255.255.0
 ip helper-address 192.168.50.1
!
interface Vlan253
 description Management VLAN253 (192.168.253.0)
 mac-address 00e0.f92c.2506
 ip address 192.168.253.3 255.255.255.0
 ip helper-address 192.168.253.1
!
interface Vlan254
 description Management VLAN254 (192.168.254.0)
 mac-address 00e0.f92c.2507
 ip address 192.168.254.3 255.255.255.0
 ip helper-address 192.168.254.1
!
ip default-gateway 192.168.1.1
!
banner motd Authorized Users Only!
!
!
!
line con 0
 password 7 0822445C000A
 login
 exec-timeout 2 0
!
line vty 0 4
 exec-timeout 2 0
 password 7 0822445C000A
 login local
 transport input ssh
line vty 5 15
 exec-timeout 2 0
 password 7 0822445C000A
 login local
 transport input ssh
!
!
!
!
end

SW2

!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
service password-encryption
!
hostname SW2
!
enable secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
!
!
ip ssh version 2
no ip domain-lookup
ip domain-name chris.doyle
!
username chris secret 5 $1$mERr$H0oY13XBA7VgU8Jsh9kWY0
!
!
!
spanning-tree mode pvst
spanning-tree extend system-id
!
interface FastEthernet0/1
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/2
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/3
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/4
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/5
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/6
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/7
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/8
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/9
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/10
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/11
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/12
 switchport access vlan 40
 switchport mode access
!
interface FastEthernet0/13
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/14
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/15
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/16
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/17
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/18
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/19
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/20
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/21
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/22
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/23
 switchport access vlan 50
 switchport mode access
!
interface FastEthernet0/24
 switchport access vlan 254
!
interface GigabitEthernet0/1
 switchport trunk native vlan 254
 switchport trunk allowed vlan 10,20,30,40,50,253-254
 switchport mode trunk
!
interface GigabitEthernet0/2
 switchport trunk native vlan 254
 switchport trunk allowed vlan 10,20,30,40,50,253-254
 switchport mode trunk
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan10
 description Sales VLAN10 (192.168.10.0)
 mac-address 00e0.a3d2.1301
 ip address 192.168.10.4 255.255.255.0
 ip helper-address 192.168.10.1
!
interface Vlan20
 description Purchasing VLAN20 (192.168.20.0)
 mac-address 00e0.a3d2.1302
 ip address 192.168.20.4 255.255.255.0
 ip helper-address 192.168.20.1
!
interface Vlan30
 description Security VLAN30 (192.168.30.0)
 mac-address 00e0.a3d2.1303
 ip address 192.168.30.4 255.255.255.0
 ip helper-address 192.168.30.1
!
interface Vlan40
 description Engineering VLAN40 (192.168.40.0)
 mac-address 00e0.a3d2.1304
 ip address 192.168.40.4 255.255.255.0
 ip helper-address 192.168.40.1
!
interface Vlan50
 description Quality VLAN50 (192.168.50.0)
 mac-address 00e0.a3d2.1305
 ip address 192.168.50.4 255.255.255.0
 ip helper-address 192.168.50.1
!
interface Vlan253
 description Management VLAN253 (192.168.253.0)
 mac-address 00e0.a3d2.1306
 ip address 192.168.253.4 255.255.255.0
 ip helper-address 192.168.253.1
!
interface Vlan254
 description Management VLAN254 (192.168.254.0)
 mac-address 00e0.a3d2.1307
 ip address 192.168.254.4 255.255.255.0
 ip helper-address 192.168.254.1
!
ip default-gateway 192.168.1.1
!
banner motd Authorized Users Only!
!
!
!
line con 0
 password 7 0822445C000A
 login
 exec-timeout 2 0
!
line vty 0 4
 exec-timeout 2 0
 password 7 0822445C000A
 login local
 transport input ssh
line vty 5 15
 exec-timeout 2 0
 password 7 0822445C000A
 login local
 transport input ssh
!
!
!
!
end

Any comments will be greatly appreciated.

 

7 REPLIES 7
Highlighted
Hall of Fame Master

Hello @ChristopherDoyle ,

a) first of all, the L2 switches should have only one SVI interface VLAN configured and active for their management otherwise you have 3 L3 switches.

b) you need to connect all the switches between them with a trunk link carrying all Vlans you don't need etherchannel at least not for a simple lab

C) on the router you cannot have at the same time an IP address on the physical interface gi0/0 and

enc dot1q native for gi0/0.254 this is not allowed. I think this is the root cause of your issues.

To what interface belong received untagged frames gi0/0 or gi0/0.254 ?

 

I would suggest you to move the L3 configuration under gi0/ 0 main interface under a subinterface with the correct encapsulation .

 

The ip default gaeway of L2 switch have to be in the management subnet.

 

Hope to help

Giuseppe

 

Highlighted
VIP Rising star

Christopher,

 

What is the actual issue you are having?

 

Highlighted

I have one pc on SW1 cant ping a computer on SW2

I would suggest you to move the L3 configuration under gi0/ 0 main interface under a subinterface with the correct encapsulation .t ping a computer on SW2.

 I dont understand that.

Highlighted

Can't ping from R1 on down, can't ping from SWM to PC's or R1

 

1. got rid of the 192.168.1.1 on g0/0 on R1

2. removed the extra VLAN254 on the f0/24 on the L2 Switchs and in the L3 on g0/24

 

Highlighted

Hello,

 

post your zipped Packet Tracer project (.pkt) file.

Highlighted
Engager

 

You can attach your PT file here but it must be in a ZIP format

Highlighted

Here is the PT file.