cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1046
Views
0
Helpful
8
Replies

Routing between routed ports on a 3550 switch

jlamanna1
Level 1
Level 1

Hi,

I have 2 3550's connected across a wireless link.

Switch A:

interface FastEthernet0/24

description downlink to switch B

no switchport

ip address 10.1.3.1 255.255.255.248

!

ip route 10.1.3.8 255.255.255.248 10.1.3.4

Switch B:

interface FastEthernet0/1

description UPLINK to Switch A

no switchport

ip address 10.1.3.4 255.255.255.248

!

interface FastEthernet0/2

description downlink to Switch C

no switchport

ip address 10.1.3.9 255.255.255.248

!

ip route 0.0.0.0 0.0.0.0 10.1.3.1

All ports are up/up

However, from Switch A, I cannot reach 10.1.3.9

Can this 3550 not route traffic between 2 routed ports?

I know I've done this before...

The problematic switch has IOS version 12.1(22)EA4

-- James

8 Replies 8

Amit Aneja
Level 3
Level 3

James,

Routing appears to be correct & 3550 should be able to route b.w them. Couple of things I want to verify:

Can you ping from Switch A (10.1.3.1) to switch B (10.1.3.4)?

"ip routing" is enabled on both switches?

Please share the o/p of "show ip route 10.1.3.9" from switch A & "show ip route" from Switch B.

We can debug & see what's wrong with it.

create an ACL for debugging purpose:

Use a number in ACL that doesn't exist on the switch.

ip access-list ex 191

permit ip host 10.1.3.1 host 10.1.3.9

permit ip host 10.1.3.9 host 10.1.3.1

debug ip packet 191 detail

Paste the o/p & we can identify what's wrong & where it is wrong.

Regards,

Amit

Hi Amit,

SWITCH_A#ping 10.1.3.4

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.3.4, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 4/4/4 ms

ip routing is enabled on both

SWITCH_A#sh ip route 10.1.3.9

Routing entry for 10.1.3.8/29

  Known via "static", distance 1, metric 0

  Routing Descriptor Blocks:

  * 10.1.3.4

      Route metric is 0, traffic share count is 1

SWITCH_B#sh ip route

Gateway of last resort is 10.1.3.1 to network 0.0.0.0

     10.0.0.0/29 is subnetted, 2 subnets

C       10.1.3.8 is directly connected, FastEthernet0/2

C       10.1.3.0 is directly connected, FastEthernet0/1

S*   0.0.0.0/0 [1/0] via 10.1.3.1

Debugging from SWITCH_A

Aug 25 10:13:18.804: FIBipv4-packet-proc: route packet from (local) src 10.1.3.1 dst 10.1.3.9

Aug 25 10:13:18.804: FIBfwd-proc: Default:10.1.3.8/29 proces level forwarding

Aug 25 10:13:18.804: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:18.804: FIBfwd-proc: try path 0 (of 1) v4-rnh-10.1.3.4[v4:Default] first short ext 0(-1)

Aug 25 10:13:18.804: FIBfwd-proc: v4-rnh-10.1.3.4[v4:Default] valid

Aug 25 10:13:18.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 0 if none nh 10.1.3.4 deag 0 via fib 204A568 path type recursive nexthop

Aug 25 10:13:18.804: FIBfwd-proc: depth 1 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:18.804: FIBfwd-proc: try path 0 (of 1) v4-adp-10.1.3.4-Fa0/24 first short ext 0(-1)

Aug 25 10:13:18.804: FIBfwd-proc: v4-adp-10.1.3.4-Fa0/24 valid

Aug 25 10:13:18.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 deag 0 via fib 0 path type adjacency prefix

Aug 25 10:13:18.808: FIBfwd-proc: packet routed to FastEthernet0/24 10.1.3.4(0)

Aug 25 10:13:18.808: FIBipv4-packet-proc: packet routing succeeded

Aug 25 10:13:18.808: IP: tableid=0, s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), routed via FIB

Aug 25 10:13:18.808: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0

Aug 25 10:13:18.808: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0 rec 0

Aug 25 10:13:18.808: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending

Aug 25 10:13:18.808:     ICMP type=8, code=0

Aug 25 10:13:18.808: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending full packet

Aug 25 10:13:18.808:     ICMP type=8, code=0

Aug 25 10:13:20.804: FIBipv4-packet-proc: route packet from (local) src 10.1.3.1 dst 10.1.3.9

Aug 25 10:13:20.804: FIBfwd-proc: Default:10.1.3.8/29 proces level forwarding

Aug 25 10:13:20.804: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:20.804: FIBfwd-proc: try path 0 (of 1) v4-rnh-10.1.3.4[v4:Default] first short ext 0(-1)

Aug 25 10:13:20.804: FIBfwd-proc: v4-rnh-10.1.3.4[v4:Default] valid

Aug 25 10:13:20.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 0 if none nh 10.1.3.4 deag 0 via fib 204A568 path type recursive nexthop

Aug 25 10:13:20.804: FIBfwd-proc: depth 1 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:20.804: FIBfwd-proc: try path 0 (of 1) v4-adp-10.1.3.4-Fa0/24 first short ext 0(-1)

Aug 25 10:13:20.804: FIBfwd-proc: v4-adp-10.1.3.4-Fa0/24 valid

Aug 25 10:13:20.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 deag 0 via fib 0 path type adjacency prefix

Aug 25 10:13:20.804: FIBfwd-proc: packet routed to FastEthernet0/24 10.1.3.4(0)

Aug 25 10:13:20.804: FIBipv4-packet-proc: packet routing succeeded

Aug 25 10:13:20.804: IP: tableid=0, s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), routed via FIB

Aug 25 10:13:20.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0

Aug 25 10:13:20.804: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0 rec 0

Aug 25 10:13:20.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending

Aug 25 10:13:20.804:     ICMP type=8, code=0

Aug 25 10:13:20.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending full packet

Aug 25 10:13:20.808:     ICMP type=8, code=0

Aug 25 10:13:22.804: FIBipv4-packet-proc: route packet from (local) src 10.1.3.1 dst 10.1.3.9

Aug 25 10:13:22.804: FIBfwd-proc: Default:10.1.3.8/29 proces level forwarding

Aug 25 10:13:22.804: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:22.804: FIBfwd-proc: try path 0 (of 1) v4-rnh-10.1.3.4[v4:Default] first short ext 0(-1)

Aug 25 10:13:22.804: FIBfwd-proc: v4-rnh-10.1.3.4[v4:Default] valid

Aug 25 10:13:22.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 0 if none nh 10.1.3.4 deag 0 via fib 204A568 path type recursive nexthop

Aug 25 10:13:22.804: FIBfwd-proc: depth 1 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:22.804: FIBfwd-proc: try path 0 (of 1) v4-adp-10.1.3.4-Fa0/24 first short ext 0(-1)

Aug 25 10:13:22.804: FIBfwd-proc: v4-adp-10.1.3.4-Fa0/24 valid

Aug 25 10:13:22.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 deag 0 via fib 0 path type adjacency prefix

Aug 25 10:13:22.804: FIBfwd-proc: packet routed to FastEthernet0/24 10.1.3.4(0)

Aug 25 10:13:22.804: FIBipv4-packet-proc: packet routing succeeded

Aug 25 10:13:22.804: IP: tableid=0, s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), routed via FIB

Aug 25 10:13:22.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0

Aug 25 10:13:22.804: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0 rec 0

Aug 25 10:13:22.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending

Aug 25 10:13:22.804:     ICMP type=8, code=0

Aug 25 10:13:22.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending full packet

Aug 25 10:13:22.808:     ICMP type=8, code=0

Aug 25 10:13:24.804: FIBipv4-packet-proc: route packet from (local) src 10.1.3.1 dst 10.1.3.9

Aug 25 10:13:24.804: FIBfwd-proc: Default:10.1.3.8/29 proces level forwarding

Aug 25 10:13:24.804: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:24.804: FIBfwd-proc: try path 0 (of 1) v4-rnh-10.1.3.4[v4:Default] first short ext 0(-1)

Aug 25 10:13:24.804: FIBfwd-proc: v4-rnh-10.1.3.4[v4:Default] valid

Aug 25 10:13:24.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 0 if none nh 10.1.3.4 deag 0 via fib 204A568 path type recursive nexthop

Aug 25 10:13:24.804: FIBfwd-proc: depth 1 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:24.804: FIBfwd-proc: try path 0 (of 1) v4-adp-10.1.3.4-Fa0/24 first short ext 0(-1)

Aug 25 10:13:24.804: FIBfwd-proc: v4-adp-10.1.3.4-Fa0/24 valid

Aug 25 10:13:24.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 deag 0 via fib 0 path type adjacency prefix

Aug 25 10:13:24.804: FIBfwd-proc: packet routed to FastEthernet0/24 10.1.3.4(0)

Aug 25 10:13:24.804: FIBipv4-packet-proc: packet routing succeeded

Aug 25 10:13:24.804: IP: tableid=0, s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), routed via FIB

Aug 25 10:13:24.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0

Aug 25 10:13:24.804: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0 rec 0

Aug 25 10:13:24.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending

Aug 25 10:13:24.804:     ICMP type=8, code=0

Aug 25 10:13:24.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending full packet

Aug 25 10:13:24.808:     ICMP type=8, code=0

Aug 25 10:13:26.804: FIBipv4-packet-proc: route packet from (local) src 10.1.3.1 dst 10.1.3.9

Aug 25 10:13:26.804: FIBfwd-proc: Default:10.1.3.8/29 proces level forwarding

Aug 25 10:13:26.804: FIBfwd-proc: depth 0 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:26.804: FIBfwd-proc: try path 0 (of 1) v4-rnh-10.1.3.4[v4:Default] first short ext 0(-1)

Aug 25 10:13:26.804: FIBfwd-proc: v4-rnh-10.1.3.4[v4:Default] valid

Aug 25 10:13:26.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 0 if none nh 10.1.3.4 deag 0 via fib 204A568 path type recursive nexthop

Aug 25 10:13:26.804: FIBfwd-proc: depth 1 first_idx 0 paths 1 long 0(0)

Aug 25 10:13:26.804: FIBfwd-proc: try path 0 (of 1) v4-adp-10.1.3.4-Fa0/24 first short ext 0(-1)

Aug 25 10:13:26.804: FIBfwd-proc: v4-adp-10.1.3.4-Fa0/24 valid

Aug 25 10:13:26.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 deag 0 via fib 0 path type adjacency prefix

Aug 25 10:13:26.804: FIBfwd-proc: packet routed to FastEthernet0/24 10.1.3.4(0)

Aug 25 10:13:26.804: FIBipv4-packet-proc: packet routing succeeded

Aug 25 10:13:26.804: IP: tableid=0, s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), routed via FIB

Aug 25 10:13:26.804: FIBfwd-proc: ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0

Aug 25 10:13:26.804: FIBfwd-proc: sending link IP ip_pak_table 0 ip_nh_table 65535 if FastEthernet0/24 nh 10.1.3.4 uhp 1 deag 0 ttlexp 0 rec 0

Aug 25 10:13:26.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending

Aug 25 10:13:26.804:     ICMP type=8, code=0

Aug 25 10:13:26.804: IP: s=10.1.3.1 (local), d=10.1.3.9 (FastEthernet0/24), len 100, sending full packet

Aug 25 10:13:26.808:     ICMP type=8, code=0

SWITCH_B doesn't have any output.

It seems as though the packets aren't making it over the wireless link, yet pinging 10.1.3.4 works fine.

The link is set up as a transparent bridge.

It for sure looks like that the packets aren't reaching the Switch B over the link. Either they are getting dropped in b/w or on the interface Fa0/1 on Switch B.

To verify that you could simply edit & put the ACL 191 on the fa0/1 interface of Switch B.

On Switch B:

undebug all

no ip access-list ex 191

ip access-list ex 191

permit ip host 10.1.3.1 host 10.1.3.9 log

permit ip host 10.1.3.9 host 10.1.3.1 log

permit ip any any

int fa0/1

ip access-group 191 in

ip access-group 191 out

Please share the following o/p from switches.

Switch B:

show run

sho int fa0/1

sho int fa0/2

Switch A:

show run

show int fa0/24

Switch_B:

ip subnet-zero

ip routing

!

!

spanning-tree mode pvst

spanning-tree extend system-id

!

!

!

!

interface FastEthernet0/1

description UPLINK to 9191

no switchport

ip address 10.1.3.4 255.255.255.248

ip access-group 191 in

ip access-group 191 out

!

interface FastEthernet0/2

description downlink to 9940

no switchport

ip address 10.1.3.9 255.255.255.248

...

interface Vlan1

no ip address

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.1.3.1

ip http server

!

access-list 191 permit ip host 10.1.3.1 host 10.1.3.9 log

access-list 191 permit ip host 10.1.3.9 host 10.1.3.1 log

access-list 191 permit ip any any

FastEthernet0/1 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 000d.ed3a.a880 (bia 000d.ed3a.a880)

  Description: UPLINK to 9191

  Internet address is 10.1.3.4/29

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 100BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:00, output 00:00:00, output hang never

  Last clearing of "show interface" counters never

  Input queue: 1/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 1000 bits/sec, 1 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     77609 packets input, 7452187 bytes, 0 no buffer

     Received 72208 broadcasts (0 IP multicast)

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 72163 multicast, 0 pause input

     0 input packets with dribble condition detected

     25189 packets output, 3674789 bytes, 0 underruns

     0 output errors, 0 collisions, 3 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

FastEthernet0/2 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 000d.ed3a.a880 (bia 000d.ed3a.a880)

  Description: downlink to 9940

  Internet address is 10.1.3.9/29

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 1/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 100BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:01, output 00:00:02, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     62614 packets input, 6247772 bytes, 0 no buffer

     Received 62592 broadcasts (0 IP multicast)

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 62546 multicast, 0 pause input

     0 input packets with dribble condition detected

     20471 packets output, 2902376 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

SWITCH_A:

ip subnet-zero

ip routing

no ip domain-lookup

!

!

!

!

spanning-tree mode pvst

spanning-tree extend system-id

...

interface FastEthernet0/24

description downlink to SWITCH_B

no switchport

ip address 10.1.3.1 255.255.255.248

!

ip classless

ip route 0.0.0.0 0.0.0.0 another.gateway

ip route 10.1.3.8 255.255.255.248 10.1.3.4

FastEthernet0/24 is up, line protocol is up (connected)

  Hardware is Fast Ethernet, address is 0011.5c58.0f80 (bia 0011.5c58.0f80)

  Description: downlink to 18111 Brookhurst

  Internet address is 10.1.3.1/29

  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,

     reliability 255/255, txload 1/255, rxload 0/255

  Encapsulation ARPA, loopback not set

  Keepalive set (10 sec)

  Full-duplex, 100Mb/s, media type is 10/100BaseTX

  input flow-control is off, output flow-control is unsupported

  ARP type: ARPA, ARP Timeout 04:00:00

  Last input 00:00:04, output 00:00:07, output hang never

  Last clearing of "show interface" counters never

  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

  Queueing strategy: fifo

  Output queue: 0/40 (size/max)

  5 minute input rate 0 bits/sec, 0 packets/sec

  5 minute output rate 0 bits/sec, 0 packets/sec

     807719 packets input, 454026965 bytes, 0 no buffer

     Received 17105 broadcasts (0 IP multicasts)

     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored

     0 watchdog, 17000 multicast, 0 pause input

     0 input packets with dribble condition detected

     689590 packets output, 147832650 bytes, 0 underruns

     0 output errors, 0 collisions, 2 interface resets

     0 babbles, 0 late collision, 0 deferred

     0 lost carrier, 0 no carrier, 0 PAUSE output

     0 output buffer failures, 0 output buffers swapped out

From Switch A, "ping 10.1.3.9 source 10.1.3.4" or use extended ping to specify the source IP.

Once you do that, do you see any hits in the ACL 191 on the SwitchB?

If yes, then the packet is getting there. If no, the packet is getting dropped in b/w & would need to check the wireless connection

I do not see anything in the logs on switch B.

The wireless connection is configured as a transparent bridge, so I'm not sure why it is dropping packets to 10.1.3.9 but allowing them to 10.1.3.4 (the 2 access point IPs are 10.1.3.2 and 10.1.3.3)

Review Cisco Networking products for a $25 gift card