cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

205
Views
0
Helpful
6
Replies
Beginner

Routing between to Subnets or Local Network

Hello Guys, 

I need some Help on the below attached network..

 

CAT 4500e:

I'm responsible to overlook this Layer 3 switch, which has 3 Vlans ( i.e. Vlan 1 is on DMZ, & 2 other vlans are clients vlan ) all are pointed to IP router 0.0.0.0 0.0.0.0 10.101.0.2  (10.101.0.2 is Mirotik Router IP & 10.101.0.1 is Cat4500e Vlan 1 IP ).

 

I have use this configuration in cisco 4500e switch for the cleints to use my Sharing server placed on DMZ with going to mikrotik Router.

 

ip dhcp pool vlan15
network 10.101.2.0 255.255.254.0
option 121 ip 23.10.101.0 10.101.2.1
!
ip dhcp pool vlan16
network 10.101.4.0 255.255.254.0
option 121 ip 23.10.101.0 10.101.4.1

 

interface GigabitEthernet1/1
switchport mode trunk
interface Vlan1
ip address 10.101.0.1 255.255.255.0
!
interface Vlan15
ip address 10.101.2.1 255.255.254.0
!
interface Vlan16
ip address 10.101.4.1 255.255.254.0

ip route 0.0.0.0 0.0.0.0 10.101.0.2

 

All thing is going fine but, Now I need to access IP TV Server on another Network Local LAN which is placed on Cat 3750g  local lan (10.0.0.0/16), so that my clients on VLAN 15 & VLAN 16  can easily access IP TV of another LOCAL LAN Network.

 

What Routes I need to configure??

will I need to remove my default router (i.e ip route 0.0.0.0 0.0.0.0 10.101.0.2)

 

I need to inform one more thing that my user are dialing pppoe to connect to mikrotik for internet usage.

 

Thanks

K Khan

 

 

 

pic 1.jpg

6 REPLIES 6
Highlighted
VIP Mentor

Re: Routing between to Subnets or Local Network

Hello,

 

judging from your topology map, the IP-TV server is connected to a layer 3 switch, which means you are effectively dealing with layer 3 to layer 3 communication. On the 3750 where tthe IP-TV server is connected to, you need a default route pointing to the 4500, and on the 4500, you need a route to the new Vlan:

 

The default route to the Mikrotik needs to remain as is.

 

If you are having trouble with the configs, post the configurations of both the 4500 and the 3750.

Beginner

Re: Routing between to Subnets or Local Network

Cat 3750g:

 

The catalyst 3750g switch is under ISP control i cant do anything into it, they provided me these things:-

 

10.0.1.0/24   (Their Local DHCP Network of Cat 3750g)

10.0.0.0/8 + 172.16.0.0/24 (they told me to add both routes point to my cat 4500 switch)

now tell me what should I do??

VIP Advisor

Re: Routing between to Subnets or Local Network

Hello
Looking at your topology it shows a link between the two L3 switch's but I don't see any ip addressing.

Only what you need to provide connectivity between the two vlans and the IPT vlan is a couple of specific static routes

Example 1-  communication just between the L3 switch vlans

L3 -sw cat45K
ip route 10.0.0.0 255.255.0.0 x.x.x.x <cat45K-3650 link ip address)

L3 -sw 3560
ip route 10.101.2.0 255.255.254.0 x.x.x.x <3650 -cat45K link ip address)
ip route 10.101.4.0 255.255.254.0 x.x.x.x <3650 -cat45K link ip address)

Example 2-  communication  between the L3 switch vlans the internet

L3 -sw cat45K

ip route 10.0.0.0 255.255.0.0 x.x.x.x <cat45K-3650 link ip address)

L3 -sw 3560
ip route 0.0.0.0 0.0.0.0 x.x.x.x  <3650 -cat45K link ip address)

2811 rtr 

ip route 10.0.0.0 255.255.0.0 x.x.x.x <2800-cat45K link ip address)
Also nat rule to allow the 3560 vlan internet access




kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Beginner

Re: Routing between to Subnets or Local Network

at 3750g:



The catalyst 3750g switch is under ISP control i cant do anything into it, they provided me these things:-



10.0.1.0/24 (Their Local DHCP Network of Cat 3750g)

10.0.0.0/8 + 172.16.0.0/24 (they told me to add both routes point to my cat 4500 switch)

now tell me what should I do??
VIP Advisor

Re: Routing between to Subnets or Local Network

Hello


@kashifzai86 wrote:
at 3750g:
The catalyst 3750g switch is under ISP control i cant do anything into it, they provided me these things:-
10.0.1.0/24 (Their Local DHCP Network of Cat 3750g)
10.0.0.0/8 + 172.16.0.0/24 (they told me to add both routes point to my cat 4500 switch)

Pointing from where?

You have a 2811 rtr and this 3750g are they both isp managed?
 

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Rising star

Re: Routing between to Subnets or Local Network

Hello,

well, looking your explantion and your topology.

You told to us that you dont have any access on your 3750 that is managed by your ISP and they have configured correct routes properly. In this case you just need create one route, like below;

I suggest you to create a new route in your 4500 appoint to LAN of 3750 managed by your ISP, for exemple:

network of IPTV is: 10.0.0.0/16 and ip lan between 3750 and 4500

route on 4500: ip route 10.0.0.0 255.255.0.0 10.0.0.0.3 (10.0.0.3 ip of 3750 that is connected to your 4500). check correctly ip address.

Regards,
Jaderson Pessoa
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards