cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
214
Views
5
Helpful
11
Replies
Beginner

Routing issue

Hello, I have a Cisco 3725 router connected to a Cisco SF500 switch, also connected to a SF500 switch (trunked)
When I try to ping 10.1.2.5 from the router, it fails. When I debug it stated:

R1#debug ip packet
IP packet debugging is on
R1#ping 10.1.2.
*Mar  1 00:24:21.927: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2
R1#ping 10.1.2.5

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.5, timeout is 2 seconds:

*Mar  1 00:24:23.675: IP: tableid=0, s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), routed via RIB
*Mar  1 00:24:23.675: IP: s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 100, sending
*Mar  1 00:24:23.679: IP: s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 100, encapsulation failed
*Mar  1 00:24:23.707: IP: tableid=0, s=10.1.2.5 (FastEthernet0/0.1), d=10.1.2.20 (FastEthernet0/0.2), routed via RIB
*Mar  1 00:24:23.707: IP: s=10.1.2.5 (FastEthernet0/0.1), d=10.1.2.20, len 60, rcvd 4
*Mar  1 00:24:23.711: IP: tableid=0, s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), routed via RIB
*Mar  1 00:24:23.711: IP: s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 60, sending
*Mar  1 00:24:23.711: IP: s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 60, encapsulation failed.

Encapsulation error, meaning it cannot find the associated MAC address of 10.1.2.5. The 3725 has dot1.q sub interfaces
Here is 3725 config:

R1#show run
Building configuration...

Current configuration : 1261 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
no aaa new-model
memory-size iomem 5
no ip icmp rate-limit unreachable
ip cef
!
no ip domain lookup
!
multilink bundle-name authenticated
!
ip tcp synwait-time 5
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation dot1Q 1 native
 ip address 10.1.1.20 255.255.255.0
!
interface FastEthernet0/0.2
 encapsulation dot1Q 50
 ip address 10.1.2.20 255.255.255.0
!
interface FastEthernet0/0.3
 encapsulation dot1Q 10
 ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.4
 encapsulation dot1Q 20
 ip address 172.20.1.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
no cdp log mismatch duplex
!
control-plane

line con 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line aux 0
 exec-timeout 0 0
 privilege level 15
 logging synchronous
line vty 0 4
 login
!
!
end
I been trying to get this working for days, no luck! Thoughts??

Geoff

11 REPLIES 11
VIP Advocate

Re: Routing issue

Can you do an extended ping on the 3750 to 10.1.2.5 sourcing from 10.1.2.20  and see what it does

Please remember to rate useful posts, by clicking on the stars below.

Beginner

Re: Routing issue

Hello, thanks, same response from 3725 router. Here is a cut & paste:

R1#ping
Protocol [ip]:
Target IP address: 10.1.2.5
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands [n]: y
Source address or interface: 10.1.2.20
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.5, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.20
.....
Success rate is 0 percent (0/5)
R1#debug ip packet
IP packet debugging is on
R1#p
*Mar  1 01:27:03.703: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2
R1#ping
Protocol [ip]:
Target IP address: 10
*Mar  1 01:27:06.703: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2
10.1.2.5
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
*Mar  1 01:27:09.727: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2

Extended commands [n]: y
Source address or interface: 1
*Mar  1 01:27:12.715: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2
10.1.2.20
*Mar  1 01:27:15.739: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2
10.1.2.20
Type of service [0]:
Set DF bit in IP header? [no]:
Validate reply data? [no]:
Data pattern [0xABCD]:
Loose, Strict, Record, Timestamp, Verbose[none]:
*Mar  1 01:27:18.751: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2

Sweep range of sizes [n]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.2.5, timeout is 2 seconds:
Packet sent with a source address of 10.1.2.20

*Mar  1 01:27:21.503: IP: tableid=0, s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), rou                                                                                                ted via RIB
*Mar  1 01:27:21.503: IP: s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 100, sendi                                                                                                ng
*Mar  1 01:27:21.507: IP: s=10.1.2.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 100, encap                                                                                                sulation failed
*Mar  1 01:27:21.759: IP: s=10.1.2.5 (FastEthernet0/0.1), d=255.255.255.255, len 44, rcvd 2.
*Mar  1 01:27:22.671: IP: s=10.1.2.5 (FastEthernet0/0.1), d=8.8.8.8, len 65, unroutable
*Mar  1 01:27:22.671: IP: tableid=0, s=10.1.1.20 (local), d=10.1.2.5 (FastEthernet0/0.2), rou                                                                                                ted via RIB
*Mar  1 01:27:22.675: IP: s=10.1.1.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 56, sendin                                                                                                g
*Mar  1 01:27:22.675: IP: s=10.1.1.20 (local), d=10.1.2.5 (FastEthernet0/0.2), len 56, encaps                                                                                                ulation failed

VIP Advocate

Re: Routing issue

sounds like a layer 2 issue, does the 10.1.2.20 have the mac address of the 10.1.2.5 at all? does the swicth to which 10.1.2.5 is connected have the correct mac address?

Please remember to rate useful posts, by clicking on the stars below.

Highlighted
VIP Mentor

Re: Routing issue

Hello,

 

on a side note, in addition to Dennis' remarks, can both devices see each other through CDP ('sh cdp neighbors' on the router, ' Administration > Discovery - CDP > CDP Neighbor Information' on the SF500, page 121 of the attached user guide) ? In the 'Details' tab, check if the native VLANs match on both sides...

 

https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbms/Sx500/administration_guide/500_Series_Admin_Guide.pdf

 

 

Beginner

Re: Routing issue

Roger, will do, at home now but will inspect again in the morning. Thanks
for the help I hope to get to the bottom of this!

Geoff
Beginner

Re: Routing issue

Hello all, well, long story short, I was actually using the router in place
of a layer 3 SF500 switch (set to layer 3 mode) and after plugging it back
in today and testing, it works! I think it might have been a default gateway
issue (on some other devices) so thanks everyone for their valuable help!



Geoff
Hall of Fame Master

Re: Routing issue

Geoff

 

Thanks for the update letting us know that it is working now.

 

HTH

 

Rick

VIP Advisor

Re: Routing issue

Hello

Providing you have the switchport attaching this router to the switch as a trunk, the switches are running are hosts and the clients are in the correct vlans then this should work

 

What is host 10.1.2.5 ?

sh ip arp | in 10.1.2.5

 

What you can try is remove the sub-interface for vlan 1 and apply the subnet address directly on to the physical interface and test again.

 

example:
conf t
no interface FastEthernet0/0.1

int fa0/0
ip address 10.1.1.20 255.255.255.0
 



kind regards
Paul

Please don't forget to rate any posts that have been helpful.
Beginner

Re: Routing issue

Hello, sure, good idea although 10.1.2.5 is a small PC on the other side of
the room hence the switches in the middle but good idea.
VIP Advisor

Re: Routing issue

Hello


@geoffwynn wrote:
Hello, sure, good idea although 10.1.2.5 is a small PC on the other side of

Also make sure that there isnt any software fw on that pc restricting icmp



kind regards
Paul

Please don't forget to rate any posts that have been helpful.
Hall of Fame Master

Re: Routing issue

The key thing to consider is the error message about encapsulation failed. This means that it was not able to find the mac address of the destination in the arp table. The source and the destination appear to be in the same subnet, so arp should work. We need to find the reason why the PC is not responding to the arp.

 

Is the PC able to access other resources in the network? Perhaps the output of ipconfig and of arp -a from the PC might be helpful.

 

HTH

 

Rick

CreatePlease to create content
Content for Community-Ad