cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
770
Views
5
Helpful
12
Replies

routing leased line internet traffic through ISDN Router

shoebwk
Level 1
Level 1

In my head office i have a 2600 leased line router connected to the internet.

my branch office is connecting to our internal servers through dialup ISDN (801).

how can i configure the ISDN router at both end to route the internet traffic from headoffice to the branch office connected via ISDN?

Regards

shoeb

12 Replies 12

Hello Shoeb,

basically, you do not need to configure anything on the branch office routers, just make sure that you have a default route on your head office router pointing to the leased line interface connected to the Internet. This way, all traffic not going to your internal networks will automatically be routed out to the Internet. Let´s say you head office router has two interfaces:

interface Serial0/0

description connected to Internet

ip address 212.24.23.1 255.255.255.252

!

interface FastEthernet0/0

ip address 192.168.1.1 255.255.255

The default route should point to Serial0/0:

ip route 0.0.0.0 0.0.0.0 Serial0/0

Assuming your servers are connected to FastEthernet0/0, the directly connected route will take care of traffic going to those servers.

Obviously you also need the route(s) to the branch office(s), but I guess you have those already configured (?)...

Does that make sense ?

Regards,

GP

please see the attached diagram, which visualise what i want.

I want the router1 to provide internet access to the BR. Lan.

What routing i have to put in the both ISDN router , Router1 and Router2 ?

The users on the BR. LAN will have a gateway to Router1.

regards

in router 2 put in a default route pointing towards router1.

in router 1 put a default route pointing towards the router 3.

and here put any other routes for ur Ho lan(ie any other routers or layer 3 switches with vlans etc.. ) exists and routes for branches subnet pointing towards respective branches routers.

in router 3 u have to do nat (only if ur branches or ho lan are running on private ip's which i guess they must be) and put a default route pointing towards internet and summarised routes for the subnets being used in ur network towards router 2.

HTH

Are you sure that i put a default route on router 2 to point to router 1 or default route on router1 to point to router2.

And default route on router2 to point to router3

Hi,

For outgoing traffic:

R1--Default Route-->R2--Default Route-->R3->Internet

For imcoming traffic

Internet-->R3(should have route for R1 LAN pool or NATed BRI IP pointing to R2)-->R2(should have route for R1 LAN pool or NATed BRI IP pointing to R1) -->R1

Let me know my assumption is correct.

Kannan.S.T.

SUPPOSE I HAVE FOLLOWING IP ADDRESSES

R1 (e0-192.168.10.1, BRI0=192.168.100.1)

R2 (e0=10.91.2.2, BRI0=192.168.100.1)

R3 (e0=10.91.2.3, BRI0=213.x.x.x)

does the following route and NAT are correct?

R1

---------

ip route 0.0.0.0 0.0.0.0 bri0

R2

---------

ip route 0.0.0.0 0.0.0.0 10.91.2.3

ip route 192.168.10.0 255.255.255.0 bri0

R3 (internet router)

---------

interface ethernet 0

ip address 10.91.2.3 255.255.255.0

ip nat inside

interface serial 0

ip address 217.x.x.x 255.255.255.0

ip nat outside

ip nat pool test 217.x.x.x 217.x.x.y prefix 24

ip nat inside source list 7 interface serial 0 overload

access-list 7 permit 10.91.2.0 0.0.0.255

access-list 7 permit 192.168.10.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 s0

ip route 192.168.10.0 255.255.255.0 10.91.2.2

please correct it accordingly

Yes, It will work.

I corrected the following things from your post.

R2 (e0=10.91.2.2, BRI0=192.168.100.2)

R3 (e0=10.91.2.3, S0=217.x.x.x)

interface serial 0

ip address 217.x.x.x 255.255.255.252

No need "ip nat pool test 217.x.x.x 217.x.x.y prefix 24"

Kannan.S.T.

i have made final change in my diagram, where there is 2 remote site instead of 1 who require internet access.

IS the configuration OK for the attached Diagram

R-A (e0-10.100.10.1, BRI0=10.200.10.1)

R-B (e0=10.90.10.1, BRI0=10.200.10.2, BRI1=10.200.20.2)

R-D (e0=10.100.50.1, BRI0=10.200.20.1)

R-C (e0=10.90.10.2, S0=217.x.x.x)

does the following route and NAT are correct?

R-A

---------

ip route 0.0.0.0 0.0.0.0 bri0

R-B

---------

ip route 0.0.0.0 0.0.0.0 10.90.10.2

ip route 10.100.10.0 255.255.255.0 bri0

Ip route 10.100.50.0 255.255.255.0 bri1

R-C

---------

Ip route 0.0.0.0 0.0.0.0 bri0

R-D (internet router)

---------

interface ethernet 0

ip address 10.90.10.2 255.255.255.0

ip nat inside

interface serial 0

ip address 217.x.x.x 255.255.255.0

ip nat outside

ip nat pool test 217.x.x.x 217.x.x.y prefix 24

Ip nat inside source list 7 pool test overload

rem ip nat inside source list 7 interface serial 0 overload

access-list 7 permit 10.91.10.0 0.0.0.255

access-list 7 permit 10.100.10.0 0.0.0.255

access-list 7 permit 10.100.50.0 0.0.0.255

ip route 0.0.0.0 0.0.0.0 s0

ip route 10.100.10.0 255.255.255.0 10.90.10.1

ip route 10.100.50.0 255.255.255.0 10.90.10.1

Yes. It will work.

I think in the access-list the first ACE is not correct. It should 10.90.10.0.

Kannan.S.T.

Thanks Kannan, for all your help.

one question i want to check about connectivity between Router A, R-B & R-D

What will be the BRI's config as it will recieve call from two different number.?

Do i have to create 2 dialer for Router-B although it will just recieve a call.

can you send me a small config for the Router-B recieving two calls.?

just refer sample config. Modify according to your need.

I hope it will useful to you.

Kannan.S.T.

hi Kanan,

Thanks for your config. There is one doubt i need to check.

The BRI interface command can be set only for

interface bri0.

when i typr interface bri1 it give invalid command

i am using cisco 801

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card