cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
1434
Views
0
Helpful
3
Replies

RR MP-iBGP for MPLS VPN in Cisco IOS-XR - Subnet not received

Hi,

I have a cisco IOS configured as iBGP Route Reflector for MPLS VPNv4. On this router, I can see the route received and redistribute to on of its neighbors. This let me suppose that the reflector function works fine

RR-P-R3#show bgp vpnv4 unicast all neighbors 11.11.11.11 advertised-routes
BGP table version is 3, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:100
*>i 10.0.10.0/24 2.2.2.2 2 100 0 ?
*>i 192.168.12.0/30 2.2.2.2 0 100 0 ?

Total number of prefixes 2

However, the neighbor 11.11.11.11 (IOS-XR) doesn't get any of those routes

RP/0/0/CPU0:ASBR-11#show bgp vpnv4 unicast neighbors 3.3.3.3 routes
Thu May 5 20:52:24.712 UTC
RP/0/0/CPU0:ASBR-11#show bgp vpnv4 unicast
Thu May 5 20:52:35.781 UTC
RP/0/0/CPU0:ASBR-11#

Below the configs

Route Reflector

=============

Total number of prefixes 2
RR-P-R3#sh running-config | s bgp
router bgp 65000
bgp router-id 3.3.3.3
bgp log-neighbor-changes
no bgp default ipv4-unicast
no bgp default route-target filter
neighbor IBGP peer-group
neighbor IBGP remote-as 65000
neighbor IBGP update-source Loopback0
neighbor 2.2.2.2 peer-group IBGP
neighbor 11.11.11.11 peer-group IBGP
!
address-family ipv4
exit-address-family
!
address-family vpnv4
neighbor IBGP send-community both
neighbor IBGP route-reflector-client
neighbor 2.2.2.2 activate
neighbor 11.11.11.11 activate
exit-address-family

Neighbor IOS-XR

==============

router bgp 65000
bgp router-id 11.11.11.11
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
neighbor 3.3.3.3
remote-as 65000
update-source Loopback0
address-family vpnv4 unicast
!
!
!
mpls ldp
graceful-restart
router-id 11.11.11.11
interface GigabitEthernet0/0/0/1
!
interface GigabitEthernet0/0/0/2
!
!
end

Any idea what is wrong here?

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions
David_Che
Beginner

IOS XR use import-rt of VRF to filter VPNV4 route into its local database, if you did not define any VRF on this XR router, it will receive none of any VPNV4 route.

View solution in original post

3 REPLIES 3
Vinit Jain
Cisco Employee

Hello,

I do not see VRF configuration on IOS XR. Could you please configure a VRF. It is after that you should be able to receive routes on the XR router.

Please let me know if that resolves the problem

Regards

Vinit

Thanks
--Vinit
David_Che
Beginner

IOS XR use import-rt of VRF to filter VPNV4 route into its local database, if you did not define any VRF on this XR router, it will receive none of any VPNV4 route.

View solution in original post

Hi,

That was the problem:

"By default, a cisco router will filter out prefixes that contain a route-target that is not use locally on that router.

This check is disabled when you configure a route-reflector-client, since the client may need one of those routes.

On an ASBR that IS already a RR, you don't need to mess with this command because the rt filter check is already turned off.

However, if your ASBR is not a RR ( or doesn't have a particular VPN configured locally) and you need to advertise VPN prefixes to another AS, then you need to turn this check off or the ASBR will filter out the prefixes when they are received from its internal peers, so it will not have them to advertise to another else. In this case, you would do a "no bgp default route-target filter" on the ASBR so the routes are accepted even though they will not be used locally."

On cisco IOS-XR the command is  retain route-target all  under  address-family vpnv4 unicast.
This is the final configuration:

router bgp 65000
bgp router-id 11.11.11.11
address-family ipv4 unicast
!
address-family vpnv4 unicast
retain route-target all
!
neighbor 3.3.3.3
remote-as 65000
update-source Loopback0
address-family vpnv4 unicast
!
!
!
mpls ldp
graceful-restart
router-id 11.11.11.11
interface GigabitEthernet0/0/0/1
!
interface GigabitEthernet0/0/0/2

And I can seer the route

RP/0/0/CPU0:ASBR-11#sh bgp vpnv4 unicast
Fri May 6 10:32:08.089 UTC
BGP router identifier 11.11.11.11, local AS number 65000
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0x0 RD version: 0
BGP main routing table version 4
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
Route Distinguisher: 1:100
*>i10.0.10.0/24 2.2.2.2 2 100 0 ?

Thanks