cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

(S,G) not forming in Source PE in SSM !!

muthupriyanka
Beginner
Beginner

Hi,

  I have SSM configured in my MPLS core and for one of my customer too - VPN A. Multicast streaming is not woking for my customer.

  I checked the (S,G) by using the cmd "sh ip mroute vrf VPNA". I am able to see (S,G) forming in only receiver PE and not in source PE.

  I configured igmp join the interface of PE router where the receiver is connected.

PE2# 

interface GigabitEthernet1/1

description "CUST-A MULTICAST TESTING"

ip vrf forwarding CUST-A

ip address 40.40.40.1 255.255.255.252

ip pim sparse-mode

ip igmp join-group 238.192.10.60 source 30.30.30.1

ip igmp version 3

end

PE2#

PE2#sh ip mroute vrf CUST-A
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.250), 02:28:52/00:02:02, RP 0.0.0.0, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet1/1, Forward/Sparse, 02:28:52/00:02:02

(30.30.30.1, 238.192.10.60), 02:29:33/00:02:08, flags: sLTI
  Incoming interface: Tunnel0, RPF nbr 192.8.233.8
  Outgoing interface list:
    GigabitEthernet1/1, Forward/Sparse, 02:29:33/00:02:08

(*, 224.0.1.40), 02:29:33/00:02:45, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel0, Forward/Sparse, 02:29:33/00:02:45

PE2#

I checked the Mtrace from PE1.It shows the below output.

PE1X#mtrace vrf CUST-A 30.30.30.1 40.40.40.1 238.192.10.60

Type escape sequence to abort.

Mtrace from 30.30.30.1 to 40.40.40.1 via group 238.192.10.60 in VRF CUST-A

From source (?) to destination (?)

Querying full reverse path... * switching to hop-by-hop:

0  40.40.40.1

-1  * 0.0.0.0 PIM/MBGP Admin. Prohibited [30.30.30.0/30]

-2  * 0.0.0.0 PIM  [30.30.30.1/32]

-2  30.30.30.1

PE1X#

PE1#sh run int Gi2/6
Building configuration...

Current configuration : 232 bytes
!
interface GigabitEthernet2/6
description "CUST-A MULTICAST TESTING"
ip vrf forwarding CUST-A
ip address 30.30.30.1 255.255.255.252
ip pim sparse-mode
ip igmp version 3
end

PE1#

        

PE1#sh ip mroute vrf CUST-A
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry, E - Extranet,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group,
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 239.255.255.250), 01:46:21/00:02:36, RP 0.0.0.0, flags: SJC
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    GigabitEthernet2/6, Forward/Sparse, 01:46:21/00:02:36

(*, 224.0.1.40), 01:46:29/00:02:54, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Tunnel0, Forward/Sparse, 01:46:29/00:02:54

7 REPLIES 7

Giuseppe Larosa
Hall of Fame Master Hall of Fame Master
Hall of Fame Master

Hello Muthupriyanka,

in order to get better help you should post the relevant configuration elements of PE2 and PE1 nodes.

I mean:

ip multicast routing enabled in global routing table

VRF configuration specially to see if you have an MDT

MP BGP configuration what type of address-family are you using in the control plane?

for each of PE1 and PE2.

Look also at the log messages on PE1 node.

The PE1 node should receive the PIM join from PE2 on the GRE tunnel interface

There are also some specific debug commands that can be used for this troubleshooting

debug ip pim vrf CUST-A

see the avaiable options there might be a reason that makes PE1 to refuse the PIM join coming from PE2 over the tunnel.

Hope to help

Giuseppe

Hi Giuseppe,

   Thanks for your reply.

    Below are the configurations from PE1.

PE1#sh run | b ip vrf CUST-A
ip vrf CUST-A
rd 24084:3001
route-target export 24084:303001
route-target import 24084:303001
mdt default 239.192.0.1
mdt data 239.192.10.0 0.0.0.255 threshold 1

PE1X#sh run | i multicast

ip multicast-routing

ip multicast-routing vrf CUST-A

PE1X#sh run | i ssm

ip pim ssm range 55

ip pim vrf CUST-A ssm range 65

PE1X#

PE1X#sh ip access-lists 55

Standard IP access list 55

    10 permit 239.192.0.0, wildcard bits 0.0.255.255 (85 matches)

PE1X#

PE1X#sh ip access-lists 65

Standard IP access list 65

    10 permit 238.192.10.0, wildcard bits 0.0.0.255 (840 matches)

PE1X#

PE1X#sh ip pim mdt

  * implies mdt is the default MDT

  MDT Group/Num   Interface   Source                   VRF

* 239.192.0.1     Tunnel0     Loopback0                CUST-A

PE1X#

PE1X#sh ip pim vrf CUST-A nei

PIM Neighbor Table

Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,

      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable

Neighbor          Interface                Uptime/Expires    Ver   DR

Address                                                            Prio/Mode

192.8.233.7       Tunnel0                  1d21h/00:01:23    v2    1 / S P G

Hello Muthupriyanka,

may you provide  the MP BGP configuration ?

I don't see it in your new post

From what I see it looks like fine

Hope to help

Giuseppe

Hi Larosa,

   Please find the MP-BGP configurations.

address-family ipv4 mdt

  neighbor rrvpnv4 send-community both

  neighbor x.x.x.x activate (RR1)

  neighbor y.y.y.y activate (RR2)

exit-address-family

!

address-family ipv4 vrf CUST-A

  no synchronization

  redistribute static

  redistribute connected

exit-address-family

!

Hello Muthu,

you are using the MDT address-family towards two route reflector servers.

But the MDT is a type of BGP extended community you need to send both standard or extended communities  in order to have them propagated from PE to PE via the RRS. In IOS communities are not sent by default.

Here it is my configuration for the same address family that I used some years ago:

Address-family ipv4 mdt

Neigh 10.80.0.21 activate

>>>Neigh 10.80.0.21 send-community both

Neigh 10.80.0.23 activate

>>>Neigh 10.80.0.23 send-community both

Explanation:

When BGP extended communities are used, the PE loopback (source address) information is sent as a VPNv4 prefix using Route Distinguisher (RD) Type 2 (to distinguish it from unicast VPNv4 prefixes). The MDT group address is carried in a BGP extended community. Using a combination of the embedded source in the VPNv4 address and the group in the extended community, PE routers in the same MVRF instance can establish SSM trees to each other.

see

http://www.cisco.com/en/US/docs/ios/ipmulti/configuration/guide/imc_cfg_mc_vpn_ps6441_TSD_Products_Configuration_Guide_Chapter.html#wp1055404

Hope to help

Giuseppe

Hi Larosa,

    Send community is already configured under peer group if u notice in the above configuration.

router bgp 1234

bgp router-id z.z.z.z
bgp always-compare-med
no bgp default ipv4-unicast
bgp log-neighbor-changes
bgp deterministic-med
bgp graceful-restart restart-time 120
bgp graceful-restart stalepath-time 360
bgp graceful-restart
neighbor rrvpnv4 peer-group
neighbor rrvpnv4 remote-as 1234
neighbor rrvpnv4 update-source Loopback0
neighbor rrvpnv4 timers 10 30
neighbor x.x.x.x peer-group rrvpnv4
neighbor y.y.y.y peer-group rrvpnv4

   

address-family ipv4 mdt

  neighbor rrvpnv4 send-community both

  neighbor x.x.x.x activate

  neighbor y.y.y.y activate

exit-address-family

Please help...

Hello Muthupriyanka,

I'm sorry I have missed you had a peer-group.

However, I would expect the following configuration in  BGP af mdt:

address-family ipv4 mdt

neighbor rrvpnv4 send-community both

neighbor rrvpnv4 activate

Hope to help

Giuseppe

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: