cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
639
Views
0
Helpful
10
Replies
majed.balsharaf
Beginner

Same BGP

Hi

  I am having two circuits of BGP with same AS 65xx5.

Can i connect them in one router and split the traffic,

as i need

my LAN 1 to go via WAN 1

my LAN 2 to go via WAN 2

As I am having configuration for both WAN's

For WAN 1

router bgp 65xx5

nei 17

2 ACCEPTED SOLUTIONS

Accepted Solutions
Simon Brooks
Beginner

Easiest option is policy base routing for dource of traffic pointing to each next hop neighbour respectively.


Sent from Cisco Technical Support Android App

View solution in original post

The below will be fine, you can have as many connections to another AS (remote-as) as you wish, Your only challenge is how best to make use of the circuits.

neighbor 10.21.x.225 remote-as 65000

neighbor 172.31.x.221 remote-as 65000

Regards Neil 

http://uk.linkedin.com/pub/neil-grant/20/5b0/267

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267

View solution in original post

10 REPLIES 10
Simon Brooks
Beginner

Are the uplinks to same isp?


Sent from Cisco Technical Support Android App

Simon Brooks
Beginner

Easiest option is policy base routing for dource of traffic pointing to each next hop neighbour respectively.


Sent from Cisco Technical Support Android App

Sorry by mistake I did the answer correct. Actually both are from same BGP and if i give the neighbor address the one exit will get over write.

So thats why I am confused.

Thanks

Steven Clinton
Beginner

How are you wanting to separate the traffic (inbound, outbound, by subnet), will Internet traffic be in involved?

Sent from Cisco Technical Support iPhone App

     Thanks for the reply actually this circuits are IPVPN circuits with BGP.

neil grant
Beginner

Outbound routemap

     Neighbough 1  Adverstise Lan 1 as primary

     match LAN 1

     set MED 100 (lowsest preferred)

     Match LAN 2

     Set Med 200

     Neighbough 2 

     match LAN 1

     Set MED 200

     Match Lan 2

     Set Med 100

Inbound route map

Match disired Prefix

Set Weight or local preference

Your provider will probably (by default, and assuming you are only using the one provider)  support multipath (if not, probably worth asking)

Router bgp X

maximum-paths 2

This will load share per session across all prefixes.

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267

Thanks I am near to my answer

But I have to interface WAN IP's

for LAN 1 WAN ip is

10.21.x.224/30

For LAN 2 WAN ip is

171.31.x.220/30

With Same bgp

if I assign the interface with this IP's ok. but when I go in router bgp 65xx5 what neighbour shall i choose

Example:

router bgp 65xx5

neighbor 10.21.x.225 remote-as 65000

10.21.x.223 is of WAN 1

if I try to add WAN 2 neighbor

router bgp 65xx5

neighbor 172.31.x.221 remote-as 65000

(this will overwrite my WAN 1 neighbor IP)

I am using 2951 router

neil grant
Beginner

Route Map example:

!

route-map Set-Primary-Out permit 10

set metric 100

route-map Set-Primary-In permit 10

set local-preference 200

route-map Set-Secondary-Out permit 10

set metric 200

route-map Set-Secondary-In permit 10

set local-preference 100

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267

Thanks I am near to my answer

But I have to interface WAN IP's

for LAN 1 WAN ip is

10.21.x.224/30

For LAN 2 WAN ip is

171.31.x.220/30

With Same bgp

if I assign the interface with this IP's ok. but when I go in router bgp 65xx5 what neighbour shall i choose

Example:

router bgp 65xx5

neighbor 10.21.x.225 remote-as 65000

10.21.x.223 is of WAN 1

if I try to add WAN 2 neighbor

router bgp 65xx5

neighbor 172.31.x.221 remote-as 65000

(this will overwrite my WAN 1 neighbor IP)

I am using 2951 router

The below will be fine, you can have as many connections to another AS (remote-as) as you wish, Your only challenge is how best to make use of the circuits.

neighbor 10.21.x.225 remote-as 65000

neighbor 172.31.x.221 remote-as 65000

Regards Neil 

http://uk.linkedin.com/pub/neil-grant/20/5b0/267

Regards Neil http://uk.linkedin.com/pub/neil-grant/20/5b0/267