cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
42064
Views
15
Helpful
11
Replies
Steve Waechter
Beginner

Set baud command on Catalyst 2950 is not working. Well, maybe it is.

I have several Catalyst 2950s that were somehow erased.

They do not boot, there is no IOS image in the flash.

.

I need to reload the IOS on it, and as far as I can tell all I can do in this case is Xmodem transfer.

I read the procedure here:

http://www.cisco.com/en/US/products/hw/switches/ps628/products_tech_note09186a0080169696.shtml

And followed it, it worked. I recovered one but it took a very long time through the console at 9600.

There is a procedure for using the set baud command to reset the console to 115200 at the bottom of that document:

How to Speed Up Xmodem Recovery

When a user tries to recover the switch from a corrupted or missing       IOS, the copy xmodem: flash:[IOS filename] command       might not be displayed under the switch: prompt.       The copy command might be displayed under the       switch: prompt, but not the copy       xmodem: command.

Complete these steps in order to speed up the Xmodem       recovery:

  1. Set the baud rate to 115200 on the             switch: prompt.

    switch: set BAUD 115200

    !--- The screen goes blank after you enter this command.

  2. Restart HyperTerminal.

  3. Under COM PORT properties, select the bits per second as             115200. The switch: prompt is             displayed.

  4. Start the Xmodem recovery.

  5. After the Xmodem recovery, set the BAUD rate back to             9600. If the set BAUD 9600 command             does not bring the baud rate to 9600, issue the unset BAUD command in order to bring the baud rate to a default value             of 9600 bps.

I did type set baud 115200, but the screen didn't go blank and I did not lose contact with the console.

I typed set

the switch reported it's settings, including

baud 115200

which I assume means that command did work, but did not take immediate effect.

I expected it to.

I reloaded the switch, but I still didn't lose contact with the switch at 9600. Clearly the switch console port speed did not change at all.

So I copied the file by xmodem at the same speed, but I should have been able to get this all going much faster.

I tried unset baud and typed set, and the baud setting was missing from the listing, so I assume that means my unset baud command was accepted.

What did I do wrong?

Is the writeup incorrect?

Can anyone shed any light on this?

Thanks in advance.

Steve

2 ACCEPTED SOLUTIONS

Accepted Solutions
paolo bevilacqua
Hall of Fame Master

Did you type BAUD uppercase ?

View solution in original post

Peter Paluch
Hall of Fame Cisco Employee