cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
270
Views
0
Helpful
6
Replies
Highlighted

Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

hi,

i have posted below current configuration of my router. i'm getting internet inside the router but not getting in interface g0/1 which is connected to my switch. i can ping to google from command,but not to the devices connected to g0/1. And my DCHP function is also not working. Please tell we which part of the code is wrong.

 

Interface g0/0 -WAN(from ISP)

interface g0/1 -LAN(to switch)

 

CODE:

 

 


!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!

 


no aaa new-model
!
!
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool LINE
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 192.168.1.1
lease 3
!
!
!
ip name-server 213.42.20.20
ip name-server 8.8.8.8
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2911/K9 sn FGL19241030
!
!
!
redundancy
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/0.21
encapsulation dot1Q 21
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface GigabitEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
no cdp enable
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
interface Dialer1
ip address negotiated
ip mtu 1492
ip nat outside
ip virtual-reassembly in
encapsulation ppp
ip tcp adjust-mss 1452
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname xxxxxx
ppp chap password 0 xxxxxx
ppp pap sent-username xxxxx password 0 xxxxxx
no cdp enable
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 10 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
!
access-list 10 permit 192.168.1.0 0.0.0.255
!
control-plane
!
!
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input all
!
scheduler allocate 20000 1000
!
end

 

Thanks

Afsal

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

Sorry for making you guys into trouble. i have sort out the issue.

problem was here

 

ip nat inside source list 10 interface GigabitEthernet0/0 overload

changed to 

ip nat inside source list 10 interface dialer1 overload

 

Now internet is working .

Thank you all. :) 

6 REPLIES 6
Advocate

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

Hi tyroafsal@gmail.com,

 

Try configuring the PPPoE parameters inside the G0/0 interface instead of the sub-interface G0/0.21

 

Regards

 

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

we have vlan tagging with ISP. without that we will not get internet.
Advocate

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

Hello tyroafsal@gmail.com,

 

What version of IOS do you have?

 

Regards

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

Version 15.0(1r)M15,
Hall of Fame Master

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

If I am understanding the original post correctly it says that the router is able to ping to resources in the Internet. If so that is good news and verifies that the connection to the ISP is working correctly. If I am understanding correctly the issue is with the lan part of the configuration. One comment says that users on the lan are not able to access the Internet. One common cause of problems accessing the Internet has to do with address translation. I see that address translation is configured but I believe that there are issues with that configuration. The current configuration does overload on the physical interface. Since the traffic is coming through the sub interface I believe that it is problematic to specify the physical interface. And since the IP address is on the dialer interface I would suggest changing the configuration of address translation to do overload on the dialer interface.

 

There is also a comment that DHCP is not working. The configuration of the interface and of DHCP appears to be reasonable. But if it is not working then I suspect that something in the router config does not match to the switch config. Would the original poster give us the output of the command show ip interface brief from the router. And also would you provide the configuration of the switch port which connects to the router?

 

HTH

 

Rick

Re: Setting up Cisco 2911 as ISP client PPPoE router with Vlan tagging

Sorry for making you guys into trouble. i have sort out the issue.

problem was here

 

ip nat inside source list 10 interface GigabitEthernet0/0 overload

changed to 

ip nat inside source list 10 interface dialer1 overload

 

Now internet is working .

Thank you all. :) 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards