cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
1721
Views
0
Helpful
26
Replies
User1234
Beginner

SG-200 08 ntp not working

Hi there,

 

i bought this Switch but ntp is not working.

All other Clients behind the Switch do have no Problem getting Time from my local ntp Server(192.168.1.1).  Active Server is always 0.0.0.0.. I tried with sntp broadcast and unicast. I tried it with the hostname and the ip of my lokal ntp Server and some on the Internet. But Time is always starting on 1970. i use the newest firmware. Gateway is set and i tried it with dhcp and static Settings. DNS is also set. I tried it with getting DNS and as DNS Server set. I also did a lot of reboots. No luck. Is there any Beta firmware. Please, i do  need that. Any workaround? Thx

 

1 ACCEPTED SOLUTION

Accepted Solutions

i managed it and it works now.

the problem was the "dns resolver" configuration on pfsense. its the dns server of pfsense.

it was no problem for all client machines recieving ntp. even freenas, a brother printer and all windows clients had no problems except this switch.

i disabled under the network interfaces the "WAN" interface. so the only selected interfaces are the "LAN"and the "LOCALHOST" interfaces and everything works now perfect (see screenshot). thx for your patient. i hope i can help other people with this solution too.dns.JPG

 

time.JPG

 

View solution in original post

26 REPLIES 26
Georg Pauwen
VIP Expert

Hello,

the SG200 supports SNTP only. You need a separate SNTP server, as NTP and SNTP do not work on the same machine (they use the same port).

Check page 68 of the attached user guide for reference:

https://www.cisco.com/c/dam/en/us/td/docs/switches/lan/csbss/sf20x_sg20x/administration_guide/Cisco_200Sx_v1_4_AG.pdf

I configurate sntp broadcast or unicast and set my local sntp Server as the Server my Switch should get synchroniced. My ntp Server has the ip 192.168.1.1. Even with the hostname it does not work. I know that it is not possible to make the 200 work as local ntp Server and getting ntp Remote Messages at the same time. The gui can only configured as one of them. 

 

What can i do?

I get the the common message from support but no solution. Even no beta firmware available? Do i have to sell this thing?

What are you using as SNTP server ?

Pfsense. And no. Nothing blocked. No 123 port messages. Every device on every subnet is working fine. Windows, bsd clients. All clients which are connected to the switch get ntp messages fine. Even a printer gets the ntp messages fine. Really every other client. I also tried a global internet time server directly in two way. With the hostname and the ip .with no luck too.

 The switch-Time is 01.01.1970

Hello,

you could try one of the SNTP time servers mentioned in the user manual:

- time-a.timefreq.bldrdoc.gov
- time-b.timefreq.bldrdoc.gov
- time-c.timefreq.bldrdoc.gov

 I already did that. That are the default time servers. Doesn’t work

In addition, try tthe following (I found this in a previous thread):

 

Go to :

Administration > Time Settings > SNTP Setting and select (check mark) each one of the SNTP servers entries (one at a time), click on <Edit> and put the check mark to <Enable> Polling Mode. Save. Do that for each SNTP server.

I already did that. Doesn’t work.

Is your DNS set up correctly ?

Another suggestion from that same thread:

Go to IP Configuration-> Domain Name System->DNS-Servers;
Add the DNS-server ip-addresses of your ISP or an public DNS-server you can use like 8.8.8.8 or 8.8.4.4
Click on host mapping to see if the DNS responds to the requests. IP Configuration-> Domain Name System->Host Mapping.

I know that thread. And even in this thread there is no solution.

 

Pinging hostname and nslookup works correctly from any Client which is connected to the switch.

But does it work from the switch itself ? Have you tried the last suggestion ?

dont know what you exactly mean? Can you please describe what I should do?

i did what you said. but no change at all -> see my screenshots (Switch + details of pfsense)

dns.JPGsntp_set.JPGsysttem_time.JPGpfsense.JPG

 

dns_client.JPG