cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1552
Views
14
Helpful
5
Replies
Highlighted
Beginner

Simulating T1 connection in Between two routers

Hi,

I am trying to run some test in between two servers. I have two 2811 with T1 card installed. I want to configure T1 on both routers that traffic wiil flow from one server to another server through T1 interface. If anybody can help me on that, would really appreciate. My configuration on both router as follows:

isdn switch-type primary-ni

controller T1 0/2/0

framing esf

linecode b8zs

cablelength short 133

pri-group timeslots 1-24

interface Serial0/2/0:23

no ip address

encapsulation hdlc

isdn switch-type primary-ni

isdn protocol-emulate network

no cdp enable

!

interface Serial0/2/0:23.1

ip address 10.1.1.1 255.255.255.0

Thanks

mrahman0302

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Master

Re: Simulating T1 connection in Between two routers

Hi,

1. need to configure "clock internal" under controller, for one router only.

2. please configure ip address under serial 0/2/0:1, do not use subinterfaces.

3. please re-enable keepalive that are intended and intended for proper operation.

4. You have a mismatch on the netmask on the the serial interface. To make it simpler, just use 255.255.255.0 on both router.

Hope this helps, please rate post if it does!

View solution in original post

5 REPLIES 5
Highlighted
Rising star

Re: Simulating T1 connection in Between two routers

Hi,

The above configuration shown is for ISDN PRI, however if you want to configure T1 line, the command would be :

no isdn switch-type primary-ni

controller T1 0/2/0

framing esf

linecode b8zs

cablelength short 133

no pri-group timeslots 1-24

channel-group 1 timeslots 1-24

And then you would require a "T1 Crossover Cable" which can be connected between the two interfaces.

HTH,

Please rate if it helps

Kind Regards,

Wilson Samuel

Highlighted
Beginner

Re: Simulating T1 connection in Between two routers

Hi Samuel,

Thanks for your reply. I have a question that do I need to configure serial interface, how the traffic will flow from one network to another network. Lets say I want traffic from x.x.x.x network to y.y.y.y network.

Thanks

mrahman0302

Highlighted
Rising star

Re: Simulating T1 connection in Between two routers

Hi,

That would be defined by the Routing process, you have basically two choices:

1. Static Routing

2. Dynamic Routing

If you select Static Routing you need to enter the Route statements

If you select a Routing protocol (for dynamic routing) then a suitable routing protocol needs to be configured.

Hope that helps,

Please rate all helpful posts

Kind Regards,

Wilson Samuel

Highlighted
Beginner

Re: Simulating T1 connection in Between two routers

Hi Samuel,

I tried the configuration but I can not communicate to other router. Here is my config:

Router A

controller T1 0/2/0

framing esf

linecode b8zs

cablelength short 133

channel-group 1 timeslots 1-24

interface FastEthernet0/0

ip address dhcp

duplex auto

speed auto

interface Serial0/2/0:1

no ip address

no keepalive

!

interface Serial0/2/0:1.1

ip address 10.1.1.252 255.255.255.240

router eigrp 1

network 10.0.0.0

auto-summary

Router B

controller T1 0/2/0

framing esf

linecode b8zs

cablelength short 133

channel-group 1 timeslots 1-24

interface FastEthernet0/0

ip address dhcp

duplex auto

speed auto

interface Serial0/2/0:1

no ip address

no keepalive

!

interface Serial0/2/0:1.1

ip address 10.1.1.253 255.255.255.224

router eigrp 1

network 10.0.0.0

network 172.20.0.0

auto-summary

Note : 1. I did configure encapsulation hdlc under serial interface but it doesn't show on the running configuration

2. Serial interface on both router is up.

Thanks

mrahman0302

Highlighted
Hall of Fame Master

Re: Simulating T1 connection in Between two routers

Hi,

1. need to configure "clock internal" under controller, for one router only.

2. please configure ip address under serial 0/2/0:1, do not use subinterfaces.

3. please re-enable keepalive that are intended and intended for proper operation.

4. You have a mismatch on the netmask on the the serial interface. To make it simpler, just use 255.255.255.0 on both router.

Hope this helps, please rate post if it does!

View solution in original post