cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1077
Views
0
Helpful
2
Replies

snmp trap on an isdn pri interface

rabeder
Beginner
Beginner

hi,

i have an isdn pri interface, which should NOT generate any trap if it goes up or down - this is the config:

interface Serial3/0:15

no ip address

encapsulation ppp

load-interval 30

timeout absolute 600 0

dialer pool-member 215

no snmp trap link-status

isdn switch-type primary-net5

no cdp enable

ppp authentication chap

ppp multilink

max-reserved-bandwidth 95

!

interface Dialer215

bandwidth 2048

ip address 1.1.1.1 255.255.255.252

encapsulation ppp

ip ospf cost 1000

load-interval 30

dialer pool 215

dialer remote-name mplsrbgope02

dialer string 123

dialer max-call 30

dialer watch-group 1

dialer-group 1

no snmp trap link-status

tag-switching mtu 1512

tag-switching ip

no cdp enable

ppp authentication chap callin

ppp chap hostname r-traun1

ppp multilink

BUT:

If i make a call to this interface (with my mobile or so), the router gnerates an snmp trap - so we get an info in our management - thats bad -

here is the snmp- debug:

r-traun1#debug snmp pa

SNMP packet debugging is on

r-traun1#

Nov 9 10:11:03.235: SNMP: Queuing packet to 10.18.120.225

Nov 9 10:11:03.235: SNMP: V1 Trap, ent ciscoIsdnMibTrapPrefix, addr 10.20.192.1, gentrap 6, spectrap 2

demandNbrLogIf.50.7 = 51

demandNbrAddress.50.7 = 67681411297

demandNbrLastDuration.50.7 = 0

demandNbrClearReason.50.7 = Incompatible destination

demandNbrClearCode.50.7 = 0x58

demandNbrCallOrigin.50.7 = 2

Nov 9 10:11:03.487: SNMP: Packet sent via UDP to 10.18.120.225

Nov 9 10:11:04.051: SNMP: Packet received via UDP from 10.18.120.225 on FastEthernet0/0.413

Nov 9 10:11:04.051: SNMP: Get request, reqid 5027855, errstat 0, erridx 0

ifEntry.1.14 = NULL TYPE/VALUE

ifEntry.8.14 = NULL TYPE/VALUE

ifEntry.7.14 = NULL TYPE/VALUE

Nov 9 10:11:04.059: SNMP: Response, reqid 5027855, errstat 0, erridx 0

ifEntry.1.14 = 14

ifEntry.8.14 = 1

ifEntry.7.14 = 1

Nov 9 10:11:04.067: SNMP: Packet sent via UDP to 10.18.120.225

r-traun1#un all

All possible debugging has been turned off

r-traun1#

i also tried the command "no snmp trap isdn-calls" - but no success

any idea????

thanks for any answer

2 Replies 2

lgijssel
Engager
Engager

The trap that is generated is not a link-state change trap. What snmp traps are enabled in the global snmp config?

Regards,

Leo

hi

thanks for answer - here are the global snmp config commands:

r-traun1#sh run | in snmp

no snmp trap link-status

no snmp trap link-status

no snmp trap link-status

no snmp trap link-status

no snmp trap link-status

no snmp trap link-status

no snmp trap link-status

no snmp trap link-status

snmp-server community xx RO 99

snmp-server community xx RW 99

snmp-server ifindex persist

snmp-server trap-source Loopback0

snmp-server location xx

snmp-server contact xx

snmp-server chassis-id S/N: 123

snmp-server system-shutdown

snmp-server enable traps snmp authentication linkdown linkup coldstart warmstart

snmp-server enable traps tty

snmp-server enable traps isdn call-information

snmp-server enable traps isdn layer2

snmp-server enable traps isdn chan-not-avail

snmp-server enable traps isdn ietf

snmp-server enable traps hsrp

snmp-server enable traps config

snmp-server enable traps entity

snmp-server enable traps frame-relay

snmp-server enable traps frame-relay subif

snmp-server enable traps syslog

snmp-server enable traps rtr

snmp-server host 1.2.3.4 public

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers