cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2670
Views
0
Helpful
13
Replies

Static IP Route

jprudencio7591
Beginner
Beginner

Hello,

 

I'm looking at setting up a new router for another branch that will be opening up. I cannot seem to get a static route to work. We are setup for VPLS through our ISP so all routes are pointed to 192.168.10.6 which is our hub site. Below is the sh run output for one of our other branches. What am I doing wrong? Why does it say "Gateway of last resort is 192.168.10.6 to network 0.0.0.0" instead of a static route?

 

Thanks,

 

version 15.4
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.0.3.1 10.0.3.189
ip dhcp excluded-address 10.0.3.204
ip dhcp excluded-address 10.0.3.250 10.0.3.255
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.128
default-router 10.10.10.1
lease 0 2
!
ip dhcp pool pool1
network 10.0.3.0 255.255.255.0
default-router 10.0.3.1
dns-server 10.0.2.9 8.8.8.8
lease 0 0 15
!
!
!
ip domain name
ip name-server 10.0.2.9
ip name-server 8.8.8.8
ip cef
no ipv6 cef
multilink bundle-name authenticated
!
cts logging verbose
!
!
redundancy
!

interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description to VPLS (192.168.10.6)
ip address 192.168.10.5 255.255.255.0
duplex auto
speed auto
!
interface GigabitEthernet0/1
description LAN
ip address 10.0.3.1 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 192.168.10.6
!
!


sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
a - application route
+ - replicated route, % - next hop override

Gateway of last resort is 192.168.10.6 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 192.168.10.6
10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C 10.0.3.0/24 is directly connected, GigabitEthernet0/1
L 10.0.3.1/32 is directly connected, GigabitEthernet0/1
192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, GigabitEthernet0/0
L 192.168.10.5/32 is directly connected, GigabitEthernet0/0

 

1 Accepted Solution

Accepted Solutions

In the recent post you tell us "The configuration you are looking at does work however I have not been able to get it to work with CPT ". If your concern is that it does not seem to work in CPT then I would not be too worried. I do not know why the emulator works differently but I am confident that the config that you show us should work fine on a real router.

 

HTH

 

Rick

 

 

 

HTH

Rick

View solution in original post

13 Replies 13

Harold Ritter
Cisco Employee
Cisco Employee

According to the "show ip route" that you provided, your static route is properly installed.

 

S* 0.0.0.0/0 [1/0] via 192.168.10.6

 

Do you have any connectivity issue with this new site?

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

I agree with Harold that the output shows that things appear to be configured correctly and that the configured static default route should be working. Perhaps we should ask the original poster why he is concerned with the statement about the gateway of last resort? Perhaps he does not recognize that any time that the routing logic has a default gateway, whether it is learned from a dynamic routing protocol or is configured with a static default route that the routing table information will identify the gateway of last resort without identifying how it was learned. Perhaps the confusion is just about the syntax of the statement.

 

HTH

 

Rick 

HTH

Rick

Hello,

I have not physically installed this router at the new branch. I have been planning the configuration with Cisco Packet Tracer. The configuration you are looking at does work however I have not been able to get it to work with CPT. I think I'm going to have to physically install and configure it and go from there. This new router should have the same routing table though correct? Since we are running VPLS all branch routes point to the same interface on the "Hub" site so the route would be the same

 

ip route 0.0.0.0 0.0.0.0 192.10.168.6

 

Adding that route to the new router should work correct?

 

Thanks

In the recent post you tell us "The configuration you are looking at does work however I have not been able to get it to work with CPT ". If your concern is that it does not seem to work in CPT then I would not be too worried. I do not know why the emulator works differently but I am confident that the config that you show us should work fine on a real router.

 

HTH

 

Rick

 

 

 

HTH

Rick

Thank you Rick. I'll be installing it tomorrow.

Thank you Harold as well

 

You are very welcome.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

HELP

 

So I reset configured a old 1841 router I had and I'm onsite and no connectivity. Here is the config for the 1841. Something missing in the routing are the local connections. Do I need to add other statc routes other than the 0.0.0.0 ? How do I do that.

 

hostname Alexandria-Test
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
 --More--         ip cef
!
!
no ip dhcp use vrf connected
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.0.4.1 10.0.4.100
ip dhcp excluded-address 10.0.4.201 10.0.4.255
!
ip dhcp pool ccp-pool
   import all
   network 10.10.10.0 255.255.255.128
   default-router 10.10.10.1
   lease 0 2
!
ip dhcp pool pool1
   network 10.0.4.0 255.255.255.0
   default-router 10.0.4.1
   dns-server 10.0.2.9 8.8.8.8
   lease 0 4
!
!
!
!
 --More--         !
!
interface FastEthernet0/0
 description VPLS Connection
 ip address 192.168.10.4 255.255.255.0
 speed 100
 full-duplex
!
interface FastEthernet0/1
 description Alexandria LAN
 ip address 10.0.4.1 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0/0
 no ip address
 shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.10.6
!
ip http server
!
 --More--         !
control-plane
!
!
line con 0
line aux 0
line vty 0 4
 login
!
end

Alexandria-Test#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is 192.168.10.6 to network 0.0.0.0

C    192.168.10.0/24 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 1 subnets
C       10.0.4.0 is directly connected, FastEthernet0/1
S*   0.0.0.0/0 [1/0] via 192.168.10.6

 

Your config and the output of the "show ip route" both look good. Could you tring pinging 192.168.10.6? If the ping doesn't work, the issue might be with the service provider.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

I cannot ping 192.168.10.6. Interestingly enough I had someone from our ISP there with me. He had come out to check the fiber connection to the SAS box. He could see the MAC address of our router from his end. I did have to enable IP Routing to get the Gateway of Last Resort to show up.I connected a PC to the switch and received a good IP from the DHCP server on the router, 10.0.4.102. That PC can ping 10.0.4.1 but cannot ping the IP 192.168.10.4 that's assigned to the other interface. It's like the subnets on each interface cannot see each other. Why in the working config that I posted first does it show Local networks but not on the second config? Does some type of static route need to be entered for them to see each other?

 

Thanks

You mention that you had to enable ip routing. Generally ip routing is enabled on routers like this. But perhaps you had disabled ip routing as you cleared the original config. At any rate enabling ip routing would be required to get the gateway of last resort to work, and would be required to be able to route between subnets. I am not sure why you are not able to ping 192.168.10.6. Perhaps a next step in investigating this would be to post the output of show arp (or perhaps show ip arp) from your router. This should verify whether you have a good layer 2 connection to the device (and also verify layer 2 connectivity to the PC that is connected). It might also be helpful if you would post the output of the commands show ip interface brief and of show ip protocol.

 

HTH

 

Rick

HTH

Rick

Hello,

 

Sorry for the late response. I was having no luck with the test bed router so I decided to take the new production router to the new site and connect and configure it there. After configuring interfaces, passwords, and DHCP pools I added the static route:

 

ip route 0.0.0.0 0.0.0.0 192.168.10.6

 

BOOM! Everything connected just fine. I could ping all of the other routers and anything inside of our WAN but I still could not ping outside of our WAN. I needed to add a static route for the new router to our Watchguard firewall. Once that route(s) was added I could ping the outside world.

 

Thank you for your patience and help

Thanks for posting back to the forum and letting us know that you have resolved the problem. It may not be surprising to find that there was some problem with the test bed router and that when configuring the same things on a new router to find that they work as expected. There were some suggestions about whether the ISP had routes to your networks connected through the new router. It is a similar situation to need routes on the firewall.

 

Congratulations

 

HTH

 

Rick

HTH

Rick
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers