cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1283
Views
0
Helpful
6
Replies

Static NAT

Ethan55
Level 1
Level 1

Hi all guys,

I have a simple static NAT config.

Topo

Client (f0/1) ----192.168.0.0/24----(f0/1)R1(f0/0)----200.0.0.0/24----(f0/0)R2

IP addresses

IP Client:

f0/1: 192.168.0.10/24

IP R1:

f0/1: 192.168.0.1/24

f0/0: 200.0.0.1/24

IP R2:

f0/0: 200.0.0.10/24

 

Config

Client:

ip route 0.0.0.0 0.0.0.0 192.168.0.1

R1:

interface FastEthernet0/1
ip nat inside

 

interface FastEthernet0/0
ip nat outside

 

Question

If I config static NAT on R1 like below:

ip nat inside source static 192.168.0.10 200.0.0.1

or

ip nat inside source static 192.168.0.10 interface f0/0

I can ping from client to 200.0.0.10 successfully.

But if I config static NAT on R1 like below:

ip nat inside source static 192.168.0.10 200.0.0.2

I can't ping from client to 200.0.0.10 successfully. R1 doesn't forward ICMP reply from R2 to Client.

 

Please give me some suggestions.

Thank you.

1 Accepted Solution

Accepted Solutions

tituscs
Level 1
Level 1

This should work normally ,
Do you see NAT translations on R1 ?

Do you see ARP for 200.0.0.2 on R2 ?

View solution in original post

6 Replies 6

tituscs
Level 1
Level 1

This should work normally ,
Do you see NAT translations on R1 ?

Do you see ARP for 200.0.0.2 on R2 ?

Hi Tituscs,

I delete all config and re-config again and it works normally.

R1#show ip nat translations
Pro Inside global Inside local Outside local Outside global
icmp 200.0.0.2:3 192.168.0.10:3 200.0.0.10:3 200.0.0.10:3
icmp 200.0.0.2:4 192.168.0.10:4 200.0.0.10:4 200.0.0.10:4
--- 200.0.0.2 192.168.0.10 --- ---

 

R2#show ip arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 200.0.0.1 4 c207.2bf8.0000 ARPA FastEthernet0/0
Internet 200.0.0.2 2 c207.2bf8.0000 ARPA FastEthernet0/0
Internet 200.0.0.10 - c208.2ab4.0000 ARPA FastEthernet0/0

 

You are doing a static NAT to interface f0/0 of R1. I don't think you could make that work unless you were doing an overload, and then that would only allow outbound. Assuming nothing else is occupying 200.0.0.2, trying using that as the outside address for the static.

Hi Elliot,

I don't know why but I deleted all config and re-config again and it works normally.

Hello

Do the rtr's have any static routing, as from youve decribed they dont require any and it should work.

 

Please post the following of the rtrs
sh run
sh ip aliases
sh arp


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Hi Paul,

This is all config.

I don't know why but I deleted all config and re-config again and it works normally.

Client#show running-config
hostname Client
!
interface FastEthernet0/1
ip address 192.168.0.10 255.255.255.0
duplex auto
speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.0.1
!
===
R1#show running-config
hostname R1
!
interface FastEthernet0/0
ip address 200.0.0.1 255.255.255.0
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 192.168.0.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
ip nat inside source static 192.168.0.10 200.0.0.2
!
===
R2#show running-config
hostname R2
!
interface FastEthernet0/0
ip address 200.0.0.10 255.255.255.0
duplex auto
speed auto
!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Review Cisco Networking products for a $25 gift card