cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
198
Views
0
Helpful
2
Replies
Highlighted
Beginner

Static route | BGP | Route-map

Here is my Network,

 

Have a VLAN in a switch which was connected to a Router which does BGP. If i use static route on my switch to send traffic to BGP router. I am able to ping VLAN interface ip address from other end also, i am able to ping from my end. But if I use route-map to match the traffic from my lan to send to BGP route using set ip next-hop  BGP route IP or set ip default next-hop BGP route IP. Ping from my end to other end work fine. But from my other end to my end drops at my BGP router.

2 REPLIES 2
Enthusiast

Re: Static route | BGP | Route-map


we probably need to see some configs to solve this like BGP router settings, route-map configs, what is route-map for? is it use for Policy Based Routing ?
Beginner

Re: Static route | BGP | Route-map

Thanks very much for the quick reply.

 

Here is my Switch Config. 

 

route-map GET permit 10
match policy-list GET_LAN
set ip next-hop 192.168.200.1

 

sh ip access-lists GET_LAN
Extended IP access list GET_LAN
10 permit ip 10.30.110.0 0.0.0.255 10.0.23.0 0.0.0.255
20 permit ip 10.30.110.0 0.0.0.255 10.1.10.0 0.0.0.255
30 permit ip 10.30.110.0 0.0.0.255 10.1.13.0 0.0.0.255

 

sh running-config interface vlan 110
Building configuration...

Current configuration : 94 bytes
!
interface Vlan110
ip address 10.30.110.1 255.255.255.0
ip policy route-map GET
end

 

BGP config 

 

router bgp 65xx
bgp log-neighbor-changes
network 10.30.110.0 mask 255.255.255.0
network 192.168.200.0 mask 255.255.255.252
redistribute static
neighbor 10.xx.x.22 remote-as 21326
neighbor 10.xx.x.22 update-source GigabitEthernet0/0
neighbor 10.xx.x.22 soft-reconfiguration inbound

 

sh ip bgp neighbors 10.xxx.x.22 received-routes
BGP table version is 9, local router ID is 192.168.200.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 10.0.23.0/24 10.254.1.22 0 21326 13979 65005 i
*> 10.1.10.0/24 10.254.1.22 0 21326 13979 65005 i
*> 10.1.13.0/24 10.254.1.22 0 21326 13979 65005 i
*> 10.254.1.12/30 10.254.1.22 0 21326 13979 65005 i
r> 10.254.1.20/30 10.254.1.22 0 0 21326 i
*> 192.168.1.0/30 10.254.1.22 0 0 21326 i

 

sh ip bgp neighbors 10.xxx.x.22 advertised-routes
BGP table version is 9, local router ID is 192.168.200.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

Network Next Hop Metric LocPrf Weight Path
*> 10.30.110.0/24 192.168.200.2 0 32768 i
*> 192.168.200.0/30 0.0.0.0 0 32768 i

Total number of prefixes 2

 

If i add a static route on my switch "ip route 10.0.23.0 255.255.255.0 192.168.200.1" only then i am able to ping  10.30.110.1 from remote end.

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards