cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
174
Views
5
Helpful
5
Replies
Participant

sub interfaces on cisco 2951 router

I am trying to setup sub interfaces on the LAN side of my router and am having issues getting out to the internet. Any suggestions? Here is my config

 

interface GigabitEthernet0/0
description To_WAN_Switch
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/0.1
description Guest_Network
encapsulation dot1Q 501
ip address 2.26.21.134 255.255.255.248
!
interface GigabitEthernet0/1
description InBound_From_Level3
ip address 2.9.15.118 255.255.255.252
ip access-group Block_Stuff in
duplex auto
speed auto

ip route 0.0.0.0 0.0.0.0 2.9.15.117


I've assigned the IP 2.26.21.129 on a laptop and can ping 2.26.21.134 but not 2.9.15.118 or outbound to the internet.



1 ACCEPTED SOLUTION

Accepted Solutions
Advocate

Re: sub interfaces on cisco 2951 router

Hi @jkay18041 

 

Check this out to start:

-Your Laptop has the correct gateway?

- Have you tried disabling the firewall of the Laptop?

-Do both networks exist in the routing table?

 

Regards

5 REPLIES 5
Advocate

Re: sub interfaces on cisco 2951 router

Hi @jkay18041 

 

Check this out to start:

-Your Laptop has the correct gateway?

- Have you tried disabling the firewall of the Laptop?

-Do both networks exist in the routing table?

 

Regards

Participant

Re: sub interfaces on cisco 2951 router

Helps when the fiber is plugged in :)

VIP Advisor

Re: sub interfaces on cisco 2951 router

Why do you need sub interface if only 1 subinterface you configured on the device, instead you can directly configure the IP address to interface right?

 

BB
*** Rate All Helpful Responses ***
Highlighted
VIP Advisor

Re: sub interfaces on cisco 2951 router

Hello

The wan switch connection to the router need to be a trunk, The access port on the switch connection to your laptop needs to be in vlan 501, Lastly make sure the acl isnt negating access also?

 



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Participant

Re: sub interfaces on cisco 2951 router

I had forgotten to plug the fiber into the ISP switch after I removed it.

 

I only have 1 of the sub interfaces configured at the time.

 

Thanks 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards