cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1438
Views
0
Helpful
9
Replies
Highlighted

T1 Multilink ppp failure

Hi everyone,

I am having troubles to enable 3xT1 ppp multilink between a 3745 and a 2921 with WICs, through a ISP WAN cloud. both sides are taking clock from ISP.                  

Today this connection is made between a 3745 on each side, and in this scenario, multilink ppp 3xT1 is working. however, since i have to replace one 3745  for an 2921, bundle goes down

i will paste both configs parts if anyone have any idea whats going on...IPs are shown as example, are not the real ones

3745:

.....

no network-clock-participate slot 1
no network-clock-participate slot 2
no network-clock-participate slot 3
no network-clock-participate slot 4

.....

interface Multilink1

description to_2921_router

ip address 1.1.1.1 255.255.255.252

ppp multilink

ppp multilink group 1

interface Serial0/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!

interface Serial3/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!

interface Serial4/0
no ip address
encapsulation ppp
ppp multilink
ppp multilink group 1
!

-------------------------------------

new 2921:

.....

no network-clock-participate wic 0

no network-clock-participate wic 1

!

multilink bundle-name authenticated
!

controller T1 0/0/0

cablelength long 0db

channel-group 1 timeslots 1-24

!

controller T1 0/0/1

cablelength long 0db

channel-group 1 timeslots 1-24

!

controller T1 0/1/0

cablelength long 0db

channel-group 1 timeslots 1-24

!

interface Multilink1

description PPP_to_3745

ip address 1.1.1.2 255.255.255.252

ip nat inside

ip virtual-reassembly in

ppp multilink

ppp multilink group 1

!

interface Serial0/0/0:1
no ip address
ip nat inside
ip virtual-reassembly in
encapsulation ppp
ppp multilink
ppp multilink group 1
!

interface Serial0/0/1:1

no ip address

ip nat inside

ip virtual-reassembly in

encapsulation ppp

ppp multilink

ppp multilink group 1

!

interface Serial0/1/0:1
no ip address
ip nat inside
ip virtual-reassembly in
encapsulation ppp
ppp multilink
ppp multilink group 1
!

----------------------

here is the output command for eache Serial interface 2921 router

Serialx/x/x:x is up, line protocol is down

  Hardware is DSX1

  MTU 1500 bytes, BW 256 Kbit/sec, DLY 20000 usec,

     reliability 192/255, txload 1/255, rxload 1/255

  Encapsulation PPP, LCP REQsent, multilink Closed, crc 16, loopback not set

Multilink1 is down, line protocol is down
  Hardware is multilink group interface

--------------------------------

anyone have any idea why is not going up this serials?

my guess is that something is going on with "multilink bundle-name authenticated" command.

thanks in advance!

9 REPLIES 9
Highlighted
Hall of Fame Guru

While the command multilink bundle-name authenticated is a command found on the new router and not on the older router it may seem to be a candidate for what is causing the problem. But I do not think that this is really the issue. That command is inserted into the config automatically in many newer versions of IOS and I doubt that it is the real cause of your problem.

Perhaps you could post the output of show controller for the serial interfaces on the 2921 and we might get some insight from that?

HTH

Rick

HTH

Rick
Highlighted

Richard,

Here is the output for show controller from the serial interfaces on the 2921...

T1 0/0/1 is up.

  Applique type is Channelized T1

  Cablelength is long 0db

--More--                             No alarms detected.

--More--                             alarm-trigger is not set

--More--                             Soaking time: 3, Clearance time: 10

--More--                             AIS State:Clear  LOS State:Clear  LOF State:Clear

--More--                             Version info FPGA Rev: 08121917, FPGA Type: PRK4

--More--                             Framing is ESF, Line Code is B8ZS, Clock Source is Line.

--More--                             CRC Threshold is 320. Reported from firmware  is 320.

--More--                             Data in current interval (93 seconds elapsed):

--More--                                0 Line Code Violations, 0 Path Code Violations

--More--                                0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

--More--                             Total Data (last 24 hours)

--More--                                3703 Line Code Violations, 9 Path Code Violations,

--More--                                0 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,

--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 82821 Unavail Secs

--More--                           T1 0/1/0 is up.

--More--                             Applique type is Channelized T1

--More--                             Cablelength is long 0db

--More--                             No alarms detected.

--More--                             alarm-trigger is not set

--More--                             Soaking time: 3, Clearance time: 10

--More--                             AIS State:Clear  LOS State:Clear  LOF State:Clear

--More--                             Version info FPGA Rev: 08121917, FPGA Type: PRK4

--More--                             Framing is ESF, Line Code is B8ZS, Clock Source is Line.

--More--                             CRC Threshold is 320. Reported from firmware  is 320.

--More--                             Data in current interval (86 seconds elapsed):

--More--                                0 Line Code Violations, 0 Path Code Violations

--More--                                0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

--More--                             Total Data (last 24 hours)

--More--                                3698 Line Code Violations, 7 Path Code Violations,

--More--                                0 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,

--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 82716 Unavail Secs

--More--                           T1 0/1/1 is up.

--More--                             Applique type is Channelized T1

--More--                             Cablelength is long 0db

--More--                             No alarms detected.

--More--                             alarm-trigger is not set

--More--                             Soaking time: 3, Clearance time: 10

--More--                             AIS State:Clear  LOS State:Clear  LOF State:Clear

--More--                             Version info FPGA Rev: 08121917, FPGA Type: PRK4

--More--                             Framing is ESF, Line Code is B8ZS, Clock Source is Line.

--More--                             CRC Threshold is 320. Reported from firmware  is 320.

--More--                             Data in current interval (86 seconds elapsed):

--More--                                0 Line Code Violations, 0 Path Code Violations

--More--                                0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins

--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs

--More--                             Total Data (last 24 hours)

--More--                                4207 Line Code Violations, 2 Path Code Violations,

--More--                                0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,

--More--                                1 Errored Secs, 1 Bursty Err Secs, 0 Severely Err Secs, 82501 Unavail Secs T1 0/0/1 is up.
  Applique type is Channelized T1
  Cablelength is long 0db
--More--                             No alarms detected.
--More--                             alarm-trigger is not set
--More--                             Soaking time: 3, Clearance time: 10
--More--                             AIS State:Clear  LOS State:Clear  LOF State:Clear
--More--                             Version info FPGA Rev: 08121917, FPGA Type: PRK4
--More--                             Framing is ESF, Line Code is B8ZS, Clock Source is Line.
--More--                             CRC Threshold is 320. Reported from firmware  is 320.
--More--                             Data in current interval (93 seconds elapsed):
--More--                                0 Line Code Violations, 0 Path Code Violations
--More--                                0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
--More--                             Total Data (last 24 hours)
--More--                                3703 Line Code Violations, 9 Path Code Violations,
--More--                                0 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 82821 Unavail Secs
--More--                           T1 0/1/0 is up.
--More--                             Applique type is Channelized T1
--More--                             Cablelength is long 0db
--More--                             No alarms detected.
--More--                             alarm-trigger is not set
--More--                             Soaking time: 3, Clearance time: 10
--More--                             AIS State:Clear  LOS State:Clear  LOF State:Clear
--More--                             Version info FPGA Rev: 08121917, FPGA Type: PRK4
--More--                             Framing is ESF, Line Code is B8ZS, Clock Source is Line.
--More--                             CRC Threshold is 320. Reported from firmware  is 320.
--More--                             Data in current interval (86 seconds elapsed):
--More--                                0 Line Code Violations, 0 Path Code Violations
--More--                                0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
--More--                             Total Data (last 24 hours)
--More--                                3698 Line Code Violations, 7 Path Code Violations,
--More--                                0 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 82716 Unavail Secs
--More--                           T1 0/1/1 is up.
--More--                             Applique type is Channelized T1
--More--                             Cablelength is long 0db
--More--                             No alarms detected.
--More--                             alarm-trigger is not set
--More--                             Soaking time: 3, Clearance time: 10
--More--                             AIS State:Clear  LOS State:Clear  LOF State:Clear
--More--                             Version info FPGA Rev: 08121917, FPGA Type: PRK4
--More--                             Framing is ESF, Line Code is B8ZS, Clock Source is Line.
--More--                             CRC Threshold is 320. Reported from firmware  is 320.
--More--                             Data in current interval (86 seconds elapsed):
--More--                                0 Line Code Violations, 0 Path Code Violations
--More--                                0 Slip Secs, 0 Fr Loss Secs, 0 Line Err Secs, 0 Degraded Mins
--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 0 Unavail Secs
--More--                             Total Data (last 24 hours)
--More--                                4207 Line Code Violations, 2 Path Code Violations,
--More--                                0 Slip Secs, 0 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
--More--                                1 Errored Secs, 1 Bursty Err Secs, 0 Severely Err Secs, 82501 Unavail Secs

Highlighted

Christian,

This probably has little to do with your issue, but why do you have "ip nat inside" on the mlp interface on the 2921? You should remove that as well as on all of your serial interfaces.

HTH,
John

*** Please rate all useful posts ***

HTH, John *** Please rate all useful posts ***
Highlighted

John,

As you didnt see present ip nat inside in old router, might confused you. However, in old router already exists 'ip nat inside' and 'ip virtual-reassembly in' on serial as well as on multilink config.

I forgot to paste it in first post.

so my guess is that is not affecting this issue.

Highlighted
Hall of Fame Master

Update IOS and check again.

Highlighted

What i didnt mention is that

3745 wic card model is WIC-1DSU-T1-V2

and 2921 ISR wic card model is HWIC-2CE1T1-PRI

shall you see any problem with this?

Highlighted

One would need to obtain much more information to say.

You should open a TAC case.

Highlighted

Thanks for posting the output of show controller as I requested. What jumps out at me from the output is this

--More--                             Total Data (last 24 hours)
--More--                                3703 Line Code Violations, 9 Path Code Violations,
--More--                                0 Slip Secs, 1 Fr Loss Secs, 1 Line Err Secs, 0 Degraded Mins,
--More--                                0 Errored Secs, 0 Bursty Err Secs, 0 Severely Err Secs, 82821 Unavail Secs

In the 24 hour period the controller sees the circuit as available only 3579 seconds. If the circuit ran clean on the old connection then I believe that this suggests that there is a problem with the cards (or less likely with the router or with the code that it is running). Can you tell us what version of code is running on the 2921?

One article that I looked at suggests that this card does channelized T1 and that including the parameter for unframed for the channel group might be helpful.

HTH

Rick

HTH

Rick
Highlighted

Richard,

Thanks for your response.

The version of code that is running on the 2921 is the c2900-universalk9_npe-mz.SPA.152-4.M2.bin

thanks in advance