cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
212
Views
0
Helpful
6
Replies
Highlighted
Beginner

Take ibgp path for some routes in BGP multihome environment

Hello all,

Please reference the image for convenience. 

 

R1 and R2 are our routers running ebgp with two isp R3 and R4 which are sending default routes towards us.

R1 and R2 are ibgp peers also sending default route to each other also running vrrp.

R5 is some cloud which is exporting R6 interface ip to bgp for isp R3 and R4. [TEST CASE]

R7 is our internal network with different ip prefixes. R1 and R2 has static route to ip prefixes in R7.[ TEST CASE]

 

What i want to accomplish is for eg,

i want ip prefix of 1.1.1.0 from R7 to prefer path through isp from R3 but another ip prefix 2.2.2.0 from R7 to prefer path through ibgp and another isp i.e R4.

 

Please help me on this.
Thanks.

 

 

 

Everyone's tags (4)
6 REPLIES 6
VIP Advisor

Re: Take ibgp path for some routes in BGP multihome environment

look at the below example and sample config for your reference :

 

https://www.cisco.com/c/en/us/support/docs/ip/border-gateway-protocol-bgp/28784-bgp-community.html

BB
*** Rate All Helpful Responses ***
Beginner

Re: Take ibgp path for some routes in BGP multihome environment

is there any method using route-map and not community?

VIP Advisor

Re: Take ibgp path for some routes in BGP multihome environment

Beginner

Re: Take ibgp path for some routes in BGP multihome environment

thanks for your time in this, BUT
I want some prefix to go to the vrrp master router then that specific prefix should take the ibgp path to the vrrp slave router and then to the isp?
Can you suggest some options to achieve this.

 

In both of our internal routing tables, there will be a default route from isp and ibgp, (route from isp always preferred)

 

VIP Advisor

Re: Take ibgp path for some routes in BGP multihome environment

can you post your exiting configuration to look and suggest to best way ?

 

BB
*** Rate All Helpful Responses ***
Beginner

Re: Take ibgp path for some routes in BGP multihome environment

Here are the configs

 

Router1(our side)

interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.1 255.255.255.0
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 103.255.126.253 255.255.255.0
duplex auto
speed auto
vrrp 1 description F1
vrrp 1 ip 103.255.126.111
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
ip address 182.93.88.62 255.255.255.0
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 13092
no synchronization
bgp log-neighbor-changes
network 103.233.182.0 mask 255.255.255.0
network 103.255.126.0 mask 255.255.255.0
neighbor 2.2.2.2 remote-as 13092
neighbor 2.2.2.2 update-source Loopback0
neighbor 2.2.2.2 next-hop-self
neighbor 2.2.2.2 route-map SUBISU-IN in
neighbor 182.93.88.61 remote-as 4007
neighbor 182.93.88.61 route-map SUBISU-IN in
neighbor 182.93.88.61 route-map SUBISU-OUT out
no auto-summary
!
ip forward-protocol nd
ip route 2.2.2.0 255.255.255.0 103.255.126.250
ip route 103.233.182.0 255.255.255.0 FastEthernet0/1
!
!
no ip http server
no ip http secure-server
!
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list P1 seq 5 permit 103.255.126.0/24
!
ip prefix-list P2 seq 5 permit 103.233.182.0/24
!
!
!
route-map SUBISU-IN permit 10
match ip address prefix-list DEFAULT
!
route-map SUBISU-OUT permit 10
match ip address prefix-list P1 P2
!

 

 

Router2(our side)

interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
shutdown
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 103.255.126.250 255.255.255.0
duplex auto
speed auto
vrrp 1 description F1
vrrp 1 ip 103.255.126.111
vrrp 1 priority 90
!
interface Serial1/0
ip address 202.79.34.61 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 13092
no synchronization
bgp log-neighbor-changes
network 103.233.182.0 mask 255.255.255.0
network 103.255.126.0 mask 255.255.255.0
neighbor 1.1.1.1 remote-as 13092
neighbor 1.1.1.1 update-source Loopback0
neighbor 1.1.1.1 next-hop-self
neighbor 202.79.34.1 remote-as 17501
neighbor 202.79.34.1 route-map WLINK-IN in
neighbor 202.79.34.1 route-map WLINK-OUT out
no auto-summary
!
ip forward-protocol nd
ip route 1.1.1.0 255.255.255.0 103.255.126.253
ip route 103.233.182.0 255.255.255.0 FastEthernet0/1
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list DEFAULT seq 5 permit 0.0.0.0/0
!
ip prefix-list P1 seq 5 permit 103.255.126.0/24
!
ip prefix-list P2 seq 5 permit 103.233.182.0/24
!
!
!
route-map WLINK-OUT permit 10
match ip address prefix-list P1 P2
!
route-map WLINK-IN permit 5
match ip address prefix-list DEFAULT
!
!

##ignore the fast 0/0 interface in both routers##

## the isp are just sending the default route towards us.##

 

I have attached image for show ip bgp  output for both routers, what i want to do is I want prefix P1 to take the ebgp route via the vrrp master router, but another prefix P2 to take the ibgp path to our 2nd router and then go to another ISP.(outbound).

 

Its been quite some time I am trying to figure this out.

Hope someone can help.

 

 

 

 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards