cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2041
Views
0
Helpful
4
Replies

telnet HWIC-3G-GSM is not working

d-mercado
Beginner
Beginner

I tried to telnet my cellular interface but it didn't work. It showing refused by remote host. Need your help please.

interface Cellular0/0/0
ip address 192.168.81.78 255.255.255.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 180
dialer string GSM
dialer-group 1
async mode interactive
ppp chap refuse
!
line 0/0/0
exec-timeout 0 0
script dialer GSM
modem InOut
no exec
transport input all
transport output all
rxspeed 3600000
txspeed 384000
line vty 0 4
privilege level 15
password 7 01161F014F0F
login
transport input all
line vty 5 15
privilege level 15
password 7 0949570C0D01
login
transport input all

test#sh ip int brief
Interface                  IP-Address      OK? Method Status                Protocol
Cellular0/0/0              192.168.81.78   YES NVRAM  up                    up  


test#telnet 192.168.81.78 2002
Trying 192.168.81.78, 2002 ...
*Dec 16 08:38:11.099: %LINK-3-UPDOWN: Interface Cellular0/0/0, changed state to up
% Connection refused by remote host

4 Replies 4

mavespig
Participant
Participant

Hi,

are you trying to reverse telnet to the GSM modem, to give AT commands?

It is not recommended to execute AT commands on 3G cards, you should do it only if explicitly asked by TAC/Developers.

Anyway, to reverse telnet you need first to be sure that the line is the right one. You are using line 2 (port 2002), double check with show line if it's the right one.

Then, if the line is currently in use it will not allow you to telnet, as IOS is already using it to communicate with the modem.

In your capture I see that right after the telnet you have a "Interface Cellular0/0/0, changed state to up", so in that case you can't access the modem.

Try using "clear line xxx" and telnet again.

Hope this helps

Marco

Actually my main objective to have a remote access to the router. My problem is the service provider they allow only one ip address ( which is the ip address of the Cellular interface). The LAN IP address is NATted. This is located in the remote branch. What is my option to do it?

interface FastEthernet0/0
ip address 11.202.30.1 255.255.255.0

ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!        
interface Cellular0/0/0
ip address 192.168.81.78 255.255.255.0
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 180
dialer string GSM
dialer-group 1
async mode interactive
ppp chap refuse

now it working now, What I did, I reassinged the ip address from cellular interface to the loopback interface. then configured the cellular interface as interface Cellular0/0/0
ip unnumbered Loopback0

Hi, if you just need to telnet the router, then why are you using port 2002?

shouldn't you just telnet to 192.168.81.78?

From a telnet perspective I don't see a difference between configuring the address directly on the cellular interface or configure the cellular as unnumbered on a loopback.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers