cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Cisco announces new innovations in SD-WAN, ISRs, SD-WAN Services, and Catalyst 9000 Series switches


228
Views
10
Helpful
33
Replies
Enthusiast

Tftp issue with new devices (9300 & 3850)

cant copy the config files from these swicthes...

 

error logs 

 

DC1XCIK1#copy startup-config tftp:
Address or name of remote host []? 192.168.19.8
Destination filename [DC1xcik1-confg]?
!.....
%Error writing tftp://192.168.19.8/DC1xcik1-confg (Timed out).....

 

I can ping tftp server and vice versa from laptop

ip tftp source interface is also configured...

what could be the reason..?

 

Thanks in advance

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Enthusiast

Re: Tftp issue with new devices (9300 & 3850)

Now issue have been resolved by using the command;

 

"ip tftp blocksize 512"

 

I dont undersatnd why cisco says that "By default, the Catalyst 3850 uses a TFTP block size value of 512"

 

Thank all of you.

33 REPLIES
VIP Mentor

Re: Tftp issue with new devices (9300 & 3850)

Hello,

 

what do you use as TFTP server ? Make sure you have specified the correct folder on your TFTP server. Right now you arevtrying to save the file to the root of your TFTP server...

Re: Tftp issue with new devices (9300 & 3850)

Check if you mark correct folder and your tftp already configured to read and write.

VIP Engager

Re: Tftp issue with new devices (9300 & 3850)

if this is windows 10 Laptop, check the it got built in FW enabled on windows 10. disable and try other option adding to other post.

 

BB
*** Rate All Helpful Responses ***
Hall of Fame Master

Re: Tftp issue with new devices (9300 & 3850)

The original post tells this

I can ping tftp server and vice versa from laptop

Can the original poster clarify whether the device is able to ping the tftp server, specifying that the source address for the ping is the address configured as tftp source address?

 

Also can the original poster tell us whether after making an attempt to tftp the file there are any messages on the tftp server showing that it received an attempt to copy the config file?

 

I have had the experience with some implementations of tftp server that the file name must already exist in the directory that the tftp server will use (sometimes is the root directory as suggested in a previous response and sometimes is a directory specified in the tftp setup). It might be worth a try to create the file in the appropriate directory and see if that makes any difference.

 

If there is not progress toward a solution it might provide helpful information to run debug for tftp, attempt the tftp copy, and post the debug output.

 

HTH

 

Rick

 

Beginner

Re: Tftp issue with new devices (9300 & 3850)

Can you post the running config so we can see the settings of your switch?  

Enthusiast

Re: Tftp issue with new devices (9300 & 3850)

here is the config from other swicth(9300)

 

no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
no platform punt-keepalive disable-kernel-core
!
hostname
!
!
vrf definition Mgmt-vrf
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!
logging buffered informational
no logging console
!
no aaa new-model
clock timezone MET 1 0
clock summer-time MEST recurring last Sun Mar 2:00 last Sun Oct 3:00
switch 1 provision c9300-48uxm
switch 2 provision c9300-48t
!
!
!
!
ip routing
!
no ip domain lookup
ip domain name
no ip dhcp use vrf connected
!
!
ip dhcp snooping
login on-failure log
login on-success log
!
!
!
!
!
!
!
vtp domain xyz
vtp mode transparent
!
!
diagnostic bootup level minimal
!
spanning-tree mode mst
spanning-tree extend system-id
spanning-tree uplinkfast
spanning-tree vlan 1-4094 priority 24576
!
spanning-tree mst configuration
name pune
revision 1
instance 1 vlan -4094
!
spanning-tree mst 0-1 priority 24576
archive
path tftp://10.18.2.17/$h
write-memory
time-period 10080
!
username ......
!
redundancy
mode sso
!
!
vlan 1-4094
!
interface Vlan1
ip address 10.60.1.2 255.255.255.0
standby 1 ip 10.60.1.1
standby 1 priority 110
standby 1 preempt
!
ip forward-protocol nd
ip http server
ip http authentication local
ip http secure-server
ip tftp source-interface Vlan1
ip route 0.0.0.0 0.0.0.0 10.60.7.254
!
ip ssh version 2
!
!
logging trap warnings
logging source-interface Vlan21
logging host 10.18.2.18
!
snmp-server community cwlesen RO
snmp-server trap-source Vlan21
snmp-server location Pune
snmp-server contact Mr. test
snmp-server enable traps snmp authentication coldstart warmstart
snmp-server enable traps license
snmp-server enable traps envmon fan shutdown supply temperature status
snmp-server enable traps config
snmp-server enable traps syslog
snmp-server host 192.168.xx.xx v2
snmp ifmib ifindex persist
!
!
control-plane
service-policy input system-cpp-policy

 

Thanks

Hall of Fame Guru

Re: Tftp issue with new devices (9300 & 3850)

ip tftp source vlan 1
Enthusiast

Re: Tftp issue with new devices (9300 & 3850)

still the same issue...

Hall of Fame Guru

Re: Tftp issue with new devices (9300 & 3850)


@ittechk4u1 wrote:

Destination filename [DC1xcik1-confg]?
!.....
%Error writing tftp://192.168.19.8/DC1xcik1-confg (Timed out).....


So the process wrote something and then stopped.  

I've seen this before and the issue is the TFTP server. 

Can you try getting another machine to be the TFTP server? 

Enthusiast

Re: Tftp issue with new devices (9300 & 3850)

1. I can ping from laptop to switch

2. I can ping from switch to laptop.

3. Used two other workstation/laptop, still the issue is same.

4. i can see the request coming to TFTP server .

 

Thanks in advance

Highlighted
VIP Mentor

Re: Tftp issue with new devices (9300 & 3850)

Hello,

 

the destination filename (Destination filename [DC1xcik1-confg]) does not match the file name in your screenshot, why is that ?

What is the hostname of your switch (doesn't show in your running config) ?

Enthusiast

Re: Tftp issue with new devices (9300 & 3850)

sorry ..

i just change the file name due to security issues..... FYI...it matches.

 

Thanks

VIP Mentor

Re: Tftp issue with new devices (9300 & 3850)

Hello,

 

not sure if this has been answered before, but what do you use as TFTP server ? And what OS (e.g. Wndows 10) is the TFTP server running on ?

Enthusiast

Re: Tftp issue with new devices (9300 & 3850)

I am using 3CDaemon as TFTP server and its running on win10 & win 7(tried both)

CreatePlease to create content
Content for Community-Ad

Blog-Cisco Community Designated VIP Dinner CLEUR2019