cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
821
Views
20
Helpful
6
Replies

The purpose of defining "address-family" within VRF in Nexus

May I know the purpose of Defining

address-family 

within VRF? Is it required on a Nexus platform? I'm trying to understand the real life scenarios? In my case, I'm going to create a VRF for a VPC keepalive.

1 Accepted Solution

Accepted Solutions

using different

 import export for each address-family

is one case that we use

address-family

under VRF. 
for your case only for keepalive I dont think you need

address-family

 

View solution in original post

6 Replies 6

using different

 import export for each address-family

is one case that we use

address-family

under VRF. 
for your case only for keepalive I dont think you need

address-family

 

Hi @MHM Cisco World ,

With the new VRF cli (i.e. vrf definition <vrf-name>), you are forced to specify the address family you want (ipv4 and/or ipv6). Otherwise you will get an error message as follow when trying to configure the ipv4 or ipv6 address on the interface:

R3(config)#vrf definition test
R3(config-vrf)#int gi0/2
R3(config-if)#vrf forwarding test
R3(config-if)#ip address 192.168.1.1 255.255.255.0
%GigabitEthernet0/2 is linked to a VRF. Enable IPv4 on that VRF first.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

this also apply to Nexus ?

FROM cisco Doc.
Cisco Nexus 9000 Series NX-OS Interfaces Configuration Guide, Release 7.x - Configuring vPCs [Cisco Nexus 9000 Series Switches] - Cisco

 

  1. Create a separate VRF for the vPC peer-keepalive link and add a Layer 3 interface to that VRF.

    switch(config)# vrf context pkal
    switch(config-vrf)# exit
    switch(config)# interface ethernet 8/1
    switch(config-if)# vrf member pkal
    switch(config-if)# ip address 172.23.145.218/24
    switch(config-if)# no shutdown
    switch(config-if)# exit

Thanks @Harold Ritter  for the explanation!

@MHM Cisco World  Thanks for the explanation. 

In Nexus devices, the concept of "address-family" within a Virtual Routing and Forwarding (VRF) instance serves a crucial purpose. Essentially, it allows the segregation and management of multiple routing instances within a single device.

By defining an address-family within a VRF, you're specifying the address type and the associated routing protocols that will be used within that particular VRF instance. This segregation enables different types of traffic (IPv4, IPv6, multicast, etc.) to be handled independently within their designated VRF, ensuring better network control, security, and scalability.

In simpler terms, the "address-family" feature in VRF helps organize and manage various types of traffic more effectively within a Nexus device by providing a way to separate and control routing information for different address types or protocols.

Great piece of information,

Thank You,

Lisa Rollins

https://frasesdebuenosdias.com/

Review Cisco Networking for a $25 gift card