ā05-02-2012 02:58 AM - edited ā03-04-2019 04:13 PM
Dear All, I have configured policies to shape the traffic on the interface of cisco 7206 router. Now my managemet wants to configure these policies on time based ie policy should be applicable during specified time period onle. Is it possible? if yes how to configure it?
Please help.
Solved! Go to Solution.
ā05-02-2012 03:43 AM
You can do it depending on how your class maps are set up. If you're classifying traffic with an acl, you can create a time range and then apply that time range to your acl. Let's say that you want to shape web traffic between the hours of 8am and 10am, but anytime after that is not shaped and has 100% of the link:
time-range Web
periodic 08:00 to 10:00
ip access-list ext Web
permit tcp any any eq 80 time-range Web
class-map Web
match access-group name Web
policy-map Web
class Web
shape average 128000
class class-default
int s0/0
service-policy output Web
This would shape their traffic only between those hours.
HTH,
John
ā05-03-2012 04:12 AM
Yes. You can use the time range anywhere an acl can be used as far as I know...
John
Please rate all useful posts...
ā05-02-2012 03:43 AM
You can do it depending on how your class maps are set up. If you're classifying traffic with an acl, you can create a time range and then apply that time range to your acl. Let's say that you want to shape web traffic between the hours of 8am and 10am, but anytime after that is not shaped and has 100% of the link:
time-range Web
periodic 08:00 to 10:00
ip access-list ext Web
permit tcp any any eq 80 time-range Web
class-map Web
match access-group name Web
policy-map Web
class Web
shape average 128000
class class-default
int s0/0
service-policy output Web
This would shape their traffic only between those hours.
HTH,
John
ā05-03-2012 04:07 AM
thanks dear for support, can i use time range in rate limit also?
ā05-03-2012 04:12 AM
Yes. You can use the time range anywhere an acl can be used as far as I know...
John
Please rate all useful posts...
ā05-18-2012 02:34 AM
Dear I ahve applied the policy as stated but i am facing some problem, Some time policy does not get started autometically at the specified time. and not gets stoped at the configured time.
I have to remove and apply policy on interface to take effect.
following is the configuration i have done.
time-range wimx
periodic daily 7:00 to 17:30
access-list 115 permit ip any any time-range wimax
class-map wimax
match access-group 115
policy-map wimax
class wimax
police cir 200000000 bc 31250000 be 31250000 conform-action transmit exceed-action drop violate-action drop
class class-default
I am using cisco 7206 router running c7600rsp72043-advipservicesk9-mz.122-33.SRD5 ios.
Please help.....
ā05-18-2012 03:40 AM
If I'm understanding you right, does the policy only work during the time if you remove it and then reapply it? What time does the local clock say on the router? Is it correct? ("sh clock") When you look at the access-list during the time that it's not working, does the access-list say "Inactive"? Are you wanting to police the traffic inbound during this time? If so, you could change your direction on the interface to "service-policy input wimax". Otherwise, you may need to look for bugs in the OS that you have or upgrade the OS as a test.
ā05-18-2012 03:52 AM
Dear following is the observation.
I mean if the policy applied on the interface it starts activated and some time even after beyond end time policy did not go to default. when i checked the show time-range and show access-list 115, both setting shows inactive.system clock is showing the correct time. but i have applied policy in both direction in and out. is it becose of this?
ā05-18-2012 04:02 AM
If the time is showing inactive during the time that it should be active, I'd look into updating the OS. There could be a bug. You can apply the policy in and outbound with no issues. When the ACL is inactive, it shouldn't match on the class. I'm going to lab this up and get back with you....
ā05-18-2012 04:14 AM
On the version that I'm running, it works fine. Maybe update IOS?
ā05-18-2012 04:15 AM
ok dear thanks, let me check and i will update u.
ā05-18-2012 04:16 AM
bythe way which ios u have tested it.
ā05-18-2012 04:21 AM
I did this in GNS with a 3745:
3700 Software (C3745-ADVENTERPRISEK9-M), Version 12.4(15)T14, RELEASE SOFTWARE (fc2)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide