cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
938
Views
0
Helpful
8
Replies
Sun Flower
Beginner

Track object doesn't work in Interchassis high availability.

I am configuring Interchassis high Availablity. But I have faced problem in "Configuring Redundancy group" section. According to manual following command must be entered. 

Device# configure terminal
Device(config)# redundancy
Device(config-red)# application redundancy
Device(config-red-app)# group 1
Device(config-red-app-grp)# name rg1
Device(config-red-app-grp)# preempt
Device(config-red-app-grp)# priority 120 failover-threshold 80
Device(config-red-app-grp)# track 44 decrement 20
Device(config-red-app-grp)# timers delay 10 reload 20
Device(config-red-app-grp)# control GigabitEthernet0/1/0 protocol 1
Device(config-red-app-grp)# data GigabitEthernet0/1/2
Device(config-red-app-grp)# end 

 

But when I enter track 44 decrement 20, it shows this error "The track objetc (44) doesn't exist ". How can I fix the error? Why doesn't the router accept the command? The router is ISR4431.   

1 ACCEPTED SOLUTION

Accepted Solutions

Issue the track command I suggested once you are in configure terminal:

en
conf t
!
track 44 interface gi0/0/1 line-protocol
!

 

View solution in original post

8 REPLIES 8
Seb Rupik
VIP Advisor

Hi there,

What is the output of show track ?

 

cheers,

Seb.

Result shows nothing...

 

 

N2_R3#show track
N2_R3#
N2_R3#

Hi there,

Then you have missed a step in the configuration guide as no tracking object has been configured.

 

Which confiugration guide are you using?

 

cheers,

Seb.

Hi,  @Seb Rupik. THank you for your quick response. 

I attached the file which I am using.

 According to this guide, I haven't missed any command. But the router is brand new, so maybe I think I should do some command except these commands. But, I don't know which one should I use. 

You need to deciced which interfasces you are going to monitor which will determine if a failover should occur.

A layer1 failure of the ASRs outbound interface would be a good bet. So assuming it is gi0/0/1 we could create the following:

!
track 44 interface gi0/0/1 line-protocol
!

You will want to raise the fail-over threshold to ensure a failover is triggered in the event of just one interfasce being disconnected:

!
application redundancy
  group 1
    priority 120 failover-threshold 101
!

cheers,

Seb.

 Unfortunately, there is no option to do any other track command in ISR 4431.  IOS XE, Version 15.5(3)S4b,
(config-red-app-grp)#track ?
<1-500> Tracked object number

(config-red-app-grp)#track 44 ?
decrement Specify decrement value
shutdown Shutdown group

(config-red-app-grp)#track 44 decrement ?
<1-255> decrement value

 

According to conf guide, I think that these red decrement amount is associated with the interface which will be monitored.

 

Device# configure terminal
Device(config)# redundancy
Device(config-red)# application redundancy
Device(config-red-app)# group 1
Device(config-red-app-grp)# name rg1
Device(config-red-app-grp)# preempt
Device(config-red-app-grp)# priority 120 failover-threshold 80
Device(config-red-app-grp)# track 44 decrement 20
Device(config-red-app-grp)# timers delay 10 reload 20
Device(config-red-app-grp)# control GigabitEthernet0/1/0 protocol 1
Device(config-red-app-grp)# data GigabitEthernet0/1/2
Device(config-red-app-grp)# end
Device# configure terminal
Device(config)# interface GigabitEthernet 0/0/1
Device(config-if)# redundancy group 1 ip 10.10.1.1 exclusive decrement 20
Device(config-if)# redundancy rii 40

Issue the track command I suggested once you are in configure terminal:

en
conf t
!
track 44 interface gi0/0/1 line-protocol
!

 

@Seb Rupik Thankyou very much. It worked.