cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
656
Views
0
Helpful
3
Replies
arell1234
Beginner

Traffic-Shape depreciated?

We recently upgraded our 2811 router with a 2911 router. The 2911 is running IOS 15.1(4)M4. I think that the old router was running 12.4

On the old router we used to limit the traffic from a specific host on the LAN to a specific host across the WAN to about 1.5Mbps using the following commands:

Interface FastEthernet0/0

description ***LAN LINK***

ip address 172.16.4.1 255.255.252.0

interface FastEthernet0/1

description ***WAN LINK***

ip address 172.17.1.6 255.255.255.252

traffic-shape group 106 1572864 125000 125000 1000

access-list 106 permit ip host 172.16.4.14 host 172.16.8.4 time-range DR-Replication

time-range DR-Replication
periodic weekdays 3:00 to 15:00

Now that we have switched to the 2911 using IOS 15.1(4)M4 it does not appear to be working. I do"

show traffic-shape

This command has been deprecated. The MQC equivalent is  "show policy-map interface"

and thats what I get.

How can I implement the same thing wiht the new IOS?

1 ACCEPTED SOLUTION

Accepted Solutions
Giuseppe Larosa
Hall of Fame Master

Hello Areil1234,

you need to use modular QoS

class-map DR-Replication

match access-group 106

policy-map SHAPE-SELECTED

class DR-Replication

shape average 1572000 125000 125000

class class-default

fair-queue

interface fas0/1

service-policy SHAPE-SELECTED output

the only point to check is the use of the time range in ACL 106.


Hope to help

Giuseppe


View solution in original post

3 REPLIES 3
Giuseppe Larosa
Hall of Fame Master

Hello Areil1234,

you need to use modular QoS

class-map DR-Replication

match access-group 106

policy-map SHAPE-SELECTED

class DR-Replication

shape average 1572000 125000 125000

class class-default

fair-queue

interface fas0/1

service-policy SHAPE-SELECTED output

the only point to check is the use of the time range in ACL 106.


Hope to help

Giuseppe


View solution in original post

Thank you very much for the reply

I have a question about this.

Will this drop packets or queue them?

what does the fair-queue do?

If I had another access-list defined, say 101, would i just add it to

class-map DR-Replication

match access-group 106

match access-group 101

and the same policy would take affect?

Disclaimer

The  Author of this posting offers the information contained within this  posting without consideration and with the reader's understanding that  there's no implied or expressed suitability or fitness for any purpose.  Information provided is for informational purposes only and should not  be construed as rendering professional advice of any kind. Usage of this  posting's information is solely at reader's own risk.

Liability Disclaimer

In  no event shall Author be liable for any damages whatsoever (including,  without limitation, damages for loss of use, data or profit) arising out  of the use or inability to use the posting's information even if Author  has been advised of the possibility of such damage.

Posting

Will this drop packets or queue them?

It will queue them, but if queue fills, then it will drop.

what does the fair-queue do?

Splits flows, within that class, into different sub-queues.  Ideally each flow will have its own sub-queue, but its possible multiple flows will map to the same sub-queue.  For whatever bandwidth the class gets, each class sub-queue will receive an equal share (NB: CBWFQ pre-HQF actually used WFQ and was only supported in class-default.)

If I had another access-list defined, say 101, would i just add it to

class-map DR-Replication

match access-group 106

match access-group 101

and the same policy would take affect?

It depends on the contents for the ACLs and whether the class-map uses a match-any (logical or) or a match-all (logical and) for its match entries.