cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

11021
Views
5
Helpful
7
Replies
Beginner

Trunk Port not forwarding VLAN traffic

Dear All,

I have got 2 Cisco switches (3560G and a 3560X) connected by a trunk port. Please see config below:

3560G#sh run int gi0/26

Building configuration...

Current configuration : 130 bytes

interface GigabitEthernet0/26

  switchport trunk encapsulation dot1q

switchport mode trunk

end

3560G#sh int trunk

Port        Mode         Encapsulation  Status        Native vlan

Gi0/26      on           802.1q         trunking      1

Port        Vlans allowed on trunk

Gi0/26      1-4094

Port        Vlans allowed and active in management domain

Gi0/26      1,22,25,28,56,59,300

Port        Vlans in spanning tree forwarding state and not pruned

Gi0/26      1,22,25,28,56,59,300

--------------------------------------------------------------------------------------

3560X#sh run int gi1/1

Building configuration...

Current configuration : 97 bytes

interface GigabitEthernet1/1

switchport trunk encapsulation dot1q

switchport mode trunk

end

3560X#sh int trunk

Port        Mode             Encapsulation  Status        Native vlan

Gi1/1       on               802.1q         trunking      1

Port        Vlans allowed on trunk

Gi1/1       1-4094

Port        Vlans allowed and active in management domain

Gi1/1       1,25,49,79

Port        Vlans in spanning tree forwarding state and not pruned

Gi1/1       1,25,49,79

--------------------------------------------------------------------------------------

I can't seem to get VLAN 79 through to the first switch (3560G). Beyond this switch there is a router with acts as default-gateway for the respective VLANs. For VLAN 79 it is 192.168.79.1. I can ping this from the first switch but can't ping it from the second (3560X) switch but can ping 192.168.25.1 which also is the default gateway for this switch.

Can someone advise what is it that i am missing in the config?

Regards,

Akbar Ali Sheikh

Everyone's tags (1)
2 ACCEPTED SOLUTIONS

Accepted Solutions
Rising star

Trunk Port not forwarding VLAN traffic

Hi,

As you can see STP not enabled on VLAN 79 on 3560G. Try to configure one access port as VLAN 79. Becase I think there is no devices on VLAN 79.

3560:

int f0/1

switchport mode access

switchport access vlan 79

And check STP on 3560G:

sh spanning-tree vlan 79

Hope it will help.

Hope it will help. Best regards, Abzal

View solution in original post

Rising star

Trunk Port not forwarding VLAN traffic

Hi Akbar,

Do you have any port configured with vlan 79 on switch 3560G? If not try configuring a switch port to access vlan 79 and make it up and see the result.

Regards

Najaf

View solution in original post

7 REPLIES 7
Rising star

Trunk Port not forwarding VLAN traffic

Hi,

As you can see STP not enabled on VLAN 79 on 3560G. Try to configure one access port as VLAN 79. Becase I think there is no devices on VLAN 79.

3560:

int f0/1

switchport mode access

switchport access vlan 79

And check STP on 3560G:

sh spanning-tree vlan 79

Hope it will help.

Hope it will help. Best regards, Abzal

View solution in original post

Rising star

Trunk Port not forwarding VLAN traffic

Hi Akbar,

Do you have any port configured with vlan 79 on switch 3560G? If not try configuring a switch port to access vlan 79 and make it up and see the result.

Regards

Najaf

View solution in original post

Beginner

Trunk Port not forwarding VLAN traffic

Hi Both,

Thank you for your help. It worked but had to create a VLAN 79 on 3560G and had to add port on it as advised.

I just got one thing to ask which is, it necessary to  create a VLAN on a switch if you only want to pass the traffic through  it to the onward router or switch? Does the middle switch has to have a reference to the VLAN of all passing traffic through its trunk ports.

Rising star

Trunk Port not forwarding VLAN traffic

As far I know yes you need a VLAN on the switch event it's just a transit to other switch. Because it's required by STP.

In order to have instance for VLAN. Logically if switch doesn't have a particular VLAN it doesn't need to particiapte in STP.

Hope it will help.

Hope it will help. Best regards, Abzal
Highlighted
Beginner

Trunk Port not forwarding VLAN traffic

Manys for your prompt reply and your assistance.

Advocate

Re: Trunk Port not forwarding VLAN traffic

Hi,

IMHO, STP is not the main reason.

In theory, you can run your LAN without STP.

But the switch neeeds to know where to forward the frames received.

Without the VLAN 79 configured (or received by VTP) on the switch, how could it forward frames received tagged for VLAN 79 from a trunk?

To all other trunks?

Creating a loop easily if multiple switches involved?

No, that's why the switches are building per-VLAN forwrding MAC address table.

BR,

Milan

Rising star

Re: Trunk Port not forwarding VLAN traffic

Hi Milan,

Yes, you are absolutely right. Yes, because VLAN is not created it has no knowledge where to forward it. STP was just my first thought .

Hope it will help. Best regards, Abzal
CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards