cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
232
Views
0
Helpful
6
Replies
Highlighted

Tunnel Gre Trouble

I have 2 device (cisco Catalyst 3850 and Cisco Catalyst 4500 in VSS mode)

I try to configure a GRE Tunnel from this device but the tunnel doesn't work.

 

If i try to build the tunnel from the Catalyst 3850 to Cisco Router 1841 with the same configuration all works fine.

 

Below you can find the configuration of both end:

 

Cisco Catalyst 4500 or Cisco Router 1841 side
!
interface Loopback76
ip address 172.31.0.5 255.255.255.255
!
interface Tunnel184
ip address 172.31.1.102 255.255.255.252
ip mtu 1400
keepalive 10 3
tunnel source Loopback76
tunnel destination 172.31.0.3
tunnel path-mtu-discovery
!

Cisco Catalyst 3850 side
!
interface Loopback184
ip address 172.31.0.3 255.255.255.255
!
interface Tunnel76
ip address 172.31.1.101 255.255.255.252
ip mtu 1400
keepalive 10 3
tunnel source Loopback184
tunnel destination 172.31.0.5
tunnel path-mtu-discovery
!

 

 

Everyone's tags (1)
6 REPLIES 6
VIP Mentor

Re: Tunnel Gre Trouble

Hello,

 

which IOS are you running on the 4500 and the 3850 ? Post the output of 'sh ver' of both switches.

 

On the switches, try and add 'tunnel mode gre ip' and check if that makes a difference.

Re: Tunnel Gre Trouble

The situation don't change.

 

The "sh ver" output are this:

 

Catalyst 4500

Cisco IOS Software, IOS-XE Software, Catalyst 4500 L3 Switch Software (cat4500e-UNIVERSALK9-M), Version 03.08.06.E RELEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Thu 05-Apr-18 06:32 by prod_rel_team

 

Cisco IOS-XE software, Copyright (c) 2005-2015 by cisco Systems, Inc.
All rights reserved. Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0. The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0.
(http://www.gnu.org/licenses/gpl-2.0.html) For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.

 

ROM: 15.0(1r)SG10
uptime is 13 weeks, 6 days, 23 hours, 3 minutes
Uptime for this control processor is 13 weeks, 6 days, 23 hours, 5 minutes
System returned to ROM by reload
System restarted at 13:33:14 GMT Wed Aug 22 2018
System image file is "bootflash:cat4500e-universalk9.SPA.03.08.06.E.152-4.E6.bin"
Jawa Revision 7, Snowtrooper Revision 0x0.0x1C

Last reload reason: Reload command

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.


License Information for 'WS-X45-SUP7-E'
License Level: ipbase Type: Permanent
Next reboot license Level: ipbase

cisco WS-C4510R+E (MPC8572) processor (revision 8) with 2097152K bytes of physical memory.

 

Cisco 3850

Cisco IOS Software [Denali], Catalyst L3 Switch Software (CAT3K_CAA-UNIVERSALK9-M), Version 16.3.5b, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2017 by Cisco Systems, Inc.
Compiled Thu 02-Nov-17 11:07 by mcpre


Cisco IOS-XE software, Copyright (c) 2005-2017 by cisco Systems, Inc.
All rights reserved. Certain components of Cisco IOS-XE software are
licensed under the GNU General Public License ("GPL") Version 2.0. The
software code licensed under GPL Version 2.0 is free software that comes
with ABSOLUTELY NO WARRANTY. You can redistribute and/or modify such
GPL code under the terms of GPL Version 2.0. For more details, see the
documentation or "License Notice" file accompanying the IOS-XE software,
or the applicable URL provided on the flyer accompanying the IOS-XE
software.


ROM: IOS-XE ROMMON
BOOTLDR: CAT3K_CAA Boot Loader (CAT3K_CAA-HBOOT-M) Version 3.58, RELEASE SOFTWARE (P)

TR38CD01 uptime is 4 weeks, 36 minutes
Uptime for this control processor is 4 weeks, 39 minutes
System returned to ROM by Power Failure at 11:33:50 GMT Fri Oct 26 2018
System image file is "flash:packages.conf"
Last reload reason: Power Failure

 

This product contains cryptographic features and is subject to United
States and local country laws governing import, export, transfer and
use. Delivery of Cisco cryptographic products does not imply
third-party authority to import, export, distribute or use encryption.
Importers, exporters, distributors and users are responsible for
compliance with U.S. and local country laws. By using this product you
agree to comply with applicable laws and regulations. If you are unable
to comply with U.S. and local laws, return this product immediately.

A summary of U.S. laws governing Cisco cryptographic products may be found at:
http://www.cisco.com/wwl/export/crypto/tool/stqrg.html

If you require further assistance please contact us by sending email to
export@cisco.com.


Technology Package License Information:

-----------------------------------------------------------------
Technology-package Technology-package
Current Type Next reboot
------------------------------------------------------------------
ipservicesk9 Permanent ipservicesk9

cisco WS-C3850-24XS (MIPS) processor (revision J0) with 865070K/6147K bytes of memory.
Processor board ID FOC2145X0HG
9 Virtual Ethernet interfaces
64 Ten Gigabit Ethernet interfaces
4 Forty Gigabit Ethernet interfaces
2048K bytes of non-volatile configuration memory.
4194304K bytes of physical memory.
253984K bytes of Crash Files at crashinfo:.
253984K bytes of Crash Files at crashinfo-1:.
3431232K bytes of Flash at flash:.
3431232K bytes of Flash at flash-1:.
0K bytes of at webui:.

Base Ethernet MAC Address : b4:a8:b9:86:13:00
Motherboard Assembly Number : 73-16649-06
Motherboard Serial Number : FOC214439G0
Model Revision Number : J0
Motherboard Revision Number : A0
Model Number : WS-C3850-24XS
System Serial Number : FOC2145X0HG


Switch Ports Model SW Version SW Image Mode
------ ----- ----- ---------- ---------- ----
1 34 WS-C3850-24XS 16.3.5b CAT3K_CAA-UNIVERSALK9 INSTALL
* 2 34 WS-C3850-24XS 16.3.5b CAT3K_CAA-UNIVERSALK9 INSTALL

 

 

 

Rising star

Re: Tunnel Gre Trouble

Beginner

Re: Tunnel Gre Trouble

You need to be able to ping the source and destination of the tunnel , a route must be configured between them

Re: Tunnel Gre Trouble

The 2 peer ping each other.

Beginner

Re: Tunnel Gre Trouble

Hi

 

Option 1:

 

Please try to ping from 4k5

 

172.31.0.3 with source 172.31.0.5

 

If this does not work, do correct the routing (via static or dynamic)

 

Option 2: (more common)

 

source the tunnel interface from phisical interfaces instead of loopbacks

 

BR

Gaston

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards