cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
5543
Views
5
Helpful
4
Replies
Engager

Tunnel Interface /32 Host Mask

hi all,

first, i would like to greet everyone a prosperous 2013!

i'm currently doing GRE tunneling between 2 routers and would like to use a /32 host mask, but was rejected. is this an IOS restriction?

R1(config-if)#tunnel destination 192.168.0.2

R1(config-if)#ip address 10.0.0.1 255.255.255.255

Bad mask /32 for address 10.0.0.1

R1(config-if)#ip address 10.0.0.1 255.255.255.254

R1(config-if)# do sh run int tu0

Building configuration...

Current configuration : 121 bytes

!

interface Tunnel0

ip address 10.0.0.1 255.255.255.254

tunnel source 192.168.0.1

tunnel destination 192.168.0.2

end

Everyone's tags (3)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Cisco Employee

Tunnel Interface /32 Host Mask

Hi John,

You cannot directly configure a /32 address on tunnel (or other physical interface). You need to configure it on a loopback interface and assign it as "ip unnumbered loop<>" under tunnel interface as below,

!

interface Loopback3

ip address 10.3.3.3 255.255.255.255

!

interface Tunnel3

ip unnumbered Loopback3

HTH,

Nagendra

4 REPLIES 4
Highlighted
Cisco Employee

Tunnel Interface /32 Host Mask

Hi John,

You cannot directly configure a /32 address on tunnel (or other physical interface). You need to configure it on a loopback interface and assign it as "ip unnumbered loop<>" under tunnel interface as below,

!

interface Loopback3

ip address 10.3.3.3 255.255.255.255

!

interface Tunnel3

ip unnumbered Loopback3

HTH,

Nagendra

Engager

Tunnel Interface /32 Host Mask

hi nagendra,

thanks for the quick reply! do you have a useful link with this info?

Beginner

Tunnel Interface /32 Host Mask

Dear john

you cannt configure any ip directly in your tunnel or any where related to interface matter.

you have to configure interface lokback 0

ip add 10.10.10.10 255.255.255.255

no shut

show ip int brie

lookback up

then you can configure any whare 10.10.10.10 255.255.255.255

subnet 255.255.255.255 means host

Re :R2(config-if)#ip address 3.3.3.3 255.255.255.255 Bad mask /32 for address 3.3.3.3

please help me when i am configuring  the R2(config)#int Fa0/1 

ip address 3.3.3.3 255.255.255.255

i am getting the Bad mask /32 for address 3.3.3.3 

 

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards