cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
344
Views
5
Helpful
11
Replies
Highlighted
Beginner

Unable to configure cellular connectivity

Hello!

 

We're really struggling to get cellular connectivity working.

 

We've tried an 887VAMG (c880data-universalk9-mz.154-3.M4.bin) and a 881G-4G (15.9).

 

We've tried them with a 3 (three.co.uk) SIM and a BT (ee) SIM.

 

It feels like we've tried every permutation of config under the sun, but they still refuse to work.

 

Here's the config for the current one we're playing with (BT SIM on 887VAMG):

 

Current configuration : 2607 bytes
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname rtr-h000619
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$rczl$ah8kjOhvvpRW2Mp74WS/d.
!
aaa new-model
!
!
aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
clock timezone gmt 0 0
clock summer-time gmt recurring
!
ip domain name x.local
ip name-server 10.11.202.1
ip cef
no ipv6 cef
!
!
multilink bundle-name authenticated
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm01 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm2 "" "ATDT*99*1,1#" TIMEOUT 60 "OK"
chat-script gsm "" "AT!CALL1" TIMEOUT 20 "OK"
cts logging verbose
license udi pid C887VAMG+7-K9 sn FCZ1735C2QR
!
controller VDSL 0
!
controller Cellular 0
!
interface Ethernet0
no ip address
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 105
no ip address
!
interface FastEthernet1
switchport access vlan 105
no ip address
!
interface FastEthernet2
switchport access vlan 105
no ip address
!
interface FastEthernet3
switchport access vlan 105
no ip address
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string gsm
dialer-group 1
async mode interactive
!
interface Vlan1
no ip address
shutdown
!
interface Vlan105
ip address 10.11.105.254 255.255.255.0
!
no ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip route 0.0.0.0 0.0.0.0 Cellular0
control-plane
!
privilege exec level 2 show startup-config
privilege exec level 2 show
!
line con 0
privilege level 15
no modem enable
line aux 0
line 3
exec-timeout 0 0
script dialer gsm
modem InOut
no exec
transport input all
line vty 0 4
exec-timeout 1440 0
privilege level 15
transport input ssh
line vty 5 15
exec-timeout 1440 0
privilege level 15
transport input ssh
!
!
end

 

 

With this config, the SIM0 light is illuminated, RSSI is at 2 bars, service is at "3.5" and the 3G WWAN light is also illuminated.

 

Profile is in place, but won't activate:

rtr-h000619#sh cell 0 prof
Profile password Encryption level: 7

Profile 1 = INACTIVE* **
--------
PDP Type = IPv4
Access Point Name (APN) = everywhere
Authentication = PAP
Username: eesecure
Password: 0832494D1C0B00

* - Default profile

Configured default profile for active SIM 0 is profile 1.

It can see the network:

 

rtr-h000619#sh cell 0 network
Current Service Status = Normal, Service Error = None
Current Service = Combined
Packet Service = HSPA (Attached)
Packet Session Status = Inactive
Current Roaming Status = Home
Network Selection Mode = Automatic
Country = GBR, Network = TMO UK
Mobile Country Code (MCC) = 234
Mobile Network Code (MNC) = 30
Location Area Code (LAC) = 1177
Routing Area Code (RAC) = 1
Cell ID = 64519
Primary Scrambling Code = 156
PLMN Selection = Automatic
Registered PLMN = BT , Abbreviated =
Service Provider =

SIM is unlocked and enabled for data

 

As you can see, we've tried multiple different 'chat scripts'. All making no difference.

 

Please can someone strong in the ways of cellular configuration, put us out of our misery and advise where our config is wrong?

 

Thank you for your time.

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Beginner

Re: Unable to configure cellular connectivity

Hi all,

 

Firstly, thanks to everyone who helped with this issue.

 

We have finally got some of our routers to now work with our BT and three.co.uk SIMs. Unfortunately, we have come to the conclusion that we have a defective C881G-4G-GA-K9 though :( So that's going to the WEEE disposal!

 

What we generally found is:

  • It can take 10-15 mins for the cellular hardware to get online (after the router is online).
  • Having something like a laptop setup to constantly ping the internet (eg: 8.8.8.8) via NAT, makes a big difference in "persuading" the router to keep trying to get online.
  • A router's IOS defaults for chat-script, line 3, cellular interfaces and controllers, generally should work without any additional configuration. Patience, waiting for the cellular hardware to come online is our biggest take-away from this.

 

For anyone interested, here's our final, working config (on a C887VAG+7-K9):

version 15.7
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname rtr-h000620
!
boot-start-marker
boot-end-marker
!
!
no logging console
enable secret 5 xxx
!
aaa new-model
!
aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
aaa session-id common
clock timezone gmt 0 0
clock summer-time gmt recurring
!
ip domain name x.local
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
!
username administrator privilege 15 secret 5 x
!
controller VDSL 0
!
controller Cellular 0
!
interface Ethernet0
 no ip address
 shutdown
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 switchport access vlan 188
 no ip address
!
interface FastEthernet1
 switchport access vlan 188
 no ip address
!
interface FastEthernet2
 switchport access vlan 188
 no ip address
!
interface FastEthernet3
 switchport access vlan 188
 no ip address
!
interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer string hspa-R7
 dialer-group 1
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan188
 ip address 10.11.188.254 255.255.255.0
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
ip ssh version 2
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
access-list 1 permit 10.11.188.0 0.0.0.255
!
control-plane
!
 vstack
privilege exec level 2 show startup-config
privilege exec level 2 show
!
line con 0
 privilege level 15
 no modem enable
line aux 0
line 3
 script dialer hspa-R7
 no exec
 rxspeed 21600000
 txspeed 5760000
line vty 0 4
 exec-timeout 1440 0
 transport input ssh
line vty 5 15
 exec-timeout 1440 0
 transport input ssh
!
end

The SIM profile was cleared, so it was forced to acquire the APN details itself.

 

Thank you

 

 

View solution in original post

11 REPLIES 11
Highlighted
VIP Mentor

Re: Unable to configure cellular connectivity

Hello,

 

I have made a few additions to your configuration (marked in bold), check if that makes a difference:

 

Current configuration : 2607 bytes
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname rtr-h000619
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$rczl$ah8kjOhvvpRW2Mp74WS/d.
!
aaa new-model
!
aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
aaa session-id common
clock timezone gmt 0 0
clock summer-time gmt recurring
!
ip domain name x.local
ip name-server 10.11.202.1
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm01 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm2 "" "ATDT*99*1,1#" TIMEOUT 60 "OK"
chat-script gsm "" "AT!CALL1" TIMEOUT 20 "OK"
cts logging verbose
license udi pid C887VAMG+7-K9 sn FCZ1735C2QR
!
controller VDSL 0
!
controller Cellular 0
!
interface Ethernet0
no ip address
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 105
no ip address
!
interface FastEthernet1
switchport access vlan 105
no ip address
!
interface FastEthernet2
switchport access vlan 105
no ip address
!
interface FastEthernet3
switchport access vlan 105
no ip address
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string gsm
dialer-group 1
--> no peer default ip address
async mode interactive
--> routing dynamic
!
interface Vlan1
no ip address
shutdown
!
interface Vlan105
ip address 10.11.105.254 255.255.255.0
--> ip nat inside
!
no ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
--> ip nat inside source list 1 interface Cellular0 overload
!
--> dialer-list 1 protocol ip permit
!
ip route 0.0.0.0 0.0.0.0 Cellular0
!
--> access-list 1 permit 10.11.105.0 0.0.0.255
!
control-plane
!
privilege exec level 2 show startup-config
privilege exec level 2 show
!
line con 0
privilege level 15
no modem enable
line aux 0
line 3
exec-timeout 0 0
script dialer gsm
modem InOut
no exec
transport input all
--> transport output all
line vty 0 4
exec-timeout 1440 0
privilege level 15
transport input ssh
line vty 5 15
exec-timeout 1440 0
privilege level 15
transport input ssh
!
!

Highlighted
Beginner

Re: Unable to configure cellular connectivity

Thank you, Georg! We will give your suggestions a try.

Beginner

Re: Unable to configure cellular connectivity

Hello,

 

Unfortunately, the amendments don't appear to have coerced our cellular connection to work.

 

Does anyone have any additional suggestions I can try, please?

 

It feels like we are so close!

 

Here's the config now:

 

Current configuration : 2973 bytes
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname rtr-h000619
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxx.
!
aaa new-model
!
aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
aaa session-id common
clock timezone gmt 0 0
clock summer-time gmt recurring
!
ip domain name x.local
ip name-server 10.11.202.1
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm01 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm2 "" "ATDT*99*1,1#" TIMEOUT 60 "OK"
chat-script gsm "" "AT!CALL1" TIMEOUT 20 "OK"
chat-script hspa "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm-script "" "ATDT*98*1#" TIMEOUT 60 "CONNECT"
cts logging verbose
!
controller VDSL 0
!
controller Cellular 0
!
interface Ethernet0
 no ip address
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 switchport access vlan 105
 no ip address
!
interface FastEthernet1
 switchport access vlan 105
 no ip address
!
interface FastEthernet2
 switchport access vlan 105
 no ip address
!
interface FastEthernet3
 switchport access vlan 105
 no ip address
!
interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer string gsm-string
 dialer-group 1
 no peer default ip address
 async mode interactive
 routing dynamic
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan105
 ip address 10.11.188.254 255.255.255.0
 ip nat inside
 ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.11.188.0 0.0.0.255
!
control-plane
!
privilege exec level 2 show startup-config
privilege exec level 2 show
!
line con 0
 privilege level 15
 no modem enable
line aux 0
line 3
 exec-timeout 0 0
 script dialer gsm-script
 modem InOut
 no exec
 transport input all
 transport output all
line vty 0 4
 exec-timeout 1440 0
 privilege level 15
 transport input ssh
line vty 5 15
 exec-timeout 1440 0
 privilege level 15
 transport input ssh
!
end
Highlighted
VIP Mentor

Re: Unable to configure cellular connectivity

Hello,

 

the chat script doesn't look right, use the one highlighted in bold. Also, you might need to manually create Vlan 105:

 

887#conf t

887(config)vlan 105

 

Current configuration : 2973 bytes
!
version 15.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname rtr-h000619
!
boot-start-marker
boot-end-marker
!
enable secret 5 xxxxxxxxxxxx.
!
aaa new-model
!
aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
aaa session-id common
clock timezone gmt 0 0
clock summer-time gmt recurring
!
ip domain name x.local
ip name-server 10.11.202.1
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
chat-script gsm "" "AT!CALL" TIMEOUT 20 "OK"
cts logging verbose
!
controller VDSL 0
!
controller Cellular 0
!
interface Ethernet0
no ip address
!
interface ATM0
no ip address
shutdown
no atm ilmi-keepalive
!
interface FastEthernet0
switchport access vlan 105
no ip address
!
interface FastEthernet1
switchport access vlan 105
no ip address
!
interface FastEthernet2
switchport access vlan 105
no ip address
!
interface FastEthernet3
switchport access vlan 105
no ip address
!
interface Cellular0
ip address negotiated
ip nat outside
ip virtual-reassembly in
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string gsm
dialer-group 1
no peer default ip address
async mode interactive
routing dynamic
!
interface Vlan1
no ip address
shutdown
!
interface Vlan105
ip address 10.11.188.254 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
!
dialer-list 1 protocol ip permit
access-list 1 permit 10.11.188.0 0.0.0.255
!
control-plane
!
privilege exec level 2 show startup-config
privilege exec level 2 show
!
line con 0
privilege level 15
no modem enable
line aux 0
line 3
exec-timeout 0 0
script dialer gsm
modem InOut
no exec
transport input all
transport output all
line vty 0 4
exec-timeout 1440 0
privilege level 15
transport input ssh
line vty 5 15
exec-timeout 1440 0
privilege level 15
transport input ssh
!
end

Highlighted
Beginner

Re: Unable to configure cellular connectivity

Hi Georg,

 

Still no luck :(

 

We've tried all of the following chat scripts:

chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm01 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm2 "" "ATDT*99*1,1#" TIMEOUT 60 "OK"
chat-script hspa "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
chat-script gsm-script "" "AT!CALL" TIMEOUT 20 "OK"
chat-script gsm3 "" "AT!CALL" TIMEOUT 20 "OK"
chat-script gsm4 "" "AT!CALL1" TIMEOUT 20 "OK"
chat-script gsm "" "AT!CALL" TIMEOUT 20 "OK"

We really don't understand how to construct a correct chat-script. Does anyone have a guide on how?

 

I have ran your command to activate the vlan:

rtr-h000619#sh vlan-switch brief

VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active
105  myvlan                           active    Fa0, Fa1, Fa2, Fa3
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup

We have tried many different combinations for the SIM profile. PAP/CHAP, username/pass and no username/pass. All getting us nowhere.

 

The really irritating part is that we have a C887VAG-4G-GA-K9 out in the field, with a 4G BT SIM, and the cellular works fine. We've compared the configs and had them identical, but this one we have here won't play (in any of the routers we have here).

 

As mentioned before (I think!), we've taken the SIM out and tried it in a phone, and the data connectivity works fine.

 

We have noticed on some other example configs (such as here), that some people use an interface Dialer (dialer 1). We've tried this too, but to no avail.

Highlighted
VIP Mentor

Re: Unable to configure cellular connectivity

Hello
Have you tired creating a custom profile instead using the ISPs defined APN?
show cellular 0 radio

Do you recive an ip address from the ISP?
show ip interface brief | in up



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: Unable to configure cellular connectivity

Hi Paul,

 

rtr-h000619#show cellular 0 radio
Radio power mode = ON
Current Band = WCDMA 2100, Channel Number = 10761
Current RSSI = -88 dBm
Band Selected = Auto
Number of nearby cells = 1
Cell 1
        Primary Scrambling Code = 0x8A
        RSCP = -84 dBm, ECIO = -4 dBm

We've tried many combos of profiles, but nothing seems to take.

 

As of yet, we've been unable to get an IP from the ISP. Every time we try something new, we are checking for this. So we're sure the issue is regarding the actual connectivity/authentication to the ISP - we just can't nail it!

Highlighted
VIP Mentor

Re: Unable to configure cellular connectivity

Hello


@Group IT wrote:
rtr-h000619#sh cell 0 prof
Profile password Encryption level: 7

Profile 1 = INACTIVE* **

 

You shouldn't need to provide any other authentication to the ISP for connection using slip unless that is slip isn't supposed to be used in this instance 

 

Try the following please:

no chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
no chat-script gsm01 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
no chat-script gsm2 "" "ATDT*99*1,1#" TIMEOUT 60 "OK"
no chat-script gsm "" "AT!CALL1" TIMEOUT 20 "OK"

chat-script gsm "" "ATDT*99#" TIMEOUT 30 "CONNECT"
chat-script gsm "" "AT!CALL" TIMEOUT 30 "CONNECT"



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future
Highlighted
Beginner

Re: Unable to configure cellular connectivity

Hi all,

 

Firstly, thanks to everyone who helped with this issue.

 

We have finally got some of our routers to now work with our BT and three.co.uk SIMs. Unfortunately, we have come to the conclusion that we have a defective C881G-4G-GA-K9 though :( So that's going to the WEEE disposal!

 

What we generally found is:

  • It can take 10-15 mins for the cellular hardware to get online (after the router is online).
  • Having something like a laptop setup to constantly ping the internet (eg: 8.8.8.8) via NAT, makes a big difference in "persuading" the router to keep trying to get online.
  • A router's IOS defaults for chat-script, line 3, cellular interfaces and controllers, generally should work without any additional configuration. Patience, waiting for the cellular hardware to come online is our biggest take-away from this.

 

For anyone interested, here's our final, working config (on a C887VAG+7-K9):

version 15.7
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname rtr-h000620
!
boot-start-marker
boot-end-marker
!
!
no logging console
enable secret 5 xxx
!
aaa new-model
!
aaa authentication login default local
aaa authentication enable default enable
aaa authorization exec default local
!
aaa session-id common
clock timezone gmt 0 0
clock summer-time gmt recurring
!
ip domain name x.local
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
chat-script hspa-R7 "" "AT!SCACT=1,1" TIMEOUT 60 "OK"
!
username administrator privilege 15 secret 5 x
!
controller VDSL 0
!
controller Cellular 0
!
interface Ethernet0
 no ip address
 shutdown
!
interface ATM0
 no ip address
 shutdown
 no atm ilmi-keepalive
!
interface FastEthernet0
 switchport access vlan 188
 no ip address
!
interface FastEthernet1
 switchport access vlan 188
 no ip address
!
interface FastEthernet2
 switchport access vlan 188
 no ip address
!
interface FastEthernet3
 switchport access vlan 188
 no ip address
!
interface Cellular0
 ip address negotiated
 ip nat outside
 ip virtual-reassembly in
 encapsulation slip
 dialer in-band
 dialer idle-timeout 0
 dialer string hspa-R7
 dialer-group 1
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan188
 ip address 10.11.188.254 255.255.255.0
 no ip proxy-arp
 ip nat inside
 ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
ip nat inside source list 1 interface Cellular0 overload
ip route 0.0.0.0 0.0.0.0 Cellular0
ip ssh version 2
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipv6 permit
ipv6 ioam timestamp
!
access-list 1 permit 10.11.188.0 0.0.0.255
!
control-plane
!
 vstack
privilege exec level 2 show startup-config
privilege exec level 2 show
!
line con 0
 privilege level 15
 no modem enable
line aux 0
line 3
 script dialer hspa-R7
 no exec
 rxspeed 21600000
 txspeed 5760000
line vty 0 4
 exec-timeout 1440 0
 transport input ssh
line vty 5 15
 exec-timeout 1440 0
 transport input ssh
!
end

The SIM profile was cleared, so it was forced to acquire the APN details itself.

 

Thank you

 

 

View solution in original post

Highlighted
VIP Mentor

Re: Unable to configure cellular connectivity

That's valuable information, thanks, and glad you got it to work.

 

Actually, you could set up an IP SLA on the router to continuously ping 8.8.8.8:

 

interface Loopback 1

ip address 1.1.1.1 255.255.255.255

!

ip sla 1

icmp-echo 8.8.8.8 source-interface Vlan 188

frequency 3

!

ip sla schedule 1 life forever start-time now

!

ip route 8.8.8.8 255.255.255.255 Cellular0

Highlighted
VIP Mentor

Re: Unable to configure cellular connectivity

Hello @Group IT 

That is good news, Glad to see you have found a solution, and thanks for sharing your findings



kind regards
Paul

Please rate and mark posts accordingly if you have found any of the information provided useful.
It will hopefully assist others with similar issues in the future