cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
233
Views
0
Helpful
5
Replies
Beginner

Unable to get 1841 DHCP Assigning

Hello,

 

I'm pretty new to my studies, but have built a small home lab for practice.  Today I configured two 2960 and one 3560 with with separate vlans and trunks.  Everything seems to be working other than DHCP.  

 

Running config from router:

 

R1#sh run
Building configuration...

Current configuration : 2090 bytes
!
! Last configuration change at 22:55:42 UTC Fri Feb 1 2019
!
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 $1$X0BP$FgWpZ9gXsyeXW4TZXMN5O0
!
no aaa new-model
!
dot11 syslog
ip source-route
!
!
!
ip dhcp excluded-address 192.168.1.1 255.255.255.0
ip dhcp excluded-address 192.168.1.255 255.255.255.0
ip dhcp excluded-address 192.168.2.1 255.255.255.0
ip dhcp excluded-address 192.168.2.255 255.255.255.0
ip dhcp excluded-address 192.168.3.1 255.255.255.0
ip dhcp excluded-address 192.168.3.255 255.255.255.0

!
ip dhcp pool VLAN101
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.2 8.8.8.8
!
ip dhcp pool VLAN102
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
!
ip dhcp pool VLAN103
network 192.168.3.0 255.255.255.0
default-router 192.168.3.1
!
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
crypto pki token default removal timeout 0
!
!
!
!
license udi pid CISCO1841 sn FTX0951Z126
!
redundancy
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.101
encapsulation dot1Q 101
ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0.102
encapsulation dot1Q 102
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.103
encapsulation dot1Q 103
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
clock rate 125000
!
interface Serial0/0/1
no ip address
shutdown
clock rate 125000
!
interface Serial0/1/0
no ip address
shutdown
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging esm config
!
!
!
!
!
!
control-plane
!
!
!
line con 0
password 7 01100F175804
logging synchronous
line aux 0
line vty 0 4
password 7 13061E010803
login
transport input all
!
scheduler allocate 20000 1000
end

 

My end goal was to configure ROAS with three vlans (one for each switch)  

 

Any help is greatly appreciated!

5 REPLIES 5
VIP Advisor

Re: Unable to get 1841 DHCP Assigning

Do you have  configured helper ?

ip helper-address x.x.x.x 

 

BB
*** Rate All Helpful Responses ***
Highlighted
Beginner

Re: Unable to get 1841 DHCP Assigning

I have not, how and what should this be configured to?

Thank you.
VIP Advisor

Re: Unable to get 1841 DHCP Assigning

here is the sample config guide to understand also how that works.

 

https://www.freeccnaworkbook.com/workbooks/ccna/configuring-an-ip-dhcp-helper-address

 

BB
*** Rate All Helpful Responses ***
Hall of Fame Guru

Re: Unable to get 1841 DHCP Assigning

 

You don't need IP helper addresses because the pools are on the router. 

 

Can you change these entries - 

 

ip dhcp excluded-address 192.168.1.1 255.255.255.0
ip dhcp excluded-address 192.168.1.255 255.255.255.0
ip dhcp excluded-address 192.168.2.1 255.255.255.0
ip dhcp excluded-address 192.168.2.255 255.255.255.0
ip dhcp excluded-address 192.168.3.1 255.255.255.0
ip dhcp excluded-address 192.168.3.255 255.255.255.0

 

to

 

ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 192.168.3.1

 

you have defined the exclusions incorrectly ie. you should have the start IP and optionally the end IP but you have used a subnet mask as the second argument and I think the router is excluding all IPs in the pools. 

 

You do not need to exclude the broadcast address for the subnet, the router will not hand that out as a DHCP IP. 

 

Jon

VIP Advisor

Re: Unable to get 1841 DHCP Assigning

@Jon Marshall  you are right, i missed that..looks like i am missing the numbers today..  Good catch and thank you.

 

BB
*** Rate All Helpful Responses ***
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards