cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
531
Views
5
Helpful
15
Replies
edwardforgacs
Beginner

Unable to send SMS on LTE EHWIC

I am unable to get SMS sending to work using a EHWIC-4G-LTE in a 2900 series router.

IP connectivity works fine with the cellular module and it can also receive SMS messages. Sending fails every time with the following error, both using E.164 and local number formats:

%CELLWAN-4-OUTGOING_SMS_ERROR: Cellular0/2/0 failed to send an outgoing SMS

I also tried enabling debug cellular 0/2/0 messages sms which produced no useful debugs, and then all all messages debugging which just produced unintelligible hex dumps.

show cellular 0/2/0 sms shows the below. An archive FTP url is set and the archiving works, but it is not shown below.

Total SMS sent successfully = 0
Total SMS send failure = 8
Number of outgoing SMS pending = 0
Number of successful archive since booting up = 4
Number of failed archive since booting up = 4
Last Outgoing SMS Status = RECEIVED SEND NOTIFICATION
Copy-to-SIM Status = 0xFF
Send-to-Network Status = 0xFF
Report-Outgoing-Message-Number:
Reference Number = 0
Result Code = 0xFF
Diag Code = 0x0 0x0 0x0 0x0 0x0

 

IOS version is 15.7(3)M8. Is this a bug?

15 REPLIES 15
pman
Participant

Unfortunately not, I have already seen that document, and it also refers to the newer NIMs (G3 ISRs) not the EHWIC (G2 ISR) which was referred to in the original question.

There appear to be very few commands to actually configure in relation to the cellular controller.

It's a 2911 and no I unfortunately don't have a LTE NIM to be able to test this in a 4000 series platform.

It is absolutely supposed to be supported on the 2900 series however and I note the end of support date for the 2900 series is 31-Dec-2022.

Hello,

 

indeed, end of support is usually a few years later than end of life. This one is going to be difficult to resolve, as it is caused by either combination of hardware/SIM/IOS version.

 

Post the full running config anyway, maybe we can spot something...

Thanks for the reply, unfortunately that is a little tricky as this is actually a production device with a non-trivial config. The issue came up during an attempt to enable SMS notifications (which had been used in the past with older IOS, but was not currently enabled). These are some relevant bits of the config. Is there really anything else that could affect something as basic as the SMS capability of the LTE card? I wonder if the carrier does not support LTE-based SMS and the 3G fallback is not working somehow, but I could not find a way to force it to use 3G or GSM-based SMS.

 

controller Cellular 0/2
lte sms archive path ftp://*****@192.168.**/sms
no lte gps enable
lte modem link-recovery rssi onset-threshold -110
lte modem link-recovery monitor-timer 20
lte modem link-recovery wait-timer 10
lte modem link-recovery debounce-count 6


interface Cellular0/2/0
description Telstra LTE
ip address negotiated
ip nat outside
ip virtual-reassembly in
ip virtual-reassembly out
ip verify unicast reverse-path
encapsulation slip
dialer in-band
dialer idle-timeout 0
dialer string lte
dialer-group 1
!
interface Cellular0/2/1
no ip address
encapsulation slip


sh controllers cellular 0/2/0

Interface Cellular0/2/0
4G WWAN EHWIC - Global Multimode(Australia) LTE/DC-HSPA+/HSPA+/HSPA/UMTS/EDGE/G unit 0

EHWIC Cellular Modem Configuration
====================================
Modem is recognized as valid for this EHWIC
manufacture id: 0x00001199 product id: 0x000068C0
Sierra Wireless Direct IP MC7304 modem
Modem Uplink Speed = 50000 kbit.
Modem Downlink Speed = 100000 kbit.

 

sh cellular 0/2/0 hardware
Modem Firmware Version = SWI9X15C_05.05.58.00
Modem Firmware built = 2015/03/04 21:30:23
Hardware Version = 1.0
Device Model ID: MC7304
Package Identifier ID: 1102029_9903299_MC7304_05.05.58.00_00_Cisco_005.014_000
International Mobile Subscriber Identity (IMSI) = *****
International Mobile Equipment Identity (IMEI) = *****
Integrated Circuit Card ID (ICCID) = ****
Mobile Subscriber Integrated Services
Digital Network-Number (MSISDN) =
Modem Status = Online
Current Modem Temperature = 31 deg C
PRI SKU ID = 1102029, PRI version = 005.021_000, Carrier = Telstra
OEM PRI version = 05.14

 

The rest of the config on the device is basically the NAT and VPN config. The LTE card is used as fallback for the primary link Gi0/1. Not sure if it is relevant but IPv6 is enabled on the device - but only on the ethernet interfaces of course (as the cellular ones don't seem to support that either).

Hello,

 

I am not sure why the archive path does not show up in the output, how did you enter the command ?

 

2911(config-controller)# lte sms archive path ftp://username:password@192.168.*.*/sms

 

Check if you can set the FTP source interface on the router:

 

ip ftp source-interface interface

 

And what syntax do you use to send the SMS ?

 

2911# cellular 0/2/0 lte sms send 12345678911 (you need 10 or 11 digits)


@Georg Pauwen wrote:

I am not sure why the archive path does not show up in the output, how did you enter the command ?


Sorry, it does, it was redacted.

And what syntax do you use to send the SMS ?

I have tried both the 10-digit format (for Australia) as well as E.164 format i.e. +61XXXXXXXXX

Hello,

 

can you for the sake of testing try and send a message to your own mobile phone ?

 

2911# cellular 0/2/0 lte sms send mobile_phone_number

Yes that's exactly how I have been testing already.

Hello,

 

which IOS version are you running ? It might be worth upgrading (obviously only if you are not already running the latest stable version), since newer version also contain newer versions of the microcode/firmware for the modem...

 

Post the output of:

 

sh ver

Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.7(3)M8, RELEASE SOFTWARE (fc1)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2021 by Cisco Systems, Inc.
Compiled Tue 02-Mar-21 07:51 by prod_rel_team

ROM: System Bootstrap, Version 15.0(1r)M15, RELEASE SOFTWARE (fc1)

sydney-edge uptime is 1 day, 19 hours, 39 minutes
System returned to ROM by reload at 14:40:08 AEST Sun Oct 17 2021
System restarted at 14:41:57 AEST Sun Oct 17 2021
System image file is "flash:c2900-universalk9-mz.SPA.157-3.M8.bin"
Last reload type: Normal Reload

 

As far as I am aware that is the latest IOS for the 2911. The firmware on the LTE card has also been updated recently to the carrier-specific version MC7304_1102029_05.05.58.00_00_TELSTRA_005.014_000 (which is a separate process to updating IOS)

Georg Pauwen
VIP Expert

Hello,

 

which 2900 model do you have ? I think the 2900 series has been end of life for a couple of years now, chances are you need a 16.x or higher release. Do you have a possibility to test your SIM in a newer device ?

Georg Pauwen
VIP Expert

Hello,

 

just to be sure, can you check if your SIM might be out of data (allowance) ?

 

Or you could try to delete and recreate the cell 0/2/0 lte profile...

 

 

Re-creating the LTE profile has been tried and it is definitely not out of data as IP traffic works. Thanks for the suggestion.

I think I am going to have to leave this one until I can obtain another SIM card on a different type of plan. As this one was worked in the past, I suspect the carrier may have implemented some sort of block due to the plan being primarily intended for data. I will report back if I can get it to work.