Showing results for 
Search instead for 
Did you mean: 

USB Console Driver install failing


Running Windows 7 64-bit and the USB driver install is failing.  Well, the setup program runs ok and reboots, but when I connect to a USB console, it installs the Console driver ok but fails on "Cisco Virtual Comm Port00".  I've tried this on multiple machines as administrator and still no joy.

Any ideas?



Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend

What are you trying to install???

I thought it was fairly obvious.  The USB Console Drivers on a PC so we can configure via USB. 

Leo Laohoo
VIP Community Legend VIP Community Legend
VIP Community Legend
I thought it was fairly obvious.  The USB Console Drivers on a PC so we can configure via USB.

Have you tried to install this proggie on a 32-bit machine?  I know some Cisco "USB drivers" won't work in 64-bit.

I have installed the driver software on 32-bit Windows 7. The driver software install is ok but when I connect my USB-to-miniUSB cable, the system attempts to install the device driver but reports "Cisco Virtual Comm Port00      X failed".

What a frustrating experience.  Has this really been out there since 2005 and Cisco still hasn't made it work? 

I'm having the same issues as above, and while the work around seemed to work, Putty and SecureCRT aren't recognizing the COM port (10 in this case).  I open Device Manager again and the Cisco Virtual Comm Port driver has disappered.


Any update on the 64 bit drivers for Windows 7?  I'm having this same trouble.  If I had access to a laptop with a serial port I'd use it but I don't.  I had a great USB to serial adapter that also doesn't work on win 7 64 bit.  You'd think a large market share holder like Cisco could get the USB drivers to WORK on the most commonly used business Windows out there...

Dale McKay

Any update on this??

Tried multiple machines, still get the report that the "Cisco Virtual Comm Port 00 failed" when you connect the USB console cable and the PC goes thru the installing device driver sequence.

Worked like a charm!


We were having the same issue installing the USB console driver on a Windows 7 x64 Professional version.  This is how we were able to resolve the issue:

1) Install the usb console driver\windows 64\setup(x64)

2) Follow the wizard and accept the defaults

3) Restart the computer (the installer usually says it needs a restart)

4) After restarting the computer, plug in the usb cable

5) The computer should say installing Device driver software and fail at the Cisco Virtual Comm Port00

6) Click the Windows button, right click computer, manage

7) Under Computer Management, Click Device Management

8) Go to Ports (COM & LPT)

9) You should see the Cisco Virtual Comm Port00 with a Yellow Exclamation point on it

10) Right Click on the Cisco Virtual Comm Port00 and select Properties

11) Click the Driver Tab

12) Click Update Driver

13) Select Browse my computer for driver software

14) Select Let me pick from a list of device drivers on my computer

15) Choose the Cisco Serial Driver

16) Device Driver is installed successfully, take note of the com port it is using and enjoy.

Hope this helps.

I just tried this solution and it worked like a charm.Thanks Greg!!!



We have EXACTLY the same problem here and unfortunately the steps above do not help us out at all. It simply tells us that we have the most up to date driver installed. We have no option to install anything else 'over the top'.

This is really quite a frustrating issue and I am shocked that this wasn't tested by Cisco in their own lab. With so many people having this issue, surely it is common place.

Can we get a fix for this one ASAP?



on step 13, dont choose the search automatically for updated driver software, choose the browse my computer for driver software, Then in step 14 choose the let me pick from a list of device drivers on my computer, this process , the default driver installed is the cypress driver. dont choose the update automatically option.

Hope this helps!

I'm having the same problem, however as I go through these steps, even with the screenshot, when i click Cisco Serial, it says something about an INF file not being available for that.  Which makes no sense since the install worked just fine. 

I've opened a case with TAC, seems silly but there is nothing else left to do.

Attached is a screenshot of the properties of COM4 and also of the error around the INF file.


I am not sure why you would be having an issue with the inf file.  Have you tried to uninstall an reinstall the driver accoring to:

Also, are you installing the 3.1 version of the driver?

As for the properties:

Make sure you are looking under the Ports (and look for the Cisco Virtual Comm Port00)

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: