cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
288
Views
5
Helpful
6
Replies
Beginner

Using L3 Switches to route between 2 locations

As indicated in the drawing below, we are currently connecting 2 locations on MPLS.  There is a Cisco 800 series router serving as CPE in each location.  The MPLS will be upgraded to 100 Mbps, which exceeds the capacity of the 800 router.  Therefore, telco advise us to make use of existing L3 switched for inter-site routing.  This will completely eliminate the Cisco 800.  Performance will improve as L3 routing is more efficient for linking WAN's. 

 

I have done some VLAN configuration, mostly for isolating traffic.  I am not sure how we can make use of L3 routing to achieve this goal.  Based on the existing design, I am thinking of creating a VLAN for the /30 subnet (i.e. 10.1.1.1/30 & 10.2.1.1/30) in each location.   Then I will add a static route for inter-site traffic to go through the VLAN interface.

 

Is that a correct approach?  Any suggestions or advice will be much appreciated.

 

 

 

 

 

Drawing1.jpg

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Using L3 Switches to route between 2 locations

Hi @JKwan,

You can enable OSPF in Global configuration:

router ospf X    (where 'X' is the OSPF process ID. It can be just number 1)
network x.x.x.x 0.0.0.0 area 0 (Where x.x.x.x is the IP address of one of your interfaces participating in OSPF)
or just
network 0.0.0.0.0 255.255.255.255 area 0 (This config lines makes OSPF advertise every single subnet the L3 Switch has in its Routing Table as Directly Connected)

or with OSPF Interface configuration mode:

router ospf X
!
interface vlanABC
 ip ospf X area 0
!
interface Ethernety/z
 ip ospf X area 0

You can check OSPF with the next commands (among several others):

show ip ospf interface brief   (What Layer 3 interfaces participate in OSPF)
show ip ospf neighbor    (What Layer 3 adjacency network devices we are forming an OSPF neighborship)
show ip route ospf    (Routes the Layer 3 Switch is learning via OSPF)

Be advised that while enabling a Routing protocol is easy configuration perspective, you need to properly understand how it operates, how to review its operation using CLI commands and how to troubleshoot it if necessary.

Routing Protocols, specially OSPF, are a whole topic in its own.

Here a nice place to being:

http://www.ciscopress.com/articles/article.asp?p=26919&seqNum=3

 

Cheers.

6 REPLIES 6

Re: Using L3 Switches to route between 2 locations

Hi @JKwan,

You are on the right track.

You can either terminate the connection on an SVI interface. For example:

configure terminal
!
vlan ABC
! interface vlanABC ip address 10.1.1.1 255.255.255.252 no shutdown
!
interface Ethernety/z
switchport mode [access | trunk] (Access for no dot1q tag. Trunk for dot1q tag from ISP)
switchport access vlan ABC (if you are expecting to receive no dot1q tag from ISP)
switchport trunk allowed vlan ABC (if you are expecting to receive a dot1q tag from ISP)
no shutdown
!

or on a Layer 3 interface (or subinterface if your ISP is sending you the traffic with 802.1q tags). For example"

configure terminal
!
interface Ethernety/z       (if you are expecting to receive no dot1q from ISP)
 no switchport
 ip address 10.1.1.1 255.255.255.252
 no shutdown

or
interface Ethernety/z.ABC (if you are expecting to receive a dot1q tag from ISP) encapsulation dot1q ABC ip address 10.1.1.1 255.255.255.252 no shutdown

If your current Cisco 800 are using Static Routes as opposed to a Dynamic Routing Protocol (BGP, EIGRP, OSPF) you can most likely do the same on your L3 Switches.

I don't see any major concern with this approach.

Regards.

 

 

DISCLAIMER:

The configurations discussed in this post can be merely templates and may not be final configurations that can be just copied & pasted to any network device in a production environment. It is responsibility of whoever follows this suggestions to review, evaluate and modify the configurations at convenience. Ensure that you understand the potential impact of any command. In all cases, make sure not to lose remote management access to the device. It is highly suggested to introduce changes to live networks only during maintenance windows. The author of this post is not responsible of unintended consequences by failing to follow this disclaimer note.

 

Beginner

Re: Using L3 Switches to route between 2 locations

I see.  I will try out the solution you suggested with the L3 switch.  

 

One further questions since you mentioned about routing protocol.  Currently we are using static routes but Telco suggested choosing OSPF.  What should I do on the L3 switch to enable this?

 

Re: Using L3 Switches to route between 2 locations

Hi @JKwan,

You can enable OSPF in Global configuration:

router ospf X    (where 'X' is the OSPF process ID. It can be just number 1)
network x.x.x.x 0.0.0.0 area 0 (Where x.x.x.x is the IP address of one of your interfaces participating in OSPF)
or just
network 0.0.0.0.0 255.255.255.255 area 0 (This config lines makes OSPF advertise every single subnet the L3 Switch has in its Routing Table as Directly Connected)

or with OSPF Interface configuration mode:

router ospf X
!
interface vlanABC
 ip ospf X area 0
!
interface Ethernety/z
 ip ospf X area 0

You can check OSPF with the next commands (among several others):

show ip ospf interface brief   (What Layer 3 interfaces participate in OSPF)
show ip ospf neighbor    (What Layer 3 adjacency network devices we are forming an OSPF neighborship)
show ip route ospf    (Routes the Layer 3 Switch is learning via OSPF)

Be advised that while enabling a Routing protocol is easy configuration perspective, you need to properly understand how it operates, how to review its operation using CLI commands and how to troubleshoot it if necessary.

Routing Protocols, specially OSPF, are a whole topic in its own.

Here a nice place to being:

http://www.ciscopress.com/articles/article.asp?p=26919&seqNum=3

 

Cheers.

Beginner

Re: Using L3 Switches to route between 2 locations

Very good.  I will follow your direction and see how it goes.

 

Will let you know.  Thanks for your help.

Highlighted

Re: Using L3 Switches to route between 2 locations

Ensure to optimize neighboring up using networ type p2p if you only have 2 speakers on IGP

 

It skip dr and bdr dessicion

Enthusiast

Re: Using L3 Switches to route between 2 locations

why OSPF? I would go with EIGRP
CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards