cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

241
Views
0
Helpful
1
Replies
Beginner

VRF EIGRP REDISTRIBUTION INTO VRF OSPF

Hello everyone. 

So we have two border routers with VRF inside of it.

in global routing we have EIGRP 195 and it has BGP Connections also. in VRF (named BRANCH) we have also eigrp 195, we have tunnels to our branch offices and they are getting default route from VRF (named BRANCH) Eigrp 195. 

 

From one router we have one tunnel to branch office. so Primary and backup. 

 

Currently everything works but we want to make reconfiguration like this : 

We are changing from ASA to checkpoint and we want to have OSPF routing. I want to have VRF EIGRP 195 with branches, then want to redistribute that total VRF EIGRP Routes into OSPF which will be visible for checkpoint also.

 

If i am doing redistribution for Primary VRF Instance it works but i am redistributing Secondary VRF EIGRP 195 into ospf then routes are getting crazier. 

 

currently running EIGRP195 config is like this : 

 

router eigrp 195
!
address-family ipv4 vrf BRANCH autonomous-system 195
  network 10.X.X.X 0.0.0.255 (Interconnection to ASA Firewall SubInterface)
  network 223.X.X.X. 0.0.255.255 (Tunnel IP Addresses)
exit-address-family
network 185.X.X.X 0.0.0.15 (Global routing Interconnection)
no passive-interface GigabitEthernet0/0/2.200

 

Future Config should be like this : 

 

router eigrp 195
!
address-family ipv4 vrf BRANCH autonomous-system 195
  network 223.X.X.X. 0.0.255.255 (Tunnel IP Addresses)
exit-address-family

 

router ospf 777 vrf BRANCH
redistribute eigrp 195 metric 50 subnets
network 10.X.X.X 0.0.0.255 (Interconnection to ASA Firewall SubInterface) area 0
distance 190

 

router ospf 888
redistribute ospf 777
passive-interface default
network 185.X.X.X 0.0.0.15 (Global routing Interconnection)
no passive-interface GigabitEthernet0/0/2.200

 

When i done that configuration ( Primary Distance 190, Metric 50, Secondary Distance 190, Metric 100) 

 

I was getting routes flapping between this two VRF Instance and also in Checkpoint device.

 

What i am missing i cant understand. 
For visualization what i am trying to achieve attaching drawing of topology. 

 

redistr.jpg

1 REPLY 1
Highlighted

Re: VRF EIGRP REDISTRIBUTION INTO VRF OSPF

 

Hi,

 

I have questions on your setup:

 

1) Where is the ASA? Is it being replaced with Checkpoint? If yes, is "no passive-interface GigabitEthernet0/0/2.200" command still needed on OSPF connecting to Checkpoint? Do you need to replace it with different interface?

2) You mentioned that you are getting routes flapping between the two VRFs; which two VRFs?

 

HTH,

Meheretab

CreatePlease to create content
Content for Community-Ad
August's Community Spotlight Awards