cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
459
Views
0
Helpful
0
Replies

VRF over EIGRP through DMVPN using loopback as VRF interface

seustache
Level 1
Level 1

Hello,

 

I am attempting to get VRF in EIGRP using loopback as a VRF interface to work without using sub-interfaces. Basically I am using BGP as my underlayin network and I am running DMVPN duel hub on top of that. The DMVPN establishes EIGRP neighborship with the remote site (Branch B). I want to add a loopback interface to that same EIGRP process is possible. Currently only interface tunnel 10 is online. The other tunnel is offline. I am using physical interface FA0/1 (description "HT")

 

Basically BGP is my physical site to site connectivity using the ("HT") interface. I am running DMVPN on top of that which establishes EIGRP neighborship with the remote site. I want Loopback 5 to run on VRF over the EIGRP w/o using sub interfaces, if possible.

Please see running config below

------------------------------------------------------------------------------------------

service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Branch A
!
!
ip vrf Oahu
description Oahu VRF
rd 10:10
!
interface Loopback5
description VRF Oahu
ip vrf forwarding Oahu
ip address 192.168.111.50 255.255.255.255
!
interface Loopback10
description ISP BGP
ip address 10.200.50.10 255.255.255.255
!
interface Loopback20
description ISP BGP
ip address 10.200.50.20 255.255.255.255
!
interface Loopback30
description EGIRP tunnel
ip address 10.200.50.30 255.255.255.255
!
interface Loopback40
description EGIRP tunnel
ip address 10.200.50.40 255.255.255.255
!
interface Loopback50
description ANP OSPF
ip address 10.200.50.50 255.255.255.255
!
interface Loopback60
description ANP OSPF
ip address 10.200.60.50 255.255.255.255
!
interface Loopback70
description Vendor BGP
ip address 10.200.50.70 255.255.255.255
!
interface Loopback80
description Vendor BGP
ip address 10.200.50.80 255.255.255.255
!
interface Tunnel10
description DMVPN HUB
ip address 192.168.100.50 255.255.255.0
no ip redirects
no ip next-hop-self eigrp 1
ip nhrp authentication cisco
ip nhrp map multicast dynamic
ip nhrp network-id 200
ip nhrp shortcut
ip nhrp redirect
no ip split-horizon eigrp 1
delay 5
tunnel source 10.200.50.2
tunnel mode gre multipoint
!
interface FastEthernet0/0
description DR
ip address 192.168.0.1 255.255.255.252
ip ospf 100 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
description HT
ip address 10.200.50.2 255.255.255.252
duplex auto
speed auto
!
!
router eigrp 1
passive-interface default
no passive-interface Tunnel10
network 10.200.50.30 0.0.0.0
network 10.200.50.40 0.0.0.0
network 192.168.100.0
no auto-summary
!
address-family ipv4 vrf Oahu
network 192.168.111.0
auto-summary
autonomous-system 10
exit-address-family
!
router ospf 100
log-adjacency-changes
passive-interface default
no passive-interface FastEthernet0/0
network 10.200.50.50 0.0.0.0 area 0
network 10.200.60.50 0.0.0.0 area 0
!
router bgp 50
no synchronization
bgp log-neighbor-changes
network 5.200.0.0 mask 255.255.255.0
network 10.100.50.0 mask 255.255.255.252
network 10.200.50.0 mask 255.255.255.252
network 10.200.50.10 mask 255.255.255.255
network 10.200.50.20 mask 255.255.255.255
network 10.200.50.21 mask 255.255.255.255
network 10.200.60.0 mask 255.255.255.252
neighbor 10.0.0.1 remote-as 1000
neighbor 10.0.0.1 description Vendor Network
neighbor 10.100.50.1 remote-as 100
neighbor 10.100.50.1 description CL
neighbor 10.100.50.1 soft-reconfiguration inbound
neighbor 10.200.50.1 remote-as 200
neighbor 10.200.50.1 description HT
neighbor 10.200.50.1 soft-reconfiguration inbound
no auto-summary
!

------------------------------------------------------------------

 

hostname Branch B
!
!
ip vrf Oahu
description Oahu VRF
rd 10:10
!
!
interface Loopback5
description VRF Oahu
ip vrf forwarding Oahu
ip address 192.168.111.10 255.255.255.0
!
interface Loopback10
description ISP BGP
ip address 10.200.10.10 255.255.255.255
!
interface Loopback20
description ISP BGP
ip address 10.200.10.20 255.255.255.255
!
interface Loopback30
description EGIRP tunnel
ip address 10.200.10.30 255.255.255.255
!
interface Loopback40
description EGIRP tunnel
ip address 10.200.10.40 255.255.255.255
!
interface Loopback100
ip address 10.200.10.255 255.255.255.255
!
interface Tunnel10
description DMVPN spoke
ip address 192.168.100.10 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map 192.168.100.50 10.200.50.2
ip nhrp map multicast 10.200.50.2
ip nhrp network-id 200
ip nhrp nhs 192.168.100.50
ip nhrp shortcut
tunnel source 10.200.10.2
tunnel mode gre multipoint
!
interface Tunnel20
description DMVPN spoke Secondary
ip address 172.168.100.10 255.255.255.0
no ip redirects
ip nhrp authentication cisco
ip nhrp map multicast 10.100.60.2
ip nhrp map 172.168.100.60 10.100.60.2
ip nhrp network-id 100
ip nhrp nhs 172.168.100.60
ip nhrp shortcut
delay 300
tunnel source 10.100.10.2
tunnel mode gre multipoint
!
interface GigabitEthernet0/0
description HT
ip address 10.200.10.2 255.255.255.252
duplex auto
speed auto
media-type rj45
!
interface GigabitEthernet1/0
description CL
ip address 10.100.10.2 255.255.255.252
negotiation auto
!
router eigrp 1
passive-interface default
no passive-interface Tunnel10
no passive-interface Tunnel20
network 10.200.10.30 0.0.0.0
network 10.200.10.40 0.0.0.0
network 172.168.100.0 0.0.0.255
network 192.168.100.0
no auto-summary
!
address-family ipv4 vrf Oahu
network 192.168.111.0
auto-summary
autonomous-system 10
exit-address-family
!
router bgp 10
no synchronization
bgp log-neighbor-changes
network 10.100.10.0 mask 255.255.255.252
network 10.200.10.0 mask 255.255.255.252
network 10.200.10.10 mask 255.255.255.255
network 10.200.10.20 mask 255.255.255.255
neighbor FHB-HT peer-group
neighbor FHB-CL peer-group
neighbor 10.100.10.1 remote-as 100
neighbor 10.100.10.1 peer-group FHB-CL
neighbor 10.200.10.1 remote-as 200
neighbor 10.200.10.1 peer-group FHB-HT
no auto-summary
!

0 Replies 0
Review Cisco Networking products for a $25 gift card