03-01-2023 03:40 AM
Hello, I'm having quite some trouble setting up my VRFs and I was wondering if anyone here could tell me what I'm doing wrong. The network topology is as shown on the picture. I have to setup two VRFs using BGP - one for CE_Prague and CE_Warsaw, and another VRF for CE_Barcelona and CE_Florence. I already did that - I made a vrf named ELI for the first two, and a vrf named KATI for the second two. The problem is the two CE routers that belong to the same VRF cannot see each other, therefore, cannot ping each other which is the main task. I'm really stuck and I don't know what I'm supposed to do so I'd be very glad if any of you can help me.
Solved! Go to Solution.
03-01-2023 06:00 AM - last edited on 03-21-2023 03:23 AM by Translator
Hi @elizabethf ,
I have various observations from the configs you posted.
- You have no VPNv4 configuration between the PE and the RR as noted by @MHM Cisco World .
- Your CE do not advertised their loop back addresses, which I suppose is the goal of the exercise.
for instance CE Warsaw should have a network statement as follow:
network 192.168.0.3 mask 255.255.255.248
- Since both CEs within the same VRF have the same AS, the update will not be accepted from one CE to the other, unless you configure the following on the BGP session towards the CE on the PE.
neighbor x.x.x.x as-override
Regards,
03-01-2023 04:23 AM
you need three step
redistribute the prefix from routing protocol you run between CE-PE into BGP (address ipv4 vrf)
redistribute the prefix from BGP into CE-PE routing protocol
last must sure the route-target in both side is mirror meaning
import in one side is same as export on other side, for lab it better use route-target both x:x
03-01-2023 04:26 AM
I use BGP between CE and PE, I have done everything and it still doesnt work...
03-01-2023 04:33 AM
Did you redistreibte connect under add family ipv4 in both side?
If not only add redistrubte connect and check again
03-01-2023 04:38 AM
i redistributed the connected routes under both of them - the ipv4 family and the bgp.. they still can't see each other
03-01-2023 04:39 AM
share the config of CE PE on both side
03-01-2023 04:52 AM - last edited on 03-21-2023 03:17 AM by Translator
CE_xxx:
interface GigabitEthernet1/0
ip address 87.85.83.17 255.255.255.252
negotiation auto
!
interface GigabitEthernet2/0
ip address 87.85.83.21 255.255.255.252
negotiation auto
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet5/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet6/0
no ip address
shutdown
negotiation auto
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 87.85.83.18 remote-as 1234
neighbor 87.85.83.22 remote-as 1234
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
PE_xxx
hostname xxx
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
ip vrf ELI
rd 1:1
route-target export 1:1
route-target import 1:1
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 200.200.200.3 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 87.85.80.17 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet2/0
ip address 87.85.80.21 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet5/0
ip address 87.85.83.26 255.255.255.252
negotiation auto
!
interface GigabitEthernet6/0
ip vrf forwarding ELI
ip address 87.85.83.18 255.255.255.252
negotiation auto
!
router ospf 1
mpls ldp autoconfig
log-adjacency-changes
redistribute connected subnets
redistribute bgp 1234 subnets
network 87.85.80.16 0.0.0.3 area 0
network 87.85.80.20 0.0.0.3 area 0
network 200.200.200.3 0.0.0.0 area 0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
bgp redistribute-internal
network 87.85.80.16 mask 255.255.255.252
network 87.85.83.16 mask 255.255.255.252
network 87.85.83.24 mask 255.255.255.252
network 200.200.200.8 mask 255.255.255.255
redistribute connected
neighbor 87.85.83.17 remote-as 65000
neighbor 87.85.83.25 remote-as 65000
neighbor 195.193.191.1 remote-as 1234
neighbor 195.193.191.5 remote-as 1234
neighbor 200.200.200.7 remote-as 1234
neighbor 200.200.200.7 update-source Loopback0
neighbor 200.200.200.8 remote-as 1234
neighbor 200.200.200.8 update-source Loopback0
no auto-summary
!
address-family ipv4 vrf ELI
redistribute connected
redistribute static
neighbor 87.85.83.17 remote-as 65000
neighbor 87.85.83.17 activate
no synchronization
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
mpls ldp router-id Loopback0
!
control-plane
!
!
PE_xxx
hostname xxx
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
ip vrf ELI
rd 1:1
route-target export 1:1
route-target import 1:1
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
mpls label protocol ldp
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 200.200.200.1 255.255.255.255
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 87.85.80.1 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet2/0
ip address 87.85.80.5 255.255.255.252
negotiation auto
mpls ip
!
interface GigabitEthernet3/0
ip vrf forwarding ELI
ip address 87.85.83.2 255.255.255.252
negotiation auto
!
interface GigabitEthernet4/0
ip address 87.85.83.10 255.255.255.252
negotiation auto
!
interface GigabitEthernet5/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet6/0
no ip address
shutdown
negotiation auto
!
router ospf 1
mpls ldp sync
mpls ldp autoconfig
log-adjacency-changes
redistribute connected subnets
network 87.85.80.0 0.0.0.3 area 0
network 87.85.80.4 0.0.0.3 area 0
network 200.200.200.1 0.0.0.0 area 0
!
router bgp 1234
no synchronization
bgp log-neighbor-changes
network 87.85.80.0 mask 255.255.255.252
network 87.85.80.4 mask 255.255.255.252
network 87.85.83.0 mask 255.255.255.252
network 87.85.83.8 mask 255.255.255.252
redistribute connected
neighbor 87.85.83.1 remote-as 65000
neighbor 87.85.83.9 remote-as 65000
neighbor 195.193.191.1 remote-as 1234
neighbor 195.193.191.5 remote-as 1234
neighbor 200.200.200.7 remote-as 1234
neighbor 200.200.200.7 update-source Loopback0
neighbor 200.200.200.8 remote-as 1234
neighbor 200.200.200.8 update-source Loopback0
no auto-summary
!
address-family ipv4 vrf ELI
redistribute connected
redistribute static
neighbor 87.85.83.1 remote-as 65000
neighbor 87.85.83.1 activate
no synchronization
exit-address-family
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
mpls ldp router-id Loopback0
!
CE_xxx
hostname xxxx
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
!
!
!
interface Loopback0
ip address 192.168.0.3 255.255.255.248
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface GigabitEthernet1/0
ip address 87.85.83.1 255.255.255.252
negotiation auto
!
interface GigabitEthernet2/0
ip address 87.85.83.5 255.255.255.252
negotiation auto
!
interface GigabitEthernet3/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet4/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet5/0
no ip address
shutdown
negotiation auto
!
interface GigabitEthernet6/0
no ip address
shutdown
negotiation auto
!
router bgp 65000
no synchronization
bgp log-neighbor-changes
neighbor 87.85.83.2 remote-as 1234
neighbor 87.85.83.6 remote-as 1234
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
03-01-2023 05:36 AM - last edited on 03-21-2023 03:20 AM by Translator
you config is missing VPNv4 config
what you need
add LO in each PE
advertise this LO in OSPF
then
router bgp x
neighbor LO-of-far-PE remote x
neighbor LO-of-far-PE update source LO-of-this-PE
address family vpnv4 unicast
neighbor LO-of-far-PE activate
03-01-2023 05:47 AM
I have two route reflectors, so the bgp sessions are established between RR and PE, I dont have PE to PE bgp configuration. So how am I supposed to do the vpnv4 configuration then? I'm sorry about my dumb questions but I'm a newbie.
03-01-2023 05:50 AM - last edited on 03-21-2023 03:21 AM by Translator
No
use same config I share above but not between
PE1-PE2 but between PE's-RR
and then
config in RR
neighbour PE1-LO route-reflector-client
neighbour PE2-LO route-reflector-client
neighbour PE1-LO activate
neighbour PE2-LO activate
03-01-2023 06:00 AM - last edited on 03-21-2023 03:23 AM by Translator
Hi @elizabethf ,
I have various observations from the configs you posted.
- You have no VPNv4 configuration between the PE and the RR as noted by @MHM Cisco World .
- Your CE do not advertised their loop back addresses, which I suppose is the goal of the exercise.
for instance CE Warsaw should have a network statement as follow:
network 192.168.0.3 mask 255.255.255.248
- Since both CEs within the same VRF have the same AS, the update will not be accepted from one CE to the other, unless you configure the following on the BGP session towards the CE on the PE.
neighbor x.x.x.x as-override
Regards,
03-01-2023 06:28 AM - last edited on 03-21-2023 03:25 AM by Translator
Thank you very much for the answer, so I added a vpnv4 configuration on both of the Route Reflectors, and I also added the
as-override
command on the PE routers but I still can't get the CEs to recognise each other. I don't know what the issue could be... My teacher told me not to use the loopbacks on the CEs so that's why I haven't set them up yet.
03-01-2023 06:31 AM - last edited on 03-21-2023 03:27 AM by Translator
share the last config of
CE PE and RR
03-01-2023 06:45 AM - last edited on 03-21-2023 03:29 AM by Translator
redistribute connect under the address family ipv4 vrf <<- only correct this and try again
address-family vpnv4
neighbor 200.200.200.1 activate
neighbor 200.200.200.1 route-reflector-client <<- you also need route-reflector-cleint under VPNv4 for ALL PE's
03-01-2023 08:11 AM - last edited on 03-21-2023 03:30 AM by Translator
After doing all of the things you recommended, this is the routing table of CE_Warsaw
87.0.0.0/30 is subnetted, 4 subnets
B 87.85.83.16 [20/0] via 87.85.83.2, 00:35:22
B 87.85.83.20 [20/0] via 87.85.83.2, 00:35:34
C 87.85.83.0 is directly connected, GigabitEthernet1/0
C 87.85.83.4 is directly connected, GigabitEthernet2/0
so that means that CE_Warsaw now knows about the other CE in the VRF, and they can successfully ping each other. But when i type in sh ip bgp sum this is the result:
Neighbor V AS MsgRcvd MsgSent TblVer InQ OutQ Up/Down State/PfxRcd
87.85.83.2 4 1234 45 41 9 0 0 00:36:24 4
87.85.83.6 4 1234 40 41 9 0 0 00:36:29 4
Is this how it's supposed to be? Shouldn't the route to CE_Prague be present in the bgp table since they are in the same VRF or?
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide