cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
3550
Views
0
Helpful
5
Replies
vishal4444
Beginner

vsat communication on cisco router through c& ku band modem with link failover

it is vsat connectivity..........and we have 40 sites..................

& every site having two modem one c band & another is ku band & also one cisco router.......every  wan is coming through modems to switch >>>>to router fe ports.............pls see the diagram & details //////////  suggest me for better solution

In this scenario we have two remote sites (remote  side 1 & remote side 2) which is connecting on IP GATEWAY .

Working style of modem:-

They are using c band modem & ku band modem (supports Rip V2).One end of both the modem is connected to switch & another end is communicating over satellite freq  with hub BASED IP GATEWAY.

I

Requirement for every site...........

1.If packet is going through wan1 then return path should be wan 1.  If forward path is wan 1 then return path should be wan1. Remote side 1 to remote side 2 communication is given below.

2.Means  remote side 1 cband modem  >>>>>>huB BASED IP GATEWAY ) >>>>then it is going on remote side 2 c band>>>& reverse     should be in the same band means C band....

3. i would like all the video & data traffic translated to c band & in case of primary link  down C band traffic  should be  translated on KU band.

FOR VIDEO & DATA,  PRIMARY BAND IS C BAND & KU BAND IS SECONDARY.

4. In case of voice , i would like all the voice traffic translated to the Ku band  & during primary  link down KU band traffic should be translated on C band.

For voice , KU Band is primary & C band is secondary.

5.C band  is working in star topology  (hub & spoke)& KU band  is working in mesh topology.

In this figure, example is given for star.

Diagram attached.

1 ACCEPTED SOLUTION

Accepted Solutions

Hello Vishal,

you can move some steps further in order to improve the solution:

first of all, if VOIP IP subnets are well known and distinct from data vlans you don't even need PBR:

you can use offset-list in a smart way so that Ku band link is the better link for VOIP to VOIP traffic.

hint: you need to use two different access-lists to be invoked under router rip for interface to Ku band and interface to C band

router rip

...

offset .....

offset ....

QoS is needed so you need to mark traffic inbound  on the LAN interface and to appy appropriate scheduler on the WAN interfaces to ensure a better treatment to VOIP traffic over data traffic

Hope to help

Giuseppe

View solution in original post

5 REPLIES 5
Giuseppe Larosa
Hall of Fame Master

Hello Vishal,

you can use RIPv2 with the satellite modems it supports classless routing. It is not very fast in convergence and it has a limit of 15 router hops in the path.

To achieve your requirements you just need to run RIPv2 making the C-band modem preferred.

You can use offset-list on the KU band link in order to make it less attractive for all traffic.

see

http://www.cisco.com/en/US/docs/ios/iproute_rip/command/reference/irr_rip.html#wp1012347

In order to satisfy points 2, 3 of your requirements the offset-list is applied inbound on the FE inteface facing the KU modem in all routers of all POPs including central site.

A PBR rule can divert VOIP packets (both bearer voice payload and voice related signaling) over the KU band link.

Marking the voice packets inbound on internal LAN interfaces allows for the use of queueing, LLQ  is required

PBR:

http://www.cisco.com/en/US/docs/ios/iproute_pi/command/reference/iri_pi1.html#wp1015665

note: if there are security concerns for sending data over the air you should look at DMVPN

to deploy an appropriate mesh of GRE tunnels protected by IPSec this might require more powerful routers

see

http://www.cisco.com/en/US/solutions/ns340/ns414/ns742/ns816/landing_overall_wan.html

Hope to help

Giuseppe

Sir,

     Thanks for Ur reply.

1. I think ,first of all ,we should used ripv2 on all the network .

2. pbr will be used for the voice ,video over wan 1 (primary)& wan2 secondary  &   for data wan2 will be primary (wan1

will be secondary)

one route map on fe interface

&

set ip next hop wan1

or set ip next hop verify-ava wan1

...

We are using 1841 router on all the sites................having  2 ge port &one fe port...............

Please find the configuration ..............  Given Below ...............& if there is any mistake please confirm me.

Current configuration : 1213 bytes

!

version 12.3

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

!

resource policy

!

memory-size iomem 5

ip subnet-zero

!

!

ip cef

no ip dhcp use vrf connected

!

!

no ip ips deny-action ips-interface

!

no ftp-server write-enable

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

ip address 13.13.13.2 255.255.255.0

shutdown

duplex auto

speed auto

!

interface FastEthernet1/0

ip address 11.11.11.1 255.255.255.0

ip policy route-map data

duplex auto

speed auto

!

interface FastEthernet2/0

ip address 12.12.12.2 255.255.255.0

duplex auto

speed auto

!

router rip

version 2

network 11.0.0.0

network 12.0.0.0

network 13.0.0.0

!

ip http server

no ip http secure-server

!

ip classless

!

!

access-list 101 permit ip 11.11.11.0 0.0.0.127 any   (for 1 to 126 ip)

access-list 102 permit ip 11.11.11.128 0.0.0.127 any  (for 129 to 254 )

!

route-map data permit 10

match ip address 101

set ip next-hop 13.13.13.1

set ip next-hop verify-availability

!

route-map data permit 20

match ip address 102

set ip next-hop 12.12.12.1

set ip next-hop verify-availability

!

!

!

control-plane

!

!

!

!

!

!

!

Hello Vishal,

you can move some steps further in order to improve the solution:

first of all, if VOIP IP subnets are well known and distinct from data vlans you don't even need PBR:

you can use offset-list in a smart way so that Ku band link is the better link for VOIP to VOIP traffic.

hint: you need to use two different access-lists to be invoked under router rip for interface to Ku band and interface to C band

router rip

...

offset .....

offset ....

QoS is needed so you need to mark traffic inbound  on the LAN interface and to appy appropriate scheduler on the WAN interfaces to ensure a better treatment to VOIP traffic over data traffic

Hope to help

Giuseppe

View solution in original post

Sir,

First of all Thanks For ur great reply.

  Please see below.. And 2nd  thing i want high convergence during failover .

If my voice call is running & ku band will be down then it should be translated to c band with minimum time means call should not be disconnected (real time application ..)..& same should be c band to ku band......Offset list will resolve this ..or not  or  i should use the ipsla for the same ...

I want high convergence .......

please see my configuration  & what ll be the offset list & access list for the same ..

pls tell me some idea..

My wan 1 is

interface FastEthernet0/0

ip address 13.13.13.2 255.255.255.0

shutdown

duplex auto

speed auto

& wan 2 is

interface FastEthernet2/0

ip address 12.12.12.2 255.255.255.0

duplex auto

speed auto

and local lan is

interface FastEthernet1/0

ip address 11.11.11.1 255.255.255.0

duplex auto

speed auto

And access list is

access-list 101 permit ip 11.11.11.0 0.0.0.127 any   (for 1 to 126 ip) for data video  c band primary & ku band secodandry in case of failover

access-list 102 permit ip 11.11.11.128 0.0.0.127 any  (for 129 to 254  & for  voice ku band  is primary & c band will be secondary in case of link failover .

waiting for ur reply.

Thanks

Vishal

9310253052

vishal4444
Beginner

vishal kumar 2 posts since Jul 29, 2011

Sep 2, 2011 4:40 AM

it is vsat connectivity..........and we have 40 sites..................

&  every site having two modem one c band & another is ku band &  also one cisco router.......every  wan is coming through modems to  switch >>>>to router fe ports.............pls see the  diagram & details //////////  suggest me for better solution

In this scenario we have two remote sites (remote  side 1 & remote side 2) which is connecting on IP GATEWAY .

Working style of modem:-

They are using c band modem & ku band modem (supports Rip V2).One end of both the modem is connected to switch & another end is communicating over satellite freq  with hub BASED IP GATEWAY.

I

Requirement for every site...........

1.If  packet is going through wan1 then return path should be wan 1.  If  forward path is wan 1 then return path should be wan1. Remote side 1 to  remote side 2 communication is given below.

2.Means  remote side 1 cband modem  >>>>>>huB BASED IP GATEWAY ) >>>>then it is going on remote side 2 c  band>>>& reverse     should be in the same band means C  band....

3. i would like all the  video & data traffic translated to c band & in case of primary  link  down C band traffic  should be  translated on KU band.

FOR VIDEO & DATA,  PRIMARY BAND IS C BAND & KU BAND IS SECONDARY.

4. In case of voice , i would like all the voice traffic translated to the  Ku band  & during primary  link down KU band traffic should be  translated on C band.

For voice , KU Band is primary & C band is secondary.

5.C band  is working in star topology  (hub & spoke)& KU band  is working in mesh topology.

In this figure, example is given for star.

Diagram attached.

Attachments: