cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

1488
Views
0
Helpful
2
Replies
Highlighted
Explorer

VSS on 4500X

Hi,

Attempting to setup VSS on 2 x 4500X's using the following guide:


https://supportforums.cisco.com/docs/DOC-29472 

But the portchans go into suspended mode when applied to the physical Ints:

SW1:

interface Port-channel5

switchport

switchport mode trunk

switchport nonegotiate

switch virtual link 1

end

sw1#sh interface tenGigabitEthernet 1/1

TenGigabitEthernet1/1 is up, line protocol is up (connected)

SW2:

interface Port-channel10

switchport

switchport mode trunk

switchport nonegotiate

switch virtual link 2

end

sw2#sh  interface tenGigabitEthernet 1/1

TenGigabitEthernet1/1 is up, line protocol is up (connected)

Then I add physical ports to the portchan, and it complains that trunk mode of the Ints is not compatable? (dynamic vs trunk)

sw1(config)#interface tenGigabitEthernet 1/1

sw1(config-if)#switchport mode trunk

sw1(config-if)#channel-group 5 mode on

WARNING: Interface TenGigabitEthernet1/1 placed in restricted config mode. All extraneous configs removed!

sw1(config-if)#

*Mar 11 16:37:24.004: %EC-5-CANNOT_BUNDLE2: Te1/1 is not compatible with Po5 and will be suspended (trunk mode of Te1/1 is dynamic, Po5 is trunk)

sw2(config)#interface TenGigabitEthernet1/1

sw2(config-if)#switchport mode trunk

sw2(config-if)#channel-group 10 mode on

WARNING: Interface TenGigabitEthernet1/1 placed in restricted config mode. All extraneous configs removed!

sw2(config-if)#

*Jan 22 00:30:13.065: %EC-5-CANNOT_BUNDLE2: Te1/1 is not compatible with Po10 and will be suspended (trunk mode of Te1/1 is dynamic, Po10 is trunk)

interface Port-channel10

switchport

switchport mode trunk

switchport nonegotiate

switch virtual link 2

end

interface TenGigabitEthernet1/1

switchport mode trunk

switchport nonegotiate

no lldp transmit

no lldp receive

no cdp enable

channel-group 10 mode on

service-policy output VSL-Queuing-Policy

If I remove "switch virtual link " from the portchans, and then re-apply them to the tenGig ints, the portchan comes up?

sw2#sh int port-channel 10

Port-channel10 is up, line protocol is up (connected)

Both switches are running 03.04.00.SG and 15.0(1r)SG7 ROM

Any help is greatly appreciated.

Everyone's tags (3)
2 REPLIES 2

VSS on 4500X

Hi,

By seeing this log message that your physical interface is still in dynamic  mode and  disabled in the port-channel.

Jan 22 00:30:13.065: %EC-5-CANNOT_BUNDLE2: Te1/1 is not compatible with Po10 and will be suspended (trunk mode of Te1/1 is dynamic, Po10 is trunk)

Please entry this below command and check the stauts. both should be match . I guess, as per your configuration you will see the difference as physical interface still in dynamic negotation mode.

show int t1/1 switchport

show int po10 sw

EX :

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: On

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Please try to disable dynamic trunking mode in the physical interface and re-configure the port-channel will fix the issue.

Try this below config:

switch(config-if)#switchport mode trunk

Command rejected: An interface whose trunk encapsulation is "Auto" can not be co

nfigured to "trunk" mode. -----------------------------------------------------> normally you will get this error when you change the interface to trunk if the int in auto mode

switch(config-if)#switchport trunk encapsulation dot1q

switch(config-if)#switchport mode trunk

switch(config-if)#switchport nonegotiate

HTH

Regards,

VS.Suresh.

*Plz rate the usefull posts.

Explorer

VSS on 4500X

Thanks for the reply - As I stated in my post, if I remove "switch virtual link" from the portchans, then re-apply them to the physical Ints, the portchan comes up?

And as you can see below, negotiation of Trunking is off on both portchan and tengig1/1:

sw2#show int t1/1 switchport

Name: Te1/1

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down (suspended member of bundle Po10)

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Capture Mode Disabled

Capture VLANs Allowed: ALL

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

sw2#

sw2#show int port-chan10 switchport

Name: Po10

Switchport: Enabled

Administrative Mode: trunk

Operational Mode: down

Administrative Trunking Encapsulation: dot1q

Negotiation of Trunking: Off

Access Mode VLAN: 1 (default)

Trunking Native Mode VLAN: 1 (default)

Administrative Native VLAN tagging: enabled

Voice VLAN: none

Administrative private-vlan host-association: none

Administrative private-vlan mapping: none

Administrative private-vlan trunk native VLAN: none

Administrative private-vlan trunk Native VLAN tagging: enabled

Administrative private-vlan trunk encapsulation: dot1q

Administrative private-vlan trunk normal VLANs: none

Administrative private-vlan trunk associations: none

Administrative private-vlan trunk mappings: none

Operational private-vlan: none

Trunking VLANs Enabled: ALL

Pruning VLANs Enabled: 2-1001

Unknown unicast blocked: disabled

Unknown multicast blocked: disabled

Appliance trust: none

sw2#

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here