cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Join Customer Connection to register!
698
Views
0
Helpful
2
Replies
lgogniat1
Beginner

Wan DSL / ISDN Failover config

Hi

I try to configure a cisco router to set up a failover between ADSL and ISDN lines.

The ISDN line only works if I call at the right dialer.

ADSL line also works if I call the associated dialer

The problem is that automatically switches between ISDN and ADSL is not working.

Can someone help me to understand the problem in my config file ?

Thank you,

Current configuration : 2635 bytes

!

version 12.4

service tcp-keepalives-in

service tcp-keepalives-out

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname cisco

!

boot-start-marker

boot-end-marker

!

security authentication failure rate 3 log

logging console critical

enable secret 5 XXXXXXXXXXXXXXXX

!

no aaa new-model

!

resource policy

!

!

!

ip cef

ip tcp synwait-time 10

!

!

ip name-server 194.2.0.20

ip name-server 194.2.0.50

isdn switch-type basic-net3

username administrateur privilege 15 secret 5 XXXXXXXXXXXXXXXXXXXX

!

!

!

!

interface FastEthernet0

ip address XXX.XXX.XXX.XXX 255.255.255.248

no ip redirects

no ip unreachables

no ip proxy-arp

ip nat inside

ip nat enable

ip route-cache flow

duplex auto

speed auto

!

interface BRI0

no ip address

no ip redirects

no ip unreachables

no ip proxy-arp

encapsulation hdlc

ip route-cache flow

dialer pool-member 2

dialer idle-timeout 10

isdn switch-type basic-net3

isdn point-to-point-setup

no keepalive

!

interface FastEthernet1

!

interface FastEthernet2

!

interface FastEthernet3

!

interface FastEthernet4

!

interface FastEthernet5

!

interface FastEthernet6

!

interface FastEthernet7

!

interface FastEthernet8

!

interface ATM0

no ip address

no atm ilmi-keepalive

pvc 8/35 

  encapsulation aal5mux ppp dialer

  dialer pool-member 1

!

dsl operating-mode auto 

!

interface Vlan1

no ip address

!

interface Dialer0

ip unnumbered FastEthernet0

ip mtu 1470

encapsulation ppp

dialer pool 1

dialer-group 1

ppp authentication chap callin

ppp chap hostname XXX@XXX

ppp chap password 7 XXXXXXXXXX

!

interface Dialer1

ip address negotiated

ip nat outside

ip nat enable

encapsulation ppp

dialer pool 2

dialer idle-timeout 170

dialer string 0860XXXXXX

dialer-group 2

no keepalive

no cdp enable

ppp authentication chap callin

ppp chap hostname XXX@XXX

ppp chap password 7 XXXXXXXXXXXX

!

ip route 0.0.0.0 0.0.0.0 1.1.1.1

ip route 0.0.0.0 0.0.0.0 Dialer1 50

!

no ip http server

ip http timeout-policy idle 60 life 86400 requests 10000

ip nat inside source list 1 interface Dialer1 overload

!

access-list 1 permit XXXXXXXX 0.0.0.7

dialer-list 1 protocol ip permit

dialer-list 2 protocol ip permit

!

control-plane

!

banner login ^CAuthorized access only!

DIsconnect IMMEDIATELY if you are not an authorized user!^C

!

line con 0

login local

transport output telnet

line aux 0

login local

transport output telnet

line vty 0 4

privilege level 15

login local

transport input telnet

line vty 5 15

privilege level 15

login local

transport input telnet

!

end

2 REPLIES 2
smitesh kharecha
Contributor

Hi,

configure the following on your dialer associated with DSL

backup interface dialer (number of your dialer for ISDN)

HTH,

Smitesh

Hi,

Why don't you try to use IP SLA:

conf t

ip sla 1

icmp-echo 4.2.2.2

exit

ip sla schedule 1 life forever start-time now

track 123 rtr 1 reachability

ip route 4.2.2.2 255.255.255.255 Dialer0 (you have 1.1.1.1)

ip route 0.0.0.0 0.0.0.0 Dialer0 track 123

ip route 0.0.0.0 0.0.0.0 Dialer1 50

You would need to adjust/tweak NAT if these are going out to Internet.

Regards.