cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
589
Views
100
Helpful
47
Replies
Beginner

Re: WAN routing issues---need some help please!

The address with 172.20.10.5 is the address my hotspot was giving when I connected it to my computer via usb to keep internet access while testing.  Please note, that when performing any tests, I would disable that network adapter so it didnt' cause any issues.  I apologize for sending the screenshot with both on there, I had taken two, and the one I didn't save only had the ethernet adapter that had the cable from the router. 

 

So does that change your thoughts on this?

Highlighted
Beginner

Re: WAN routing issues---need some help please!

The address with 172.20.10.5 is the address my hotspot was giving when I connected it to my computer via usb to keep internet access while testing.  Please note, that when performing any tests, I would disable that network adapter so it didnt' cause any issues.  I apologize for sending the screenshot with both on there, I had taken two, and the one I didn't save only had the ethernet adapter that had the cable from the router. 

 

So does that change your thoughts on this?

Everyone's tags (1)
Beginner

Re: WAN routing issues---need some help please!

Here is a better capture of the info if it helps.

 

 

full dump.PNGAls

 

Also, here are the dumps of show ip int gig0/0 which I found interesting.....

 

Lab_2921#show ip int br
Interface IP-Address OK? Method Status Protocol
Embedded-Service-Engine0/0 unassigned YES unset administratively down down
GigabitEthernet0/0 69.180.36.8 YES DHCP up up
GigabitEthernet0/1 10.0.1.1 YES manual up up
GigabitEthernet0/2 unassigned YES unset administratively down down
NVI0 unassigned YES unset up up
Lab_2921#show ip int gig0/0
GigabitEthernet0/0 is up, line protocol is up
Internet address is 69.180.36.8/23
Broadcast address is 255.255.255.255
Address determined by DHCP
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is disabled
IP Null turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
IP route-cache flags are No CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, NAT Outside, MCI Check
Output features: Post-routing NAT Outside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled

Hall of Fame Master

Re: WAN routing issues---need some help please!

Thanks for the explanation about the second IP address. When I first saw that output I suspected that the second address might be part of the problem. But as I looked further I found a problem on your 10.0.1.2 interface and thought that the second IP address did not cause your problem.

 

The fundamental issue is that your PC does not have a default gateway. It can communicate with things that are on the same subnet but is not able to communicate with things that are on remote subnets. Go back to the configuration of your router and put the default router parameter into your DHCP scope and then test again.

 

You comment that you found the output of show ip int gig0/0 interesting. What did you find interesting in it?

 

HTH

 

Rick

Beginner

Re: WAN routing issues---need some help please!

So I totally agree about the PC not picking up a default gateway, but I'm not sure how to get it to do so.  I've added a default-gateway to int gig0/1 as well as adding it to my DHCP pool, but as you can see it's still not picking it up....am I missing how to do so?  Here is the output of the PC as well as the show run and show ip int.  


I feel like we are really close, but just need to close this out.  Thank you again so so much for your help! 

 

PC Status.PNGh

 

Lab_2921>show run
^
% Invalid input detected at '^' marker.

Lab_2921>ena
Lab_2921#show run
Building configuration...

Current configuration : 1971 bytes
!
! Last configuration change at 09:02:51 EST Thu Mar 28 2019 by davidstriplin
! NVRAM config last updated at 08:32:13 EST Thu Mar 28 2019 by davidstriplin
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_2921
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.1.170
ip dhcp excluded-address 10.0.1.100 10.0.1.254
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool Inside DHCP
network 10.0.1.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
!
!
ip dhcp class any
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1728AHR1
!
!
username davidstriplin secret 5 $1$j5Ka$6u.mf3wInjRpFMZ2PRLxY.
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Facing The ISP (WAN)
ip address dhcp
ip nat outside
ip virtual-reassembly in
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Facing The LAN (LAN)
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 10.0.1.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
!
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
!
control-plane
!
!
vstack
!
line con 0
logout-warning 120
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input none
!
scheduler allocate 20000 1000
!
end

 

Lab_2921>show ip dhcp pool

Pool Inside DHCP :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 1
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
10.0.1.3 10.0.1.1 - 10.0.1.254 1
Lab_2921>show ip int gig0/1
GigabitEthernet0/1 is up, line protocol is up
Internet address is 10.0.1.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain inside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, MCI Check
Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled

Hall of Fame Master

Re: WAN routing issues---need some help please!

In the DHCP pool in your router config add the statement default-router 10.0.1.1

If you look at some of the early posts in this discussion you will find it there. Somewhere along the line it was removed. Now you need to put it back.

 

HTH

 

Rick

Beginner

Re: WAN routing issues---need some help please!

And we are good to go!  I am currently writing this using the configuration that you helped me create and I'm browsing on the internet through the Cisco router hooked directly to my PC!!!!!!!!  

 

Seriously, I want to sincerely thank you for taking time out of your day and helping me so much, it is greatly appreciated!  

 

Just for grins....here is the current show run and show ip int so you can see if everything else looks good.

 

Lab_2921#show ip int br
Interface IP-Address OK? Method Status Protocol
Embedded-Service-Engine0/0 unassigned YES unset administratively down down
GigabitEthernet0/0 69.180.36.8 YES DHCP up up
GigabitEthernet0/1 10.0.1.1 YES manual up up
GigabitEthernet0/2 unassigned YES unset administratively down down
NVI0 unassigned YES unset up up
Lab_2921#show ip int
Embedded-Service-Engine0/0 is administratively down, line protocol is down
Internet protocol processing disabled
GigabitEthernet0/0 is up, line protocol is up
Internet address is 69.180.36.8/23
Broadcast address is 255.255.255.255
Address determined by DHCP
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is disabled
IP Null turbo vector
IP multicast fast switching is disabled
IP multicast distributed fast switching is disabled
IP route-cache flags are No CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, NAT Outside, MCI Check
Output features: Post-routing NAT Outside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
GigabitEthernet0/1 is up, line protocol is up
Internet address is 10.0.1.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain inside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, MCI Check
Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
GigabitEthernet0/2 is administratively down, line protocol is down
Internet protocol processing disabled
NVI0 is up, line protocol is up
Internet address will be negotiated using IPCP
Broadcast address is 255.255.255.255
MTU is 1514 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is disabled
IP Null turbo vector
IP Null turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
BGP Policy Mapping is disabled
Input features: MCI Check
Output features: Post-routing NAT NVI Output
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
Lab_2921#
Lab_2921#show run
Building configuration...

Current configuration : 1993 bytes
!
! Last configuration change at 09:33:53 EST Thu Mar 28 2019 by davidstriplin
! NVRAM config last updated at 09:26:26 EST Thu Mar 28 2019 by davidstriplin
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_2921
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.1.170
ip dhcp excluded-address 10.0.1.100 10.0.1.254
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool Inside DHCP
network 10.0.1.0 255.255.255.0
dns-server 75.75.75.75 75.75.76.76
!
!
ip dhcp class any
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1728AHR1
!
!
username davidstriplin secret 5 $1$j5Ka$6u.mf3wInjRpFMZ2PRLxY.
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Facing The ISP (WAN)
ip address dhcp
ip nat outside
ip virtual-reassembly in
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Facing The LAN (LAN)
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 10.0.1.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
!
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
!
control-plane
!
!
vstack
!
line con 0
logout-warning 120
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input none
!
scheduler allocate 20000 1000
!
end

PC status_working.PNGipconfig_working.PNG

 

 

 

Hall of Fame Master

Re: WAN routing issues---need some help please!

You are quite welcome. I am glad that our suggestions have been helpful. It has been a group effort and I am happy that it now is working for you successfully. Thank you for marking this question as solved. This will help other participants in the community to identify discussions which have helpful information. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

 

In looking at the config that you posted and the interface information I notice a couple of things. First and most important is that I do not see the default-router command in the DHCP scope. It must have been there because the ipconfig does have a default gateway. But I do not see it in the running config that you posted and that is concerning.

 

Also I notice that interface Gig0/0 has fast switching and cef switching disabled. This is because of the command no ip route-cache  that is configured on the interface. It is not a big deal but I would suggest that you enable them this way 

interface gig0/0

ip route-cache

end

Otherwise I believe that you are good to go.

 

HTH

 

Rick

 

Beginner

Re: WAN routing issues---need some help please!

Rick,

 

Done as requested.  Here is the output of show run to confirm.

 

Lab_2921#show dhcp pool InsideDHCP
^
% Invalid input detected at '^' marker.

Lab_2921#show ip dhcp pool

Pool Inside DHCP :
Utilization mark (high/low) : 100 / 0
Subnet size (first/next) : 0 / 0
Total addresses : 254
Leased addresses : 9
Pending event : none
1 subnet is currently in the pool :
Current index IP address range Leased addresses
10.0.1.19 10.0.1.1 - 10.0.1.254 9
Lab_2921#
Lab_2921#
Lab_2921#show ip int
Embedded-Service-Engine0/0 is administratively down, line protocol is down
Internet protocol processing disabled
GigabitEthernet0/0 is up, line protocol is up
Internet address is 69.180.36.8/23
Broadcast address is 255.255.255.255
Address determined by DHCP
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is disabled
IP Null turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, No CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, NAT Outside, MCI Check
Output features: Post-routing NAT Outside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
GigabitEthernet0/1 is up, line protocol is up
Internet address is 10.0.1.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain inside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, MCI Check
Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
GigabitEthernet0/2 is administratively down, line protocol is down
Internet protocol processing disabled
NVI0 is up, line protocol is up
Internet address will be negotiated using IPCP
Broadcast address is 255.255.255.255
MTU is 1514 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is disabled
IP Null turbo vector
IP Null turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
BGP Policy Mapping is disabled
Input features: MCI Check
Output features: Post-routing NAT NVI Output
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled

 

Lab_2921(config)#int gig0/0
Lab_2921(config-if)#ip route-cache
Lab_2921(config-if)#exit
Lab_2921(config)#exit
Lab_2921#cop
Mar 28 15:30:59.779: %SYS-5-CONFIG_I: Configured from console by davidstriplin o n console
Lab_2921#copy run
Lab_2921#copy running-config st
Lab_2921#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Lab_2921#co
Lab_2921#cop
Lab_2921#copy ru
Lab_2921#copy running-config tftp
Address or name of remote host []? Lab 2921 Config_WORKING_ 3-28-2019
?Invalid host address or name
%Error parsing filename (Invalid IP address or hostname)
Lab_2921#copy running-config tftp
Address or name of remote host []? 10.0.1.3
Destination filename [lab_2921-confg]? Lab 2921 Config_WORKING_ 3-28-2019
!!
1996 bytes copied in 0.256 secs (7797 bytes/sec)

Lab_2921#copy
Lab_2921#copy r
Lab_2921#copy ru
Lab_2921#copy running-config st
Lab_2921#copy running-config startup-config
Destination filename [startup-config]?
Building configuration...
[OK]
Lab_2921#show run
Building configuration...

Current configuration : 1996 bytes
!
! Last configuration change at 10:30:59 EST Thu Mar 28 2019 by davidstriplin
! NVRAM config last updated at 10:32:53 EST Thu Mar 28 2019 by davidstriplin
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_2921
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.1.170
ip dhcp excluded-address 10.0.1.100 10.0.1.254
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool Inside DHCP
network 10.0.1.0 255.255.255.0
dns-server 75.75.75.75 75.75.76.76
!
!
ip dhcp class any
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1728AHR1
!
!
username davidstriplin secret 5 $1$j5Ka$6u.mf3wInjRpFMZ2PRLxY.
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Facing The ISP (WAN)
ip address dhcp
ip nat outside
ip virtual-reassembly in
no ip route-cache cef
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Facing The LAN (LAN)
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 10.0.1.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
!
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
!
control-plane
!
!
vstack
!
line con 0
logout-warning 120
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

Hall of Fame Master

Re: WAN routing issues---need some help please!

We made some progress but are not quite there yet. Please add these commands to the config 

ip dhcp pool Inside DHCP

default-router 10.0.1.1

interface gig0/0

ip route-cache cef

 

HTH

 

Rick

Beginner

Re: WAN routing issues---need some help please!

Rick,

 

Thanks again....you helped another issue that I wasn't going to bother you with but it also allowed my wireless clients to start connecting when I plugged my AP in!

 

Here is the output of show run an show ip int

Lab_2921#show run
Building configuration...


Current configuration : 2018 bytes
!
! Last configuration change at 12:36:32 EST Thu Mar 28 2019 by davidstriplin
! NVRAM config last updated at 12:36:39 EST Thu Mar 28 2019 by davidstriplin
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_2921
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
clock timezone EST -5 0
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.1.170
ip dhcp excluded-address 10.0.1.100 10.0.1.254
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool Inside DHCP
network 10.0.1.0 255.255.255.0
dns-server 75.75.75.75 75.75.76.76
default-router 10.0.1.1
!
!
ip dhcp class any
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1728AHR1
!
!
username davidstriplin secret 5 $1$j5Ka$6u.mf3wInjRpFMZ2PRLxY.
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Facing The ISP (WAN)
ip address dhcp
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Facing The LAN (LAN)
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip default-gateway 10.0.1.1
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip dns server
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
ip ssh time-out 60
!
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
!
control-plane
!
!
vstack
!
line con 0
logout-warning 120
login local
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login local
transport input ssh
!
scheduler allocate 20000 1000
!
end

 

Lab_2921#show ip int
Embedded-Service-Engine0/0 is administratively down, line protocol is down
Internet protocol processing disabled
GigabitEthernet0/0 is up, line protocol is up
Internet address is 69.180.36.8/23
Broadcast address is 255.255.255.255
Address determined by DHCP
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain outside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, NAT Outside, MCI Check
Output features: Post-routing NAT Outside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
GigabitEthernet0/1 is up, line protocol is up
Internet address is 10.0.1.1/24
Broadcast address is 255.255.255.255
Address determined by setup command
MTU is 1500 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is enabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is enabled
IP CEF switching turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is enabled, interface in domain inside
BGP Policy Mapping is disabled
Input features: Common Flow Table, Stateful Inspection, Virtual Fragment Reassembly, Virtual Fragment Reassembly After IPSec Decryption, MCI Check
Output features: NAT Inside, Common Flow Table, Stateful Inspection, NAT ALG proxy
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled
GigabitEthernet0/2 is administratively down, line protocol is down
Internet protocol processing disabled
NVI0 is up, line protocol is up
Internet address will be negotiated using IPCP
Broadcast address is 255.255.255.255
MTU is 1514 bytes
Helper address is not set
Directed broadcast forwarding is disabled
Outgoing access list is not set
Inbound access list is not set
Proxy ARP is enabled
Local Proxy ARP is disabled
Security level is default
Split horizon is enabled
ICMP redirects are always sent
ICMP unreachables are always sent
ICMP mask replies are never sent
IP fast switching is disabled
IP fast switching on the same interface is disabled
IP Flow switching is disabled
IP CEF switching is disabled
IP Null turbo vector
IP Null turbo vector
IP multicast fast switching is enabled
IP multicast distributed fast switching is disabled
IP route-cache flags are Fast, CEF
Router Discovery is disabled
IP output packet accounting is disabled
IP access violation accounting is disabled
TCP/IP header compression is disabled
RTP/IP header compression is disabled
Policy routing is disabled
Network address translation is disabled
BGP Policy Mapping is disabled
Input features: MCI Check
Output features: Post-routing NAT NVI Output
IPv4 WCCP Redirect outbound is disabled
IPv4 WCCP Redirect inbound is disabled
IPv4 WCCP Redirect exclude is disabled

Hall of Fame Master

Re: WAN routing issues---need some help please!

It is looking good to me. I think now you are good to go.

 

HTH

 

Rick

Beginner

Re: WAN routing issues---need some help please!

Rick, thanks again, I appreciate everything.

 

Thanks,

Dave

VIP Advocate

Re: WAN routing issues---need some help please!

Hi,

Please add default Gateway on your system.

 

Regards,

Deepak Kumar

Regards,
Deepak Kumar,
Don't forget to vote and accept the solution If this comment will make help you!
Beginner

Re: WAN routing issues---need some help please!

Hi,

 

Thank you so much for helping.  I've made the changes as requested, but still no internet access.  BTW, when I say internet access, I'm talking about web browsing on Chrome, not trying to ping another address if that makes a difference to you at all.  Here are the outputs of show run, show arp. 

 

PC Address - 10.0.1.3

GW - 10.0.1.1

DNS 8.8.8.8 8.8.4.4

Lab_2921#show arp
Protocol Address Age (min) Hardware Addr Type Interface
Internet 10.0.1.1 - f872.ea8c.0ed1 ARPA GigabitEthernet0/1

 

Lab_2921#show run
Building configuration...

Current configuration : 1919 bytes
!
! Last configuration change at 14:31:03 UTC Wed Mar 27 2019
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Lab_2921
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
ip dhcp excluded-address 10.0.1.170
ip dhcp excluded-address 10.0.1.100 10.0.1.254
ip dhcp excluded-address 10.0.1.1
!
ip dhcp pool InsideDHCP
import all
network 10.0.0.0 255.0.0.0
default-router 10.0.1.1
dns-server 8.8.8.8 8.8.4.4
class any
!
ip dhcp pool Inside DHCP
network 10.0.1.0 255.255.255.0
!
!
ip dhcp class any
!
!
no ip domain lookup
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1728AHR1
!
!
username davidstriplin secret 5 $1$j5Ka$6u.mf3wInjRpFMZ2PRLxY.
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
description Facing The ISP (WAN)
ip address dhcp
ip nat outside
ip virtual-reassembly in
no ip route-cache
duplex auto
speed auto
!
interface GigabitEthernet0/1
description Facing The LAN (LAN)
ip address 10.0.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
duplex auto
speed auto
!
interface GigabitEthernet0/2
no ip address
shutdown
duplex auto
speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface GigabitEthernet0/0 overload
ip route 0.0.0.0 0.0.0.0 dhcp
ip route 0.0.0.0 0.0.0.0 GigabitEthernet0/0 dhcp
!
!
!
access-list 1 permit 10.0.1.0 0.0.0.255
access-list 102 permit ip 10.0.1.0 0.0.0.255 any
!
control-plane
!
!
vstack
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

CreatePlease to create content
Content for Community-Ad
July's Community Spotlight Awards