cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
263
Views
20
Helpful
10
Replies
hfakoor222
Participant

Why is router not routing traffic generator traffic?

R1 is not routing the packets with destination 172.16.23.x which is subnet for R3

No packets are going past R1

 

Only policy applied to outbound interface is DSCP marking policy, and so I am not sure why it is not routing traffic beyond R1

 

 

Topology

 

3.png

 

 

Ipv4 header

 

Picture 1.png

 

 

 

From Switch ALS1 to R1 the Wireshark output

2.png

 

 

There doesn't seem to be IPV4 header

2.png

 

 

here is packet view from traffic generator showing dest 172.16.23.3

2.png

R1 is no routing packets

 

Can someone help me fix this

 

Here's output R1 run

 


Current configuration : 2000 bytes
!
! Last configuration change at 06:41:17 EST Fri May 27 2022
! NVRAM config last updated at 04:49:25 EST Fri May 27 2022
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone EST -5
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
class-map match-any critical
match protocol eigrp
match protocol ntp
class-map match-any interactive
match protocol telnet
match protocol ssh
match protocol xwindows
class-map match-any web
match protocol http
match protocol pop3
match protocol netbios
!
!
policy-map Marking
class interactive
set precedence 5
class critical
set precedence 5
class web
set precedence 3
class class-default
set precedence 1
!
!
!
!
!
interface FastEthernet0/0
ip address 172.16.10.1 255.255.255.0
ip nbar protocol-discovery
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
ip address 172.16.12.1 255.255.255.0
serial restart-delay 0
clock rate 79841
service-policy output Marking
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 172.16.12.2
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
ntp logging
ntp master
ntp server 172.16.10.1
end

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Harold Ritter
Cisco Employee

Hi @hfakoor222 ,

 

The issue seems to be at the origin. There's a few things wrong with the generated IP packets. 

 

- The destination MAC address (08:00:00:00:00:00:00)

- The ether type (00c1). It should be 0800 for IPv4.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

10 REPLIES 10
Flavio Miranda
Advisor

Hi

 I dont think problem is in R1 as it has default route to R2.

ip route 0.0.0.0 0.0.0.0 172.16.12.2

 The problem can be in R2 or in the link between R1 and R2. I saw this is a serial link but I did not see you using any encapsulation on the interface.

 

 

Hmm why would encapsulation be important here?

 

 

after encapsulation of hdcl on each s1/3 interface of R2 and R1 the output from wireshark is showing no traffic

 

2.png3.png

Btw here is run for R2

#sh run
Building configuration...

Current configuration : 1850 bytes
!
! Last configuration change at 04:46:57 EST Fri May 27 2022
! NVRAM config last updated at 04:49:21 EST Fri May 27 2022
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
clock timezone EST -5
ip source-route
no ip icmp rate-limit unreachable
ip cef
!
!
!
!
no ip domain lookup
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
ip tcp synwait-time 5
!
class-map match-any prec5
match precedence 5
match protocol eigrp
class-map match-all prec0
class-map match-all prec1
match precedence 1
class-map match-all prec3
!
!
policy-map llqpolicy
class prec5
priority percent 15
class prec3
bandwidth percent 30
class prec1
bandwidth percent 20
class class-default
fair-queue
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface Serial1/0
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
ip address 172.16.23.2 255.255.255.0
serial restart-delay 0
clock rate 128000
service-policy output llqpolicy
!
interface Serial1/3
ip address 172.16.12.2 255.255.255.0
serial restart-delay 0
clock rate 79841
!
router eigrp 1
network 172.16.0.0
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
no cdp log mismatch duplex
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line aux 0
exec-timeout 0 0
privilege level 15
logging synchronous
stopbits 1
line vty 0 4
login
!
ntp server 172.16.10.1


Well, probably it is using HDLC by default but I preffer enable PPP. Anyway, on router 2, do you have a route send to R1?

 

R2:

ip route 172.16.10.0 255.255.255.0 172.16.12.1

 

ip route 172.16.10.0 255.255.255.0 172.16.12.1

 

 

did you mean to type   172.16.12.1 255.255.255.0 172.16.12.1?

 

 

It seem the f0/0 interface is not receiving extra packets when I run the traffic generator

 

2.png

 

 

2.png

You are trying to send traffc to network 172.16.23.x from 172.16.10.x, correct?

 

What about the routing in R2?

 

 

Inked3_LI.jpg

I see what you are saying now, thank you that is good advice for next time

Harold Ritter
Cisco Employee

Hi @hfakoor222 ,

 

The issue seems to be at the origin. There's a few things wrong with the generated IP packets. 

 

- The destination MAC address (08:00:00:00:00:00:00)

- The ether type (00c1). It should be 0800 for IPv4.

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

now that I think of it I put R3 mac as dest mac address and not R1

After changing mac address from R3 to R1 Dest traffic is now being routed, and i can focus on my QOS labbing.

Thank you very much Harold i appreciate it

David Ruess
Enthusiast

Hello,

 

It looks like your running EIGRP.

 

2 things.

 

Have all 3 routers formed a neighorship?

Can you provide the output of

show ip route

on all routers?

 

You can also try running a ping from R1 F0/0 interface to R3 network. If it reaches then you have basic connectivity. This could point to an issue between your R1 F0/0 interface and traffic generator. If this is a simulator then it could just be buggy.

 

-David