cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
440
Views
0
Helpful
0
Replies
Highlighted

WRED possible on the C4900m?

Is it possible to enable WRED on a c4900M, with CBWFW or directy on a interface?

I have tried but cant see thats the random-detect command as a configurable option. The point is that I want to avoid tail-drop which can lead to TCP global sync.

Topology:

2x  c4900M, each  with the module WS-X4920-GB-RJ45 20 port 10/100/1000 RJ45. Its a 100mbit link between them. IOS is 12254SG ENTERPRISE SERVICES

The present configuration where I am not able to enable WRED with random-detect:

class-map match-all All_IP
  match access-group 103
class-map match-all NetApp_replikeringstrafikk
  match access-group 101
class-map match-all default
class-map match-all FTP_trafikk
  match access-group 102
!
policy-map WAN_Policy
class NetApp_replikeringstrafikk
    bandwidth percent 20
class FTP_trafikk
    bandwidth percent 2
class All_IP
    bandwidth percent 53
class class-default
    bandwidth percent 25

!

access-list 101 permit tcp host 172.17.3.20 host 172.16.3.20 range 10565 10569
access-list 102 permit tcp any any eq ftp-data
access-list 102 permit tcp any any eq ftp
access-list 103 permit ip any any

!

interface GigabitEthernet2/20
  switchport access vlan 414
switchport mode access
bandwidth 130000
service-policy output WAN_Policy

As a alternativ to avoid tail drop, I wrote this shaping config (which I have not had the possiblity to apply and test yet)

policy-map WAN_Policy
class NetApp_replikeringstrafikk
    shape average 20480                       
class FTP_trafikk
    shape average 2048                           
class All_IP
    shape average 54272                
class class-default
    bandwidth 25600                        

All comments are greatly appreciated!

0 REPLIES 0
This widget could not be displayed.